N900 Media Player/MediaBox

Discuss alternative media renderers (not PS3) supported by PS3 Media Server (e.g. Xbox 360, TVs &c.)

N900 Media Player/MediaBox

Postby qiet72 » Sun Aug 29, 2010 4:49 pm

Hi,

Has anyone got transcoding to work with MediaBox on the Nokia N900 Smartphone? The Nokia N900 comes with Media player which is supposed to detect DLNA servers on the net. Unfortunetly, I have only been able to get it to see Vuze (Azureus). You can also install via the repositories, MediaBox, which is supposed to have more features. MediaBox seems to work a lot better with PMS. It can see, browse, and stream videos via PMS, but videos that need transcoding, just breaks on PMS. I have tested PMS with my XBOX360, XBOX, and PS3 and it works perfectly with transcoding.

I don't know if it is because it has a short timeout. I have tried to make my own config file (renderers/n900.conf) using PS3.conf as a template. I managed to get PMS recognise MediaBox as a renderer, but transcoding is still not working as it should. I have tried the setting TranscodeFastStart=true , but that didn't help either.

Any suggestions?

P.S.: I am using the latest firmware PR1.2.

qiet72
qiet72
 
Posts: 3
Joined: Sun Aug 29, 2010 4:41 pm

Re: N900 Media Player/MediaBox

Postby qiet72 » Sun Aug 29, 2010 5:15 pm

Hi,

More info: I am using the latest beta version of PMS: 1.20.409

Here is the section of debug.log where it fails:
[Thread-44] DEBUG 17:17:51.220 MEncoder SVN-r1.0~rc3+svn20090426-4.4.3 (C) 2000-2009 MPlayer Team
[Thread-41] DEBUG 17:17:51.220 Using SSE optimized IMDCT transform
[Thread-41] DEBUG 17:17:51.221 Using MMX optimized resampler
[Thread-41] DEBUG 17:17:51.221 ** MUXER_LAVF *****************************************************************
[Thread-44] DEBUG 17:17:51.221 success: format: 0 data: 0x0 - 0x5beb0b3c
[Thread-41] DEBUG 17:17:51.221 REMEMBER: MEncoder's libavformat muxing is presently broken and can generate
[Thread-44] DEBUG 17:17:51.221 [mkv] Track ID 1: video (V_MPEG4/ISO/AVC), -vid 0
[Thread-41] DEBUG 17:17:51.221 INCORRECT files in the presence of B-frames. Moreover, due to bugs MPlayer
[Thread-44] DEBUG 17:17:51.221 [mkv] Track ID 2: audio (A_AC3), -aid 0, -alang eng
[Thread-41] DEBUG 17:17:51.222 will play these INCORRECT files as if nothing were wrong!
[Thread-44] DEBUG 17:17:51.222 [mkv] Track ID 3: subtitles (S_TEXT/ASS), -sid 0, -slang eng
[Thread-41] DEBUG 17:17:51.222 *******************************************************************************
[Thread-41] DEBUG 17:17:51.222 [h264 @ 0x1df16b0]Cannot parallelize deblocking type 1, decoding such frames in sequential order
[Thread-44] DEBUG 17:17:51.222 [mkv] Will play video track 1.
[Thread-44] DEBUG 17:17:51.222 Matroska file format detected.
[Thread-44] DEBUG 17:17:51.222 VIDEO: [avc1] 1280x720 24bpp 23.976 fps 0.0 kbps ( 0.0 kbyte/s)
[Thread-44] DEBUG 17:17:51.222 [V] filefmt:31 fourcc:0x31637661 size:1280x720 fps:23.976 ftime:=0.0417
[Thread-44] DEBUG 17:17:51.222 ==========================================================================
[Thread-44] DEBUG 17:17:51.222 Opening audio decoder: [liba52] AC3 decoding with liba52
[Thread-44] DEBUG 17:17:51.222 AUDIO: 48000 Hz, 2 ch, s16le, 224.0 kbit/14.58% (ratio: 28000->192000)
[Thread-44] DEBUG 17:17:51.222 Selected audio codec: [a52] afm: liba52 (AC3-liba52)
[Thread-44] DEBUG 17:17:51.222 ==========================================================================
[Thread-44] DEBUG 17:17:51.222 OK, exit.
[Thread-44] DEBUG 17:17:51.222 Opening video filter: [expand osd=1]
[Thread-44] DEBUG 17:17:51.222 Expand: -1 x -1, -1 ; -1, osd: 1, aspect: 0.000000, round: 1
[Thread-44] DEBUG 17:17:51.222 ==========================================================================
[Thread-44] DEBUG 17:17:51.222 Opening video decoder: [ffmpeg] FFmpeg's libavcodec codec family
[Thread-44] DEBUG 17:17:51.222 Selected video codec: [ffh264] vfm: ffmpeg (FFmpeg H.264)
[Thread-44] DEBUG 17:17:51.222 ==========================================================================
[Thread-44] DEBUG 17:17:51.225 VDec: vo config request - 1280 x 720 (preferred colorspace: Planar YV12)
[Thread-44] DEBUG 17:17:51.225 VDec: using Planar YV12 as output csp (no 0)
[Thread-44] DEBUG 17:17:51.225 Movie-Aspect is 1.78:1 - prescaling to correct movie aspect.
[Thread-44] DEBUG 17:17:51.225 videocodec: libavcodec (1280x720 fourcc=32564d57 [WMV2])
[Thread-44] DEBUG 17:17:51.225 [VE_LAVC] Using constant qscale = 1.000000 (VBR).
[Thread-41] DEBUG 17:17:51.231 New_Face failed. Maybe the font path is wrong.
[Thread-41] DEBUG 17:17:51.231 Please supply the text font file (~/.mplayer/subfont.ttf).
[Thread-41] DEBUG 17:17:51.231 subtitle font: load_sub_face failed.
[Thread-44] DEBUG 17:17:51.241 VIDEO CODEC ID: 19
[Thread-41] DEBUG 17:17:51.241 [asf @ 0x1de02d0]Codec for stream 0 does not use global headers but container format requires global headers
[Thread-44] DEBUG 17:17:51.241 AUDIO CODEC ID: 15008, TAG: 0
[Thread-41] DEBUG 17:17:51.241 [asf @ 0x1de02d0]Codec for stream 1 does not use global headers but container format requires global headers
[Thread-44] DEBUG 17:17:51.241 Writing header...
[Timer-2] DEBUG 17:17:53.220 Buffered Space: 2214999 bytes / inputs: 0
[Timer-2] DEBUG 17:17:55.220 Buffered Space: 6746199 bytes / inputs: 0
[Timer-2] DEBUG 17:17:57.221 Buffered Space: 9971799 bytes / inputs: 0
[New I/O server worker #1-1] DEBUG 17:17:57.265 Suspend Read: readCount=0 / writeCount=10032599
[Timer-2] DEBUG 17:17:59.221 Buffered Space: 12595799 bytes / inputs: 1
[New I/O server worker #1-1] DEBUG 17:17:59.265 Resume Read: readCount=0 / writeCount=12627799
[New I/O server worker #1-1] DEBUG 17:17:59.268 Sent to socket: Accept-Ranges: bytes
[New I/O server worker #1-1] DEBUG 17:17:59.269 Sent to socket: Connection: keep-alive
[New I/O server worker #1-1] DEBUG 17:17:59.269 Sent to socket: Content-Type: video/x-ms-wmv
[New I/O server worker #1-1] DEBUG 17:17:59.269 Sent to socket: Server: Linux-amd64-2.6.32-24-generic, UPnP/1.0, PMS/1.20.409
[New I/O server worker #1-1] DEBUG 17:17:59.337 Ready to Stop: true
[New I/O server worker #1-2] DEBUG 17:17:59.813 Opened handler on socket /10.0.0.111:56729 // N900 MediaBox
[New I/O server worker #1-2] DEBUG 17:17:59.813 Handler infos: HTTP/1.1 : GET : get/0$1$10/9+%28Nine%29+2009+720p+BluRay+nHD+x264+NhaNc3.mkv
[New I/O server worker #1-2] DEBUG 17:17:59.813 Received on socket: Connection: close
[New I/O server worker #1-2] DEBUG 17:17:59.813 Received on socket: Host: 10.0.0.102:5001
[New I/O server worker #1-2] DEBUG 17:17:59.813 Received on socket: icy-metadata: 1
[New I/O server worker #1-2] DEBUG 17:17:59.813 Received on socket: transferMode.dlna.org: Streaming
[New I/O server worker #1-2] DEBUG 17:17:59.813 Received on socket: User-Agent: GStreamer souphttpsrc libsoup/2.26.3
[New I/O server worker #1-2] INFO 17:17:59.813 HTTP: get/0$1$10/9+%28Nine%29+2009+720p+BluRay+nHD+x264+NhaNc3.mkv / 0-0
[New I/O server worker #1-2] DEBUG 17:17:59.813 Searching for objectId: 0$1$10 with children option: false
[New I/O server worker #1-2] DEBUG 17:17:59.813 Asked stream chunk [0-0] timeseek: 0.0 of 9 (Nine) 2009 720p BluRay nHD x264 NhaNc3.mkv and player MEncoder
[New I/O server worker #1-2] DEBUG 17:17:59.814 Ready to Stop: false
[New I/O server worker #1-2] DEBUG 17:17:59.817 Sent to socket: Accept-Ranges: bytes
[New I/O server worker #1-2] DEBUG 17:17:59.817 Sent to socket: Connection: keep-alive
[New I/O server worker #1-2] DEBUG 17:17:59.817 Sent to socket: Content-Type: video/x-ms-wmv
[New I/O server worker #1-2] DEBUG 17:17:59.817 Sent to socket: Server: Linux-amd64-2.6.32-24-generic, UPnP/1.0, PMS/1.20.409
[New I/O server worker #1-2] DEBUG 17:17:59.817 Sent to socket: TransferMode.DLNA.ORG: Streaming
[Thread-10] DEBUG 17:17:59.975 Receiving a M-SEARCH from [10.0.0.111:60420]
[Thread-10] DEBUG 17:18:00.517 Receiving a M-SEARCH from [10.0.0.111:60420]
[Thread-10] DEBUG 17:18:01.054 Receiving a M-SEARCH from [10.0.0.111:60420]
[Timer-2] DEBUG 17:18:01.222 Buffered Space: 14606294 bytes / inputs: 1
[Timer-2] DEBUG 17:18:03.221 Buffered Space: 16916054 bytes / inputs: 1
[New I/O server worker #1-2] DEBUG 17:18:03.812 Ready to Stop: true
[Timer-2] DEBUG 17:18:05.221 Buffered Space: 19770199 bytes / inputs: 0
[Thread-47] INFO 17:18:06.312 Stopping process: mencoder
[Thread-47] DEBUG 17:18:06.312 Killing the Unix process: 1366
[Thread-48] INFO 17:18:06.313 Destroying buffer
[mencoder] DEBUG 17:18:06.643 EOF


qiet72
qiet72
 
Posts: 3
Joined: Sun Aug 29, 2010 4:41 pm

Re: N900 Media Player/MediaBox

Postby dan_lotfy » Sun Sep 19, 2010 11:13 am

Hi,
I'm using PS3MS with my N900 with no issues, able to view my media files, play most of them; except for MKV and MP4 files "not sure for the reason", as well as mp3 playback. the only thing is, you have to wait few seconds till N900 detects PS3MS, after that there's a reasonable lag to refresh folder contents each time you log to a new one. wish that is helpful.
dan_lotfy
 
Posts: 5
Joined: Tue Dec 01, 2009 1:52 pm

Re: N900 Media Player/MediaBox

Postby qiet72 » Sun Sep 19, 2010 11:16 am

Hi,

The default media player in my N900 suddenly was able to see PMS one day. Don't know why it couldn't before but it works although not smoothly

qiet72
qiet72
 
Posts: 3
Joined: Sun Aug 29, 2010 4:41 pm

Re: N900 Media Player/MediaBox

Postby dan_lotfy » Tue Sep 21, 2010 11:33 am

Well, not sure what's wrong in this case, but for me I have a Linksys wireless router with UPnp enabled, can you check the router config? also I have to say that Wifi load onthe router affects the connectivity level, and thus the N900 local player buffering status.
dan_lotfy
 
Posts: 5
Joined: Tue Dec 01, 2009 1:52 pm


Return to Alternative Media Renderers

Who is online

Users browsing this forum: No registered users and 1 guest