Sony Bravia 5500 Series not playing MKV

Discuss alternative media renderers (not PS3) supported by PS3 Media Server (e.g. Xbox 360, TVs &c.)

Sony Bravia 5500 Series not playing MKV

Postby Fuzzyme » Sun Jun 13, 2010 1:50 am

I am new to PS3mediaserver and I am trying to get MKV files playing on my sony TV with no luck PS3mediaserver. It will pla AVI files but not MKV. I have the latest beta version of Ps3mediaserver. Any assistance with this would be greatly appreciated.

thanks
Fuzzyme
 
Posts: 4
Joined: Mon Mar 15, 2010 10:40 pm

Re: Sony Bravia 5500 Series not playing MKV

Postby taxexile » Mon Jun 14, 2010 12:10 am

Try putting tsmuxer as the first "video file engine"; or try streaming the clip, give it a few seconds and then return and then retry; please make sure u have a good wireless connection; i have 54Mbs and I am using about 10% of this, so it you're able to maintain that about of bandwidth it should work; works fine for me on my 40ex503 here
taxexile
 
Posts: 2
Joined: Sun Jun 13, 2010 11:52 pm

Re: Sony Bravia 5500 Series not playing MKV

Postby Fuzzyme » Mon Jun 14, 2010 3:01 am

Hi,

I used tmuxer however, the screen is black when I play those files. I can hear sound but no video. My connections are hard wired.
Fuzzyme
 
Posts: 4
Joined: Mon Mar 15, 2010 10:40 pm

Re: Sony Bravia 5500 Series not playing MKV

Postby patters » Mon Jun 14, 2010 3:06 am

Fuzzyme wrote:Hi,

I used tmuxer however, the screen is black when I play those files. I can hear sound but no video. My connections are hard wired.


It's quite likely that the files are encoded in a non-compatible way, i.e. higher than H.264 High Profile Level 4.1 or with some encoder prefs set wrong.
Not many rips "out there" are compliant unfortunately. The same is true of the PS3 so read up about that - there's plenty of info available.
patters
 
Posts: 97
Joined: Sun Apr 11, 2010 12:06 pm

Re: Sony Bravia 5500 Series not playing MKV

Postby Fuzzyme » Mon Jun 14, 2010 3:26 am

Not sure what it is but the files work when the PS3 is the renderer, just not with the TV. I not sure if there is some other setting that I am missing.
Fuzzyme
 
Posts: 4
Joined: Mon Mar 15, 2010 10:40 pm

Re: Sony Bravia 5500 Series not playing MKV

Postby patters » Mon Jun 14, 2010 1:06 pm

There are MKVs I've downloaded that claim to be PS3 compatible which don't work on the Bravia, it seems to be a bit of a lottery. The H.264 rips that are prepared as 4GB m2ts files seem to be ok though.

EDIT - I think the problem is that the Bravia 5500 renderer is very picky about the video resolutions. So even if the profile is right, that's usually the issue with files that won't play.
Last edited by patters on Sun Aug 22, 2010 9:54 pm, edited 1 time in total.
patters
 
Posts: 97
Joined: Sun Apr 11, 2010 12:06 pm

Re: Sony Bravia 5500 Series not playing MKV

Postby armthehomeless » Wed Aug 11, 2010 1:01 pm

taxexile wrote:Try putting tsmuxer as the first "video file engine"; or try streaming the clip, give it a few seconds and then return and then retry; please make sure u have a good wireless connection; i have 54Mbs and I am using about 10% of this, so it you're able to maintain that about of bandwidth it should work; works fine for me on my 40ex503 here


How do you tell it to stream instead of transcode?
armthehomeless
 
Posts: 23
Joined: Tue Feb 23, 2010 3:36 am

Re: Sony Bravia 5500 Series not playing MKV

Postby Lascar » Tue Nov 30, 2010 10:15 pm

It's not a lotery, Tsmuxer will not work properly with Bravia if the size of the Video is not standard.
Standard size are 1920x1080, 1280x720 or 720x480.
If your video is not at the right size you can use UncropMKV, which can resize it.
Lascar
 
Posts: 2
Joined: Wed Aug 05, 2009 5:22 pm

Re: Sony Bravia 5500 Series not playing MKV

Postby cotton » Sat Dec 11, 2010 2:22 am

Select Mencoder in the left hand pane of the the transcoder tab, then click on "Expert settings". In the bottom pane, I have:

vcodec == mpeg2 && srtfile == null :: -ovc copy -nosync
(width/height) >= 1.8 :: -vf expand=:::::16/9

On my 40W5500 Bravia, this plays (pretty much) everything I've chucked at it (superbly), including mkvs, avis & mp4s.
Had a slight sound sync problem with occasional 720p files which I'm still trying to resolve. Not CPU related though. Suspect a problem with the original encoding.
cotton
 
Posts: 4
Joined: Tue Jan 12, 2010 12:07 am

Re: Sony Bravia 5500 Series not playing MKV

Postby mazey » Sat Jan 22, 2011 2:19 pm

guys, me and tomeko have been working on a new bravia 5500.conf file can u guys help test it, it should play everything u throw at it. the only drawback is (due to bravia 5500 being so select when it comes to h264 content) that all h264 will be transcoded.. the advantages though is with mediainfo on now it wont keep trying to stream mpeg1 which isnt supported by the tv. it will also stop giving u blank screens so u dont have to exit out of the file/dir and then go back in with h264 content. u also dont need to set any custom settings, default is fine.

Code: Select all
# ps3mediaserver renderer profile for Sony Bravia 5500 series
# Refer to PS3.conf for help

RendererName=Sony Bravia 5500 Series
RendererIcon=bravia.png
UserAgentSearch=notusedhere
UserAgentAdditionalHeader=X-AV-Client-Info
UserAgentAdditionalHeaderSearch=(BRAVIA KDL.+5[0-9]{3})|(BRAVIA KDL.+WE5)|(BRAVIA KDL-[0-9]{2}XBR9)
Video=true
Audio=true
Image=true
SeekByTime=true
TranscodeVideo=MPEGAC3
TranscodeAudio=MP3
DefaultVBVBufSize=true
MuxH264ToMpegTS=true
MuxDTSToMpeg=false
WrapDTSIntoPCM=false
MuxLPCMToMpeg=false
MaxVideoBitrateMbps=0
MaxVideoWidth=0
MaxVideoHeight=0
H264Level41Limited=true
MimeTypesChanges=audio/wav=audio/L16|video/mp4=video/mpeg
DLNALocalizationRequired=true
TranscodeExtensions=dvr-ms,dvr,mkv,dv,ty,mov,ogm,hdmov,hdm,rmv,rmvb,rm,asf,evo,asx,flv,m2v,mpe,mod,tivo,ty,tmf,ts,tp,m2p,mp4,m4v,avi,wmv,wm,divx,div,flac,mlp,fla,wma,m4a,aac,dts,mka,ape,ogg,shn,mpc,ra,mp2,wv,oma,aa3,gif,png,arw,cr2,crw,dng,raf,mrw,nef,pef,tif,tiff
StreamExtensions=

MediaInfo=true
# temporary removed lpcm, and h264
#Supported = f:mpegps|mpegts    v:mpeg2|h264    a:ac3|lpcm|aac|mpa   m:video/mpeg
Supported = f:mpegps|mpegts    v:mpeg2    a:ac3|aac|mpa   m:video/mpeg
Supported = f:mp3   m:audio/mpeg
# Bravia can't play wav, only lpcm. PMS can't produce lpcm at this moment.
#Supported = f:wav   m:audio/L16
Supported = f:jpg   m:image/jpeg


the more ppl we get testing this the sooner it can be brought into the official build, feedback is appreciated.
PMS 1.90.2 Snapshot - Intel Celeron G1840 Dual 2.8Ghz / Asus Z97m-plus / Corsair Vengeance 8GB / Windows 8.1 Pro (64 bit)
mazey
 
Posts: 775
Joined: Sat Oct 24, 2009 9:07 am

Next

Return to Alternative Media Renderers

Who is online

Users browsing this forum: No registered users and 4 guests