Sony BDP-S370 (DLNA-compatible with new firmware M03.R.567)

Discuss alternative media renderers (not PS3) supported by PS3 Media Server (e.g. Xbox 360, TVs &c.)

Re: Sony BDP-S370 (DLNA-compatible with new firmware M03.R.5

Postby vitaumtb » Tue Jan 11, 2011 12:36 am

I downloaded the 410 v4 binary for BDP-S370 and its working nice here, but the fas-forward is not working, I' d like to know if the PMS 412 with this patch would fast-foward and if it does,
can someone upload a binary of the 412 with this patch.
thanks!
vitaumtb
 
Posts: 2
Joined: Tue Jan 11, 2011 12:32 am

Re: Sony BDP-S370 (DLNA-compatible with new firmware M03.R.5

Postby wg4ever » Tue Jan 11, 2011 10:31 pm

I tried Patter's executable on here and I see everything on the BDP-S470, but when I try to play something, mencoder crashes on the PC. I wish someone could please make a patched executable with all the latest workarounds for this. I have a 2 year old and unfortunately cant sit down and mess with source code and try doing it myself. I would sure appreciate it!
wg4ever
 
Posts: 1
Joined: Tue Jan 11, 2011 10:18 pm

Re: Sony BDP-S370 (DLNA-compatible with new firmware M03.R.5

Postby harryballzonya » Fri Jan 14, 2011 2:21 pm

RE: Mencoder crashing
I had a similar problem and traced it back to avi container xvid clips with ac3 audio. The ac3audio was the culprit in my case. Google and download "mediainfo" (if you don't already have it) and you can verify if this is the problem with your clips as well. Or play the clip in VLC media player and see what the codec info says about that clip when it's playing. Either way, see if those clips crashing it utilize ac3 audio. If so,I can describe how I used Virtual Dub MOD v1.5.10.2 with some specific addins (LAME mp3, AC3 Filer for decompressor, etc..) to streamcopy the video portion and only convert the audio to mp3 all in one rapid step. Was blazing fast mux and does not harm video quality. It works similar to some software I wrote (ActionBlu AVCHD) to process HD camcorder h.264 mov/mp4 clips to AVCHD. It only has to convert the audio to mp3 so it will stream and leaves the video intact ; ). I'm on a different PC at the moment or I would give you more exact steps of the process I used. If anyone wants to know how I processed the clips to mp3 audio all in one quick step, just let me know and I'll post them. I'm a newbie to this forum but would like to say good work on the software guys!

My rendering devices: Sony BDP-S370, PS3 and some Boxee PCs
Last edited by harryballzonya on Sat Jan 15, 2011 3:09 am, edited 1 time in total.
harryballzonya
 
Posts: 3
Joined: Fri Jan 14, 2011 1:45 pm

Re: Sony BDP-S370 (DLNA-compatible with new firmware M03.R.5

Postby grolschie » Fri Jan 14, 2011 10:25 pm

AC3 is no problem with the patch I posted. As long as your amp can decode it.
grolschie
 
Posts: 263
Joined: Thu Jun 10, 2010 7:05 am

Re: Sony BDP-S370 (DLNA-compatible with new firmware M03.R.5

Postby Anders » Sat Jan 15, 2011 2:59 pm

tried compiling with the patch using revision 412 (newer revisions resulted in errors when applying the patch) however i got an error when compiling stating that it was expecting a value somwhere in WebStream.java
Just thought id let you know.

here is a picture of the error message given bye ant:

Image
Anders
 
Posts: 17
Joined: Sun Aug 30, 2009 12:38 pm

Re: Sony BDP-S370 (DLNA-compatible with new firmware M03.R.5

Postby harryballzonya » Sat Jan 15, 2011 6:49 pm

grolschie wrote:AC3 is no problem with the patch I posted. As long as your amp can decode it.


My experience was with v410 on a win binary that someone created in a earlier post of this thread. Where exactly it was mentioned/posted i can't recall...

The install called it 410 but in PMS command screen it said 409, so.... In that version, if it truly had your patch applied properly, it would crash mencoder on the ps3 server pc when attempting to stream a xvid clip with ac3 audio only. Not complaining or anything like that, just trying to elaborate. Thanks for your work on this patch by the way. very grateful :D
harryballzonya
 
Posts: 3
Joined: Fri Jan 14, 2011 1:45 pm

SVN checkout, patching and compiling

Postby grolschie » Sat Jan 15, 2011 10:58 pm

Anders wrote:tried compiling with the patch using revision 412 (newer revisions resulted in errors when applying the patch) however i got an error when compiling stating that it was expecting a value somwhere in WebStream.java
Just thought id let you know.



Thanks for that. Interesting. Here's what I did just now:

1). Checked out a clean copy of PMS 412 into a new folder e.g. C:\TEMP_412\. In the dialog box, you can select 412 in the "Revision" field:

Image

2). Copied the patch file into the patch file into the ps3mediaserver folder e.g. C:\TEMP_412\ps3mediaserver.

3). Using Command Prompt, I navigate to the folder and type the command: patch -p0 < BDP-Sx70.patch

4). Then in the same folder type the command: ant

Result is shown here:
Image

As you can see, I had no problems patching the code or compiling it. FYI, I am using:
  • Windows XP (32bit) SP3
  • Java[TM] SE Development Kit 6 Update 23
  • TortoiseSVN 1.6.12.20536 (32bit)
  • Apache Ant 1.8.1
  • GnuWin32's patch.exe 2.5.9.2670

What software versions are you using?

Does the clean revision 412 code compile on your PC prior to patching?
Last edited by grolschie on Sat Jan 15, 2011 11:28 pm, edited 1 time in total.
grolschie
 
Posts: 263
Joined: Thu Jun 10, 2010 7:05 am

Re: Sony BDP-S370 (DLNA-compatible with new firmware M03.R.5

Postby grolschie » Sat Jan 15, 2011 11:01 pm

harryballzonya wrote:
grolschie wrote:AC3 is no problem with the patch I posted. As long as your amp can decode it.


My experience was with v410 on a win binary that someone created in a earlier post of this thread. Where exactly it was mentioned/posted i can't recall...

The install called it 410 but in PMS command screen it said 409, so.... In that version, if it truly had your patch applied properly, it would crash mencoder on the ps3 server pc when attempting to stream a xvid clip with ac3 audio only. Not complaining or anything like that, just trying to elaborate. Thanks for your work on this patch by the way. very grateful :D


The executable in 412 still shows 409. Did you put the BDP-sx70.conf file (that is in the zip file with the patch) into the renderers folder?
grolschie
 
Posts: 263
Joined: Thu Jun 10, 2010 7:05 am

Re: Sony BDP-S370 (DLNA-compatible with new firmware M03.R.5

Postby harryballzonya » Sat Jan 15, 2011 11:12 pm

grolschie wrote:
harryballzonya wrote:
grolschie wrote:AC3 is no problem with the patch I posted. As long as your amp can decode it.


My experience was with v410 on a win binary that someone created in a earlier post of this thread. Where exactly it was mentioned/posted i can't recall...

The install called it 410 but in PMS command screen it said 409, so.... In that version, if it truly had your patch applied properly, it would crash mencoder on the ps3 server pc when attempting to stream a xvid clip with ac3 audio only. Not complaining or anything like that, just trying to elaborate. Thanks for your work on this patch by the way. very grateful :D


The executable in 412 still shows 409. Did you put the BDP-sx70.conf file (that is in the zip file with the patch) into the renderers folder?


Oops... Ugh, that would be ah NO and probably why I had trouble... My bad. Thanks for the info! :mrgreen:
harryballzonya
 
Posts: 3
Joined: Fri Jan 14, 2011 1:45 pm

Re: Sony BDP-S370 (DLNA-compatible with new firmware M03.R.5

Postby grolschie » Sat Jan 15, 2011 11:20 pm

No problem. :-)

Also, HTTP Engine V2 must be enabled in PMS.conf.
grolschie
 
Posts: 263
Joined: Thu Jun 10, 2010 7:05 am

PreviousNext

Return to Alternative Media Renderers

Who is online

Users browsing this forum: Yahoo [Bot] and 5 guests