Sony BDP-S370 (DLNA-compatible with new firmware M03.R.567)

Discuss alternative media renderers (not PS3) supported by PS3 Media Server (e.g. Xbox 360, TVs &c.)

Re: Sony BDP-S370 (DLNA-compatible with new firmware M03.R.5

Postby mikehell » Tue Sep 21, 2010 1:56 pm

patters wrote:Do you have a US one, or European? And have you used PS3MS before, or is this the first time?


The other patched version (v2) works fine. Mine is a USA version which seems to be different than the ones sold elsewhere.
mikehell
 
Posts: 5
Joined: Wed Sep 15, 2010 1:26 pm

Re: Sony BDP-S370 (DLNA-compatible with new firmware M03.R.5

Postby patters » Tue Sep 21, 2010 8:56 pm

Try my v4 and see if that fixes it. I forgot to update the SonyBluray.conf file in v3.
patters
 
Posts: 97
Joined: Sun Apr 11, 2010 12:06 pm

Re: Sony BDP-S370 (DLNA-compatible with new firmware M03.R.5

Postby unmesh » Wed Sep 22, 2010 11:40 pm

so here is a newbie question.

I'm trying to run 1.10.51 on win7 and would love to know what I do with the .conf file that has patters content in it?
thanks
unmesh
 
Posts: 1
Joined: Wed Sep 22, 2010 11:33 pm

Re: Sony BDP-S370 (DLNA-compatible with new firmware M03.R.5

Postby ExSport » Wed Sep 22, 2010 11:51 pm

v1.10.51 doesn't support custom renderer files. You need latest betas for additional features as custom renderers etc...
ExSport
 
Posts: 2168
Joined: Mon Jan 19, 2009 5:40 pm

Re: Sony BDP-S370 (DLNA-compatible with new firmware M03.R.5

Postby infidel » Thu Sep 23, 2010 5:27 pm

If you're using pmsencoder for web video, the author suggests disabling HTTP Engine V2 in order to avoid a 40 second delay in playback. To make this workaround possible with the Sony BDP, here's a trivial patch to extend the WoH/Patters fixes to HTTP Engine V1:

sony_bdp_http_engine_v1_patch.zip
(918 Bytes) Downloaded 209 times

To enable the workaround you'll need to add this to your PMS.conf:
Code: Select all
http_engine_v2=false

Don't expect any miracles, speedup is only marginal afaict.
infidel
 
Posts: 278
Joined: Sun Aug 15, 2010 4:56 pm

Re: Sony BDP-S370 (DLNA-compatible with new firmware M03.R.5

Postby grolschie » Thu Sep 23, 2010 8:33 pm

Hi. Thanks Infidel. I hope to try this patch soon. I found that psmencoder (mostly) doesn't work for me with the combo WoH/patters patch though. With the stock PS3MS and applying WoHs first patch manually, psmencoder seems to work fine - and streams seemed to load reasonably quick anyway. Did you get psmencoder to work with the WoH/patters combo patch?
grolschie
 
Posts: 263
Joined: Thu Jun 10, 2010 7:05 am

Re: Sony BDP-S370 (DLNA-compatible with new firmware M03.R.5

Postby grolschie » Thu Sep 23, 2010 10:31 pm

I have tried the patch. Many thanks for that Infidel. It needs a slight change to apply it though:

Code: Select all
--- net/pms/network/Request.java   2010-09-04 19:34:36.000000000 -0400
+++ net/pms/network/Request.java   2010-09-23 10:23:21.798401000 -0400


For me, playback of internet tv fails with this also. I get "The file is corrupt or unsupported" error message. Whereas a stock PMS with WoH's original patch, not the combo patch, seems to work fine with pmsencoder for me for some reason. :?:

Thanks everyone for the work done so far. :D
grolschie
 
Posts: 263
Joined: Thu Jun 10, 2010 7:05 am

Re: Sony BDP-S370 (DLNA-compatible with new firmware M03.R.5

Postby starindigo » Fri Sep 24, 2010 12:15 pm

Could some kind soul, post a file patched with the latest patch from PATTERS' latest patch v4 that is. I am on Windows 7 64 bit and believe me, I have been reading the whole forum and searched on compiling the latest build but I kept getting build fail with apache 1.8.1. I have also tried apache 1.7.1 without success. And yes I have used 64 bit progs whenever I can, even for JDK.
starindigo
 
Posts: 1
Joined: Fri Sep 24, 2010 12:09 pm

Re: Sony BDP-S370 (DLNA-compatible with new firmware M03.R.5

Postby grolschie » Sat Oct 02, 2010 4:57 am

Ok, trying to solve this one again. From a clean svn check out of PSM 411 (not using any v1,v2,v3,v4, etc combo patch), if I patch manually with WoH's Content Range patch, I can stream .avi's with DTS. But pmsencoder doesn't work - I get "File is Corrupt or Unsupported". Chocolateboy has confirmed that the logs show that pmsencoder is not having any problems.

Now if I patch over this with the Content Length = -1 patch (there seems to be some overlap in the two patches), pmsencoder works fine, but attempting to stream an .avi file with DTS causes the blu-ray player to hang with the cursor going around and around.

I am using a simple render config that sets the mimetypes to .avi for many video filetypes, and only streams avi, divx, mpg and mpeg, for video. Any ideas as to why the content length patch kills this type of streaming please? Thanks in advance.
grolschie
 
Posts: 263
Joined: Thu Jun 10, 2010 7:05 am

Re: Sony BDP-S370 (DLNA-compatible with new firmware M03.R.5

Postby grolschie » Sat Oct 02, 2010 4:59 am

starindigo wrote:Could some kind soul, post a file patched with the latest patch from PATTERS' latest patch v4 that is. I am on Windows 7 64 bit and believe me, I have been reading the whole forum and searched on compiling the latest build but I kept getting build fail with apache 1.8.1. I have also tried apache 1.7.1 without success. And yes I have used 64 bit progs whenever I can, even for JDK.



Hello. Maybe this post could help. I don't have a 64bit machine.
grolschie
 
Posts: 263
Joined: Thu Jun 10, 2010 7:05 am

PreviousNext

Return to Alternative Media Renderers

Who is online

Users browsing this forum: No registered users and 3 guests