Official thread for non-ps3 renderers (Bravia, etc.)

Discuss alternative media renderers (not PS3) supported by PS3 Media Server (e.g. Xbox 360, TVs &c.)

Re: Official thread for non-ps3 renderers (Bravia, etc.)

Postby fragglerock » Fri Oct 08, 2010 6:44 pm

Hi all,

I have studied a lot of topics and wiki how-to to find answers to my questions.
I red the traces tab in PS3MS and saw this line :
Code: Select all
[New I/O server worker #1-1] DEBUG 19:13:18.281 Received on socket: USER-AGENT: SEC_HHP_TV-40C630/1.0

So i created a LE40C630.conf file with these lines and the content of Samsung.conf
Code: Select all
RendererName=Samsung LE40C630
RendererIcon=bravia.png
UserAgentSearch=SEC_HHP_TV-40C630/1.0
# UserAgentAdditionalHeader=X-AV-Client-Info
# UserAgentAdditionalHeaderSearch=SEC_HHP_TV-40C630/1.0
Video=true
Audio=true
Image=true
SeekByTime=false
TranscodeVideo=MPEGAC3
TranscodeAudio=PCM
DefaultVBVBufSize=true
MuxH264ToMpegTS=true
MuxDTSToMpeg=true
WrapDTSIntoPCM=false
MuxLPCMToMpeg=false
MaxVideoBitrateMbps=0
MaxVideoWidth=0
MaxVideoHeight=0
MimeTypesChanges=audio/wav=audio/L16
TranscodeExtensions=dvr-ms,dvr,mkv,dv,ty,mov,ogm,hdmov,hdm,rmv,rmvb,rm,asf,evo,asx,flv,m2v,mpe,mod,tivo,ty,tmf,ts,tp,m2p,mp4,m4v,wm,div,flac,mlp,fla,wma,m4a,aac,dts,mka,ape,ogg,shn,mpc,ra,mp2,wv,oma,aa3,gif,png,arw,cr2,crw,dng,raf,mrw,nef,pef,tif,tiff
StreamExtensions=


Restart PSMS and LE 40C630 was found, marvelous ;) ;)
So now i have to configure encoder to work only with unsuported file format or container.

I tried this with mkv and rmvb files but i get an error while transcoding. Here they are :
Code: Select all
[New I/O server worker #1-1] TRACE 19:13:20.296 Renderer Samsung LE40C630 have an estimated network speed of: 85 Mb/s
[New I/O server worker #1-3] TRACE 19:15:01.281 Starting transcode/remux of Il était un fois dans l'ouest.rmvb
[win32/tsMuxeR.exe] TRACE 19:15:03.203 Process C:\Program Files\PS3 Media Server\win32\tsMuxeR.exe has a return code of -2! Maybe an error occured... check the log file
[New I/O server worker #1-3] TRACE 19:15:13.937 Starting transcode/remux of Les rivières pourpres 2.mkv
[win32/tsMuxeR.exe] TRACE 19:15:15.312 Process C:\Program Files\PS3 Media Server\win32\tsMuxeR.exe has a return code of -2! Maybe an error occured... check the log file


There is no problem reding supported format (Divx, avi, xvid).
I tried Sony setting and mkv sarted to work and i saw the transcode status bar to move.
The network speed is estimated at 85 mb/s so it's not a good project to try to stream 1080p mkv ?
Code: Select all
[New I/O server worker #1-1] TRACE 19:13:20.296 Renderer Samsung LE40C630 have an estimated network speed of: 85 Mb/s


So the next question is :
What are the settings to watch all king of files format knowning my TV is compatible with :
Image
Maybe somebody have a conf file which could be a good starting point ?

Another question. I have a DVB-T card in my PC and i cand record TV. What are the best settings to record ? PS, TS ? And if it's HD TV (just to try) ?

Thank you
fragglerock
 
Posts: 3
Joined: Thu Oct 07, 2010 8:15 pm

Re: Official thread for non-ps3 renderers (Bravia, etc.)

Postby dunng » Thu Oct 14, 2010 1:25 am

Anyone have any luck with a Sony SMP-N100? Thanks!
dunng
 
Posts: 1
Joined: Thu Oct 14, 2010 1:22 am

Re: Official thread for non-ps3 renderers (Bravia, etc.)

Postby homer2k » Tue Oct 19, 2010 5:04 pm

I also have a smp-n100 i have been able to get it to steam the content but thats not good for HD video. I have been messing around with the settings for a couple days trying to get the server to buffer the movies. It either crashes or buffer fills then empty's right away and the video never starts. I have PS3's and they all work fine and i was assuming that the config would be similar enough but its not. I can't even get it to run right using Brivia configs. Anyone have any suggestions on how to get this to work??

Thanks in advance
User avatar
homer2k
 
Posts: 1
Joined: Tue Oct 19, 2010 4:49 pm

Re: Official thread for non-ps3 renderers (Bravia, etc.)

Postby beig1 » Fri Nov 19, 2010 4:35 pm

hello there,

i have a sony bravia 5500 and i tried to stream some files but when they load i have ~1 fps and the peak bitrate is maxed at ~3500 kb/s but the current bitrate is ~2000kb/s

this is the bravia5500.conf i found here on the forums

Code: Select all
# ps3mediaserver renderer profile for Sony Bravia 5500 series
# Refer to PS3.conf for help

RendererName=Sony Bravia 5500 Series
RendererIcon=bravia.png
UserAgentSearch=notusedhere
UserAgentAdditionalHeader=X-AV-Client-Info
UserAgentAdditionalHeaderSearch=(BRAVIA KDL.+5[0-9]{3})|(BRAVIA KDL.+WE5)|(BRAVIA KDL-[0-9]{2}XBR9)|(BRAVIA KDL.+EX5)
Video=true
Audio=true
Image=true
SeekByTime=true
#TranscodeVideo=MPEGTSAC3 for mpgs files
TranscodeVideo=MPEGTSAC3
#TranscodeVideo=MPEGAC3 for ISO files
#TranscodeVideo=MPEGAC3
TranscodeAudio=MP3
DefaultVBVBufSize=true
MuxH264ToMpegTS=true
MuxDTSToMpeg=false
WrapDTSIntoPCM=false
MuxLPCMToMpeg=false
MaxVideoBitrateMbps=0
MaxVideoWidth=0
MaxVideoHeight=0
H264Level41Limited=true
MimeTypesChanges=
# to check
#MimeTypesChanges=audio/wav=audio/L16|audio/ac3=audio/L16|video/mp4=video/mpeg
# http://ps3mediaserver.org/forum/viewtopic.php?f=6&t=4809&p=23509&hilit=MPEGTSAC3#p23509
DLNALocalizationRequired=true
TranscodeExtensions=mpg,dvr-ms,dvr,mkv,dv,ty,mov,ogm,hdmov,hdm,rmv,rmvb,rm,asf,evo,asx,flv,m2v,mpe,mod,tivo,ty,tmf,ts,tp,m2p,mp4,m4v,avi,wmv,wm,divx,div,flac,mlp,fla,wma,m4a,aac,dts,mka,ape,ogg,ogv,shn,mpc,ra,mp2,wv,oma,aa3,gif,png,arw,cr2,crw,dng,raf,mrw,nef,pef,tif,tiff,thm
StreamExtensions=


#Better/faster codec detection method ! true to enable it
#Need testing !
#MediaInfo=false
#Supported = f:mpegps|mpegts    v:mpeg2|mp4|h264    a:ac3|lpcm|aac|mpa   m:video/mpeg
#Supported = f:mp3   m:audio/mpeg
#Supported = f:wav   m:audio/L16
#Supported = f:jpg   m:image/jpeg


and my psm.conf i found here too

Code: Select all
thumbnails = true
alternativeffmpegpath = C:\\Program Files (x86)\\PS3 Media Server\\win32\\dvrms\\ffmpeg_MPGMUX.exe
mencoder_ass = true
language = en
folders = C:\\Users\\Thomy\\Downloads\\jDownloads
audiochannels = 2
network_interface = eth3
engines = pmsencoder,mencoder,tsmuxer,avsffmpeg,avsmencoder,ffmpegaudio,mplayeraudio,tsmuxeraudio,mencoderwebvideo,vlcvideo,mplayervideodump,mplayerwebaudio,vlcaudio,rawthumbs,ffmpegdvrmsremux
mencoder_mux_compatible = true
maxvideobuffer = 400
dvd_isos_thumbnails = true
thumbnail_seek_pos = 1
mencoder_mt = true
fix_25fps_av_mismatch = true
mencoder_intelligent_sync = true
codec_spec_script =
mencoder_forcefps = false



this is the trace when i start the ps3 media server (connected to my TV)

Code: Select all
[main] TRACE 16:32:02.634 http://code.google.com/p/ps3mediaserver
[main] TRACE 16:32:02.634
[main] TRACE 16:32:02.634 Java 1.6.0_12-Sun Microsystems Inc.
[main] TRACE 16:32:02.634 OS Windows Vista x86 6.1
[main] TRACE 16:32:02.635 Encoding: UTF-8
[main] TRACE 16:32:02.642 Temp folder: C:\Users\Thomy\AppData\Local\Temp\javaps3media
[main] TRACE 16:32:02.746 Loading configuration file: Bravia4500.conf
[main] TRACE 16:32:02.749 Loading configuration file: Bravia5500.conf
[main] TRACE 16:32:02.754 Loading configuration file: BraviaEX.conf
[main] TRACE 16:32:02.757 Loading configuration file: FreeboxHD.conf
[main] TRACE 16:32:02.759 Loading configuration file: FreecomMusicPal.conf
[main] TRACE 16:32:02.761 Loading configuration file: Kuro.conf
[main] TRACE 16:32:02.762 Loading configuration file: Philips.conf
[main] TRACE 16:32:02.764 Loading configuration file: PopcornHour.conf
[main] TRACE 16:32:02.765 Loading configuration file: PS3.conf
[main] TRACE 16:32:02.770 Loading configuration file: Realtek.conf
[main] TRACE 16:32:02.772 Loading configuration file: Samsung.conf
[main] TRACE 16:32:02.773 Loading configuration file: Streamium.conf
[main] TRACE 16:32:02.775 Loading configuration file: WDTVLive.conf
[main] TRACE 16:32:02.776 Loading configuration file: XBMC.conf
[main] TRACE 16:32:02.777 Loading configuration file: XBOX360.conf
[main] TRACE 16:32:02.779 Checking font cache... launching simple instance of MPlayer... You may have to wait 60 seconds !
[main] TRACE 16:32:02.979 Done!
[main] TRACE 16:32:02.980 Found AviSynth plugins dir: C:\Program Files (x86)\AviSynth 2.5\plugins
[main] TRACE 16:32:02.980 Found VideoLAN version 1.1.4 at: C:\Program Files (x86)\VideoLAN\VLC\vlc.exe
[main] TRACE 16:32:02.980 Unfortunately, VideoLAN 1.x is not supported at this point. Last known working version is 0.98
[main] TRACE 16:32:02.991 Registering transcoding engine AviSynth/FFmpeg
[main] TRACE 16:32:02.991 Registering transcoding engine FFmpeg Audio
[main] TRACE 16:32:02.999 Registering transcoding engine MEncoder
[main] TRACE 16:32:03.000 Registering transcoding engine Avisynth/MEncoder
[main] TRACE 16:32:03.001 Registering transcoding engine MPlayer Audio
[main] TRACE 16:32:03.001 Registering transcoding engine MEncoder Web
[main] TRACE 16:32:03.002 Registering transcoding engine MPlayer Video Dump
[main] TRACE 16:32:03.002 Registering transcoding engine MPlayer Web
[main] TRACE 16:32:03.004 Registering transcoding engine TsMuxer
[main] TRACE 16:32:03.005 Registering transcoding engine Audio High Fidelity
[main] TRACE 16:32:03.006 Registering transcoding engine VideoLan Audio Streaming
[main] TRACE 16:32:03.007 Registering transcoding engine VideoLan Video Streaming
[main] TRACE 16:32:03.007 Registering transcoding engine FFmpeg DVR-MS Remux
[main] TRACE 16:32:03.008 Registering transcoding engine Raws Thumbnailer
[main] TRACE 16:32:03.250 Scanning network interface eth3 / Realtek RTL8168B/8111B-Familie-PCI-E-Gigabit-Ethernet-NIC (NDIS 6.20)
[main] TRACE 16:32:03.254 Using address /10.0.0.4 found on network interface: name:eth3 (Realtek RTL8168B/8111B-Familie-PCI-E-Gigabit-Ethernet-NIC (NDIS 6.20)) index: 11 addresses: /10.0.0.4;
[main] TRACE 16:32:03.255 Created socket: /10.0.0.4:5001
[main] TRACE 16:32:03.356 Using following UUID: 6ab6476e-9699-302c-bc0c-02fff96dceb7
[New I/O server worker #1-1] TRACE 16:32:05.202 Renderer Sony Bravia 5500 Series found on this address: /10.0.0.9
[main] TRACE 16:32:08.766 It's ready! You should see the server appears on XMB
[New I/O server worker #1-3] TRACE 16:32:45.801 Starting transcode/remux of NG.Seconds.From.Disaster - Alpine Tsunami.avi


is there a way to get it work on my bravia 5500?

thanks for your help
beig1
 
Posts: 1
Joined: Fri Nov 19, 2010 4:17 pm

Re: Official thread for non-ps3 renderers (Bravia, etc.)

Postby smorges » Sun Nov 21, 2010 6:22 pm

Any chance of someone figuring out how to fix the EX500 aspect ratio problem?

All my mkv HD 16:9 tv episodes play fine, but some of my HD movies get double black bars. Maybe it's the way its encoded and some MKV HD movies that are not 16:9 do play correctly.
smorges
 
Posts: 5
Joined: Sun Nov 21, 2010 6:18 pm

Re: Official thread for non-ps3 renderers (Bravia, etc.)

Postby Jaiket » Mon Nov 22, 2010 3:22 pm

I've just set up my Sony 5500 and it streams most files with no problem. I cant however get .mkv files to work. Everything seems fine in the trace log,but I just get a black screen on my TV. Any help much appreciated!
Jaiket
 
Posts: 3
Joined: Mon Nov 22, 2010 3:14 pm

Re: Official thread for non-ps3 renderers (Bravia, etc.)

Postby picld » Sat Nov 27, 2010 7:13 pm

Would anyone happen to know why my Bravia KDL-46NX710 insists on transcoding every single avi/divx and mp4 (which are played perfectly fine from a USB media) to mpeg2, although my renderer config looks like this:

Code: Select all
RendererName=Sony Bravia KDL-46NX710
RendererIcon=bravia.png
UserAgentSearch=notusedhere
UserAgentAdditionalHeader=X-AV-Client-Info
UserAgentAdditionalHeaderSearch=BRAVIA KDL-46NX710
Video=true
Audio=true
Image=true
SeekByTime=true
TranscodeVideo=MPEGAC3
TranscodeAudio=MP3
DefaultVBVBufSize=true
MuxH264ToMpegTS=true
MuxDTSToMpeg=false
WrapDTSIntoPCM=false
MuxLPCMToMpeg=false
MaxVideoBitrateMbps=0
MaxVideoWidth=0
MaxVideoHeight=0
H264Level41Limited=true
TranscodeAudioTo441kHz=false
AutoExifRotate=true
MimeTypesChanges=audio/wav=audio/L16
DLNALocalizationRequired=true
TranscodeExtensions=dvr-ms,dvr,mkv,dv,ty,mov,ogm,hdmov,hdm,rmv,rmvb,rm,asf,evo,asx,flv,m2v,mpe,mod,tivo,ty,tmf,ts,tp,m2p,m4v,wmv,wm,divx,div,flac,mlp,fla,wma,m4a,aac,dts,mka,ape,ogg,shn,mpc,ra,mp2,wv,oma,aa3,gif,png,arw,cr2,crw,dng,raf,mrw,nef,pef,tif,tiff
StreamExtensions=

MediaInfo=true
# [Supported video formats]:
# Here we declare support (or lack) of DTS (here, none of the entries declare dts as a supported audio codec)
Supported = f:mpegps|mpegts v:mpeg1|mpeg2|mp4|h264 a:ac3|lpcm|aac|mpa m:video/mpeg
# No H264 for AVI files, plus specific mediainfo attributes, for better auto detection (qpel and gmc are not supported here)
Supported = f:avi|divx v:mp4|divx|mjpeg a:mp3|lpcm|mpa|ac3 m:video/x-divx qpel:no gmc:0
Supported = f:mp4 v:mp4|h264 a:ac3|aac m:video/mp4
# WMV files are supported, but not with 5.1 audio: (hence the n:2)
Supported = f:wmv v:wmv|vc1 a:wma n:2 m:video/x-ms-wmv
# [Supported audio formats]:
Supported = f:wav a:dts|lpcm n:6 s:48000 m:audio/wav
Supported = f:wav n:2 s:48000 m:audio/wav
Supported = f:mp3 n:2 m:audio/mpeg
# Apple lossless not supported
Supported = f:aac n:2 a:(?!alac).+ m:audio/x-m4a
Supported = f:wma n:2 m:audio/x-ms-wma
Supported = f:atrac n:2 m:audio/x-oma
# [Supported image formats]
Supported = f:jpg m:image/jpeg
Supported = f:png m:image/png
Supported = f:gif m:image/gif
Supported = f:tiff m:image/tiff


only the h264 encoded MKV files are correctly streamed without any cpu overhead :roll: why?
picld
 
Posts: 4
Joined: Thu Sep 09, 2010 2:38 pm

Re: Official thread for non-ps3 renderers (Bravia, etc.)

Postby Illico » Mon Nov 29, 2010 11:09 am

picld wrote:Would anyone happen to know why my Bravia KDL-46NX710 insists on transcoding every single avi/divx and mp4 (which are played perfectly fine from a USB media) to mpeg2, although my renderer config looks like this:

Because the Sony Bravia DLNA renderer support only mpeg2ts or mpeg2ps with mpeg2 or AVC(h264) video and AC3 audio.
Have a look on this
viewtopic.php?f=15&t=7423#p34595

GetProtocolInfo
Use Intel Tool:
- Install Intel UPnP tools
- run Device Spy
- It should list all your UPnP device and among them yout device (eg TV, console, etc)
- Expand the device's tree and find service: urn:upnp-org:serviceId:ConnectionManager:1
- Expand that and double click on GetProtocolInfo(...).
- Click on Invoke and the result is in field Sink.
You will find all DNLA supported format of your device...
Sony Bravia KDL-46EX501 | Sony BDP-S373 | Sony SMP-N100 |Serviio / PS3MS | Buffalo 2Share DD
User avatar
Illico
 
Posts: 129
Joined: Wed Jun 30, 2010 2:28 pm
Location: France

Re: Official thread for non-ps3 renderers (Bravia, etc.)

Postby TomDoe » Sat Dec 04, 2010 4:39 pm

Problem with Samsung.conf for Samsung LE40C750.

Trace: [New I/O server worker #1-2] TRACE 16:36:11.985 Media renderer was not recognized. HTTP User agent : DLNADOC/1.50

samsung.conf:

RendererName=Samsung LE40C750
RendererIcon=bravia.png
UserAgentSearch=DLNADOC/1.50
Video=true
Audio=true
Image=true
SeekByTime=true
TranscodeVideo=MPEGAC3
TranscodeAudio=PCM
DefaultVBVBufSize=true
MuxH264ToMpegTS=true
MuxDTSToMpeg=true
WrapDTSIntoPCM=false
MuxLPCMToMpeg=true
MaxVideoBitrateMbps=0
MaxVideoWidth=0
MaxVideoHeight=0
H264Level41Limited=true
TranscodeAudioTo441kHz=false
TranscodeFastStart=false
TranscodedVideoFileSize=-1
AutoExifRotate=true AutoExifRotate = true
MimeTypesChanges=audio/wav=audio/L16|video/x-matroska=video/avi
#MimeTypesChanges=audio/wav=audio/L16
TranscodeExtensions=mov
StreamExtensions=mp3,mp4,avi,hdmov,hdm,flac,fla,dts,ogg,asf,asx,m2v,mkv

Any idea, why it doesnt recognize it?
TomDoe
 
Posts: 23
Joined: Sun Jan 25, 2009 5:55 pm

Re: Official thread for non-ps3 renderers (Bravia, etc.)

Postby picld » Tue Dec 07, 2010 8:12 pm

Illico wrote:Because the Sony Bravia DLNA renderer support only mpeg2ts or mpeg2ps with mpeg2 or AVC(h264) video and AC3 audio.

Thanks for the reference mate. Still, I cannot understand why mp4 file won't simply be remuxed for heaven's sake. The video is already coded as AVC, same as any other MKV. Only AAC audio should be transcoded to AC3. :?: What gives?
Is there REALLY absolutely no way to trick the DLNA renderer with some codec configuration into believing that a MP4 with AVC/AAC is actually a h264/AC3 M2TS without transcoding the video part??
picld
 
Posts: 4
Joined: Thu Sep 09, 2010 2:38 pm

PreviousNext

Return to Alternative Media Renderers

Who is online

Users browsing this forum: Yahoo [Bot] and 6 guests