Videos (MKV and AVI) are lagging on Panasonic TX-P50VT30E

Discuss alternative media renderers (not PS3) supported by PS3 Media Server (e.g. Xbox 360, TVs &c.)

Videos (MKV and AVI) are lagging on Panasonic TX-P50VT30E

Postby gabychou » Thu Mar 29, 2012 10:39 pm

Hi there,

I've tried for a long time to read subtitles (from SRT files) with videos through DLNA on my Panasonic VT30 (connected to my computer through wifi).
I was told DLNA doesn't support it, but I've recently tried PMS and find out il seems possible!
Although I have some other issues : all the videos I am trying to read are lagging after few seconds, even AVI files, even without subtitles :o
I've tried to downgrade the quality of the video but nothing changes...

The fact is, traces show nothing wrong and it should works since I don't have any issue with serviio (which doesn't support srt files through DLNA :? )

Code: Select all
[main] INFO  23:07:02.058 Starting PS3 Media Server 1.40.0
[main] INFO  23:07:02.063 by shagrath / 2008-2011
[main] INFO  23:07:02.063 http://ps3mediaserver.org
[main] INFO  23:07:02.064 http://code.google.com/p/ps3mediaserver
[main] INFO  23:07:02.064 http://ps3mediaserver.blogspot.com
[main] INFO  23:07:02.064
[main] INFO  23:07:02.065 Java: 1.6.0_31-Sun Microsystems Inc.
[main] INFO  23:07:02.066 OS: Windows 7 x86 6.1
[main] INFO  23:07:02.066 Encoding: UTF-8
[main] INFO  23:07:02.067 Working directory: C:\Program Files (x86)\PS3 Media Server
[main] INFO  23:07:02.085 Temp folder: C:\Temp\ps3mediaserver
[main] INFO  23:07:02.085 Logging config file: C:\Program Files (x86)\PS3 Media Server\logback.xml
[main] INFO  23:07:02.086 debug.log: C:\Program Files (x86)\PS3 Media Server\debug.log
[main] INFO  23:07:02.086
[main] INFO  23:07:02.087 Profile directory: C:\ProgramData\PMS
[main] INFO  23:07:02.087 Profile path: C:\ProgramData\PMS\PMS.conf
[main] INFO  23:07:02.088 Profile status: rw
[main] INFO  23:07:02.089 Profile name: mezzanine
[main] INFO  23:07:02.089
[main] INFO  23:07:02.095 Loading MediaInfo library
[main] INFO  23:07:02.224 Loaded MediaInfoLib - v0.7.47
[main] INFO  23:07:02.230 Loading renderer configurations from C:\Program Files (x86)\PS3 Media Server\renderers
[main] INFO  23:07:02.231 Loading configuration file: AirPlayer.conf
[main] INFO  23:07:02.245 Loading configuration file: Android.conf
[main] INFO  23:07:02.247 Loading configuration file: Bravia4500.conf
[main] INFO  23:07:02.249 Loading configuration file: Bravia5500.conf
[main] INFO  23:07:02.255 Loading configuration file: BraviaEX.conf
[main] INFO  23:07:02.260 Loading configuration file: FreeboxHD.conf
[main] INFO  23:07:02.262 Loading configuration file: FreecomMusicPal.conf
[main] INFO  23:07:02.264 Loading configuration file: iPad-iPhone.conf
[main] INFO  23:07:02.266 Loading configuration file: Kuro.conf
[main] INFO  23:07:02.268 Loading configuration file: N900.conf
[main] INFO  23:07:02.269 Loading configuration file: Panasonic.conf
[main] INFO  23:07:02.271 Loading configuration file: Philips.conf
[main] INFO  23:07:02.273 Loading configuration file: PopcornHour.conf
[main] INFO  23:07:02.274 Loading configuration file: PS3.conf
[main] INFO  23:07:02.277 Loading configuration file: Realtek.conf
[main] INFO  23:07:02.279 Loading configuration file: Samsung.conf
[main] INFO  23:07:02.281 Loading configuration file: Showtime3.conf
[main] INFO  23:07:02.283 Loading configuration file: SonyBluray.conf
[main] INFO  23:07:02.285 Loading configuration file: Streamium.conf
[main] INFO  23:07:02.287 Loading configuration file: WDTVLive.conf
[main] INFO  23:07:02.288 Loading configuration file: WMP.conf
[main] INFO  23:07:02.289 Loading configuration file: XBMC.conf
[main] INFO  23:07:02.291 Loading configuration file: XBOX360.conf
[main] INFO  23:07:02.292 Checking MPlayer font cache. It can take a minute or so.
[AWT-EventQueue-0] INFO  23:07:44.051 Configuration saved to: C:\ProgramData\PMS\PMS.conf
[main] INFO  23:07:56.544 Done!
[main] INFO  23:07:56.638 Loading plugins from C:\Program Files (x86)\PS3 Media Server\plugins
[main] INFO  23:07:56.641 No plugins found
[main] INFO  23:07:56.648 Transcoder profile AviSynth/FFmpeg will not be used because AviSynth was not found
[main] INFO  23:07:56.650 Registering transcoding engine: FFmpeg Audio
[main] INFO  23:07:56.658 Registering transcoding engine: MEncoder
[main] INFO  23:07:56.660 Transcoder profile Avisynth/MEncoder will not be used because AviSynth was not found
[main] INFO  23:07:56.661 Registering transcoding engine: MPlayer Audio
[main] INFO  23:07:56.662 Registering transcoding engine: MEncoder Web
[main] INFO  23:07:56.663 Registering transcoding engine: MPlayer Video Dump
[main] INFO  23:07:56.665 Registering transcoding engine: MPlayer Web
[main] INFO  23:07:56.673 Registering transcoding engine: TsMuxer
[main] INFO  23:07:56.675 Registering transcoding engine: Audio High Fidelity
[main] INFO  23:07:56.677 Executable of transcoder profile VLC Audio Streaming not found
[main] INFO  23:07:56.678 Executable of transcoder profile VLC Video Streaming not found
[main] INFO  23:07:56.680 Registering transcoding engine: FFmpeg DVR-MS Remux
[main] INFO  23:07:56.680 Registering transcoding engine: Raws Thumbnailer
[main] INFO  23:07:56.681 AviSynth is not installed. You cannot use avsffmpeg as a transcoding engine.
[main] INFO  23:07:56.915 Scanning network interface lo / Software Loopback Interface 1
[main] INFO  23:07:56.922 Scanning network interface net0 / WAN Miniport (SSTP)
[main] INFO  23:07:56.930 Scanning network interface net1 / WAN Miniport (L2TP)
[main] INFO  23:07:56.937 Scanning network interface net2 / WAN Miniport (PPTP)
[main] INFO  23:07:56.944 Scanning network interface ppp0 / WAN Miniport (PPPOE)
[main] INFO  23:07:56.951 Scanning network interface eth0 / WAN Miniport (IPv6)
[main] INFO  23:07:56.957 Scanning network interface eth1 / WAN Miniport (Network Monitor)
[main] INFO  23:07:56.965 Scanning network interface eth2 / WAN Miniport (IP)
[main] INFO  23:07:56.973 Scanning network interface ppp1 / RAS Async Adapter
[main] INFO  23:07:56.981 Scanning network interface eth3 / NVIDIA nForce 10/100 Mbps Ethernet
[main] INFO  23:07:56.990 Using address /192.168.1.1 found on network interface: name:eth3 (NVIDIA nForce 10/100 Mbps Ethernet )
[main] INFO  23:07:56.991 Created socket: /192.168.1.1:5001
[main] INFO  23:07:57.149 Using the following UUID configured in PMS.conf: 33143597-10f8-4292-9a1a-bd1382482df0
[New I/O server worker #1-1] INFO  23:07:57.284 Renderer Panasonic found on this address: COM-MID1.home (192.168.1.2)
[main] INFO  23:08:02.682 The server should now appear on your renderer
[New I/O server worker #1-1] INFO  23:09:40.601 Starting transcode/remux of Fringe.S04E15.720p.HDTV.X264-DIMENSION.mkv


Any idea?
gabychou
 
Posts: 5
Joined: Thu Mar 29, 2012 10:27 pm

Re: Videos (MKV and AVI) are lagging on Panasonic TX-P50VT30

Postby ExSport » Fri Mar 30, 2012 7:22 am

Post debug.log and not trace log ;)
Yes, PanTV doesn't support subtitles via DLNA but PMS supports it. When subs are used, file is not streamed as is to TV but it is transcoded so CPU and network is heavily used.
So problem should be CPU or your WIFI. Without debug.log nobody knows more ;)
ExSport
 
Posts: 2167
Joined: Mon Jan 19, 2009 5:40 pm

Re: Videos (MKV and AVI) are lagging on Panasonic TX-P50VT30

Postby gabychou » Fri Mar 30, 2012 6:25 pm

Ok, thanks for the clear explanation!

Here are the logs:

Code: Select all
[main] INFO  23:07:02.058 Starting PS3 Media Server 1.40.0
[main] INFO  23:07:02.063 by shagrath / 2008-2011
[main] INFO  23:07:02.063 http://ps3mediaserver.org
[main] INFO  23:07:02.064 http://code.google.com/p/ps3mediaserver
[main] INFO  23:07:02.064 http://ps3mediaserver.blogspot.com
[main] INFO  23:07:02.064
[main] INFO  23:07:02.065 Java: 1.6.0_31-Sun Microsystems Inc.
[main] INFO  23:07:02.066 OS: Windows 7 x86 6.1
[main] INFO  23:07:02.066 Encoding: UTF-8
[main] INFO  23:07:02.067 Working directory: C:\Program Files (x86)\PS3 Media Server
[main] INFO  23:07:02.085 Temp folder: C:\Temp\ps3mediaserver
[main] INFO  23:07:02.085 Logging config file: C:\Program Files (x86)\PS3 Media Server\logback.xml
[main] INFO  23:07:02.086 debug.log: C:\Program Files (x86)\PS3 Media Server\debug.log
[main] INFO  23:07:02.086
[main] INFO  23:07:02.087 Profile directory: C:\ProgramData\PMS
[main] INFO  23:07:02.087 Profile path: C:\ProgramData\PMS\PMS.conf
[main] INFO  23:07:02.088 Profile status: rw
[main] INFO  23:07:02.089 Profile name: mezzanine
[main] INFO  23:07:02.089
[main] INFO  23:07:02.095 Loading MediaInfo library
[main] INFO  23:07:02.224 Loaded MediaInfoLib - v0.7.47
[main] INFO  23:07:02.230 Loading renderer configurations from C:\Program Files (x86)\PS3 Media Server\renderers
[main] INFO  23:07:02.231 Loading configuration file: AirPlayer.conf
[main] INFO  23:07:02.245 Loading configuration file: Android.conf
[main] INFO  23:07:02.247 Loading configuration file: Bravia4500.conf
[main] INFO  23:07:02.249 Loading configuration file: Bravia5500.conf
[main] INFO  23:07:02.255 Loading configuration file: BraviaEX.conf
[main] INFO  23:07:02.260 Loading configuration file: FreeboxHD.conf
[main] INFO  23:07:02.262 Loading configuration file: FreecomMusicPal.conf
[main] INFO  23:07:02.264 Loading configuration file: iPad-iPhone.conf
[main] INFO  23:07:02.266 Loading configuration file: Kuro.conf
[main] INFO  23:07:02.268 Loading configuration file: N900.conf
[main] INFO  23:07:02.269 Loading configuration file: Panasonic.conf
[main] INFO  23:07:02.271 Loading configuration file: Philips.conf
[main] INFO  23:07:02.273 Loading configuration file: PopcornHour.conf
[main] INFO  23:07:02.274 Loading configuration file: PS3.conf
[main] INFO  23:07:02.277 Loading configuration file: Realtek.conf
[main] INFO  23:07:02.279 Loading configuration file: Samsung.conf
[main] INFO  23:07:02.281 Loading configuration file: Showtime3.conf
[main] INFO  23:07:02.283 Loading configuration file: SonyBluray.conf
[main] INFO  23:07:02.285 Loading configuration file: Streamium.conf
[main] INFO  23:07:02.287 Loading configuration file: WDTVLive.conf
[main] INFO  23:07:02.288 Loading configuration file: WMP.conf
[main] INFO  23:07:02.289 Loading configuration file: XBMC.conf
[main] INFO  23:07:02.291 Loading configuration file: XBOX360.conf
[main] INFO  23:07:02.292 Checking MPlayer font cache. It can take a minute or so.
[main] DEBUG 23:07:02.293 launching: win32/mplayer.exe
[main] DEBUG 23:07:40.421 launching: win32/mplayer.exe
[AWT-EventQueue-0] INFO  23:07:44.051 Configuration saved to: C:\ProgramData\PMS\PMS.conf
[main] INFO  23:07:56.544 Done!
[main] INFO  23:07:56.638 Loading plugins from C:\Program Files (x86)\PS3 Media Server\plugins
[main] INFO  23:07:56.641 No plugins found
[main] INFO  23:07:56.648 Transcoder profile AviSynth/FFmpeg will not be used because AviSynth was not found
[main] INFO  23:07:56.650 Registering transcoding engine: FFmpeg Audio
[main] INFO  23:07:56.658 Registering transcoding engine: MEncoder
[main] INFO  23:07:56.660 Transcoder profile Avisynth/MEncoder will not be used because AviSynth was not found
[main] INFO  23:07:56.661 Registering transcoding engine: MPlayer Audio
[main] INFO  23:07:56.662 Registering transcoding engine: MEncoder Web
[main] INFO  23:07:56.663 Registering transcoding engine: MPlayer Video Dump
[main] INFO  23:07:56.665 Registering transcoding engine: MPlayer Web
[main] INFO  23:07:56.673 Registering transcoding engine: TsMuxer
[main] INFO  23:07:56.675 Registering transcoding engine: Audio High Fidelity
[main] INFO  23:07:56.677 Executable of transcoder profile VLC Audio Streaming not found
[main] INFO  23:07:56.678 Executable of transcoder profile VLC Video Streaming not found
[main] INFO  23:07:56.680 Registering transcoding engine: FFmpeg DVR-MS Remux
[main] INFO  23:07:56.680 Registering transcoding engine: Raws Thumbnailer
[main] INFO  23:07:56.681 AviSynth is not installed. You cannot use avsffmpeg as a transcoding engine.
[main] INFO  23:07:56.915 Scanning network interface lo / Software Loopback Interface 1
[main] INFO  23:07:56.922 Scanning network interface net0 / WAN Miniport (SSTP)
[main] INFO  23:07:56.930 Scanning network interface net1 / WAN Miniport (L2TP)
[main] INFO  23:07:56.937 Scanning network interface net2 / WAN Miniport (PPTP)
[main] INFO  23:07:56.944 Scanning network interface ppp0 / WAN Miniport (PPPOE)
[main] INFO  23:07:56.951 Scanning network interface eth0 / WAN Miniport (IPv6)
[main] INFO  23:07:56.957 Scanning network interface eth1 / WAN Miniport (Network Monitor)
[main] INFO  23:07:56.965 Scanning network interface eth2 / WAN Miniport (IP)
[main] INFO  23:07:56.973 Scanning network interface ppp1 / RAS Async Adapter
[main] INFO  23:07:56.981 Scanning network interface eth3 / NVIDIA nForce 10/100 Mbps Ethernet
[main] INFO  23:07:56.990 Using address /192.168.1.1 found on network interface: name:eth3 (NVIDIA nForce 10/100 Mbps Ethernet )
[main] INFO  23:07:56.991 Created socket: /192.168.1.1:5001
[main] DEBUG 23:07:57.113 Sending ALIVE...
[main] INFO  23:07:57.149 Using the following UUID configured in PMS.conf: 33143597-10f8-4292-9a1a-bd1382482df0
[New I/O server worker #1-1] INFO  23:07:57.284 Renderer Panasonic found on this address: COM-MID1.home (192.168.1.2)
[New I/O server worker #1-1] DEBUG 23:07:57.289 Starting ping -n 3 -l 64000 192.168.1.2
[Thread-15] DEBUG 23:07:59.289 Stopping process: ping
[main] INFO  23:08:02.682 The server should now appear on your renderer
[Thread-18] DEBUG 23:08:12.681 Sending ALIVE...
[Thread-18] DEBUG 23:08:37.892 Sending ALIVE...
[New I/O server worker #1-3] DEBUG 23:09:39.280 Forcing short path name on D:\Vidéos\Séries\Fringe\Fringe.S04E15.720p.HDTV.X264-DIMENSION.srt
[New I/O server worker #1-4] DEBUG 23:09:39.584 Forcing short path name on D:\Vidéos\Séries\Fringe\Fringe.S04E15.720p.HDTV.X264-DIMENSION.mkv
[New I/O server worker #1-4] DEBUG 23:09:39.587 Starting C:\Program Files (x86)\PS3 Media Server\win32\ffmpeg.exe -ss 1 -i D:\VIDOS~1\SRIES~1\Fringe\FRINGE~1.MKV -an -an -s 320x180 -vframes 1 -f image2 pipe:
[New I/O server worker #1-4] DEBUG 23:09:39.633 Attaching thread: win32/ffmpeg.exe
[New I/O server worker #1-1] INFO  23:09:40.601 Starting transcode/remux of Fringe.S04E15.720p.HDTV.X264-DIMENSION.mkv
[New I/O server worker #1-1] DEBUG 23:09:40.605 Forcing short path name on D:\Vidéos\Séries\Fringe\Fringe.S04E15.720p.HDTV.X264-DIMENSION.mkv
[New I/O server worker #1-1] DEBUG 23:09:40.624 Forcing short path name on D:\Vidéos\Séries\Fringe\Fringe.S04E15.720p.HDTV.X264-DIMENSION.srt
[New I/O server worker #1-4] DEBUG 23:09:40.634 Forcing short path name on D:\Vidéos\Séries\Fringe\Fringe.S04E15.720p.HDTV.X264-DIMENSION.mkv
[New I/O server worker #1-1] DEBUG 23:09:40.710 Creating pipe \\.\pipe\mencoder1333055380707
[Thread-25] DEBUG 23:09:40.855 Waiting for pipe connection \\.\pipe\mencoder1333055380707
[win32/mencoder_mt.exe] DEBUG 23:09:40.906 Starting C:\Program Files (x86)\PS3 Media Server\win32\mencoder_mt.exe -ss 0 -quiet D:\VIDOS~1\SRIES~1\Fringe\FRINGE~1.MKV -quiet -quiet -oac copy -of mpeg -quiet -quiet -mpegopts format=mpeg2:muxrate=500000:vbuf_size=1194:abuf_size=64 -ovc lavc -channels 2 -lavdopts debug=0:threads=2 -lavcopts autoaspect=1:vcodec=mpeg2video:vrc_buf_size=1835:vrc_minrate=15000:vrc_maxrate=15000:vbitrate=15000:acodec=ac3:abitrate=256:threads=2:keyint=5:vqscale=1:vqmin=3:vqmax=5:vrc_maxrate=60000:vrc_buf_size=7000 -subcp cp1252 -subfont C:\Windows\Fonts\Arial.ttf -subfont-text-scale 3 -subfont-outline 1 -subfont-blur 1 -subpos 98 -quiet -quiet -sid 100 -quiet -quiet -ofps 24000/1001 -sub D:\VIDOS~1\SRIES~1\Fringe\FRINGE~1.SRT -lavdopts fast -mc 0 -noskip -af lavcresample=48000 -srate 48000 -o \\.\pipe\mencoder1333055380707
[win32/mencoder_mt.exe] DEBUG 23:09:40.927 Reading pipe: \\.\pipe\mencoder1333055380707
[win32/mencoder_mt.exe] DEBUG 23:09:40.927 Attaching thread: win32/mencoder_mt.exe
[New I/O server worker #1-1] DEBUG 23:09:41.005 Forcing short path name on D:\Vidéos\Séries\Fringe\Fringe.S04E15.720p.HDTV.X264-DIMENSION.mkv
[Thread-29] DEBUG 23:09:41.009 Forcing short path name on D:\Vidéos\Séries\Fringe\Fringe.S04E15.720p.HDTV.X264-DIMENSION.mkv
[Thread-25] DEBUG 23:09:41.026 Result of \\.\pipe\mencoder1333055380707 : true
[Thread-24] DEBUG 23:09:43.137 Stopping process: win32/ffmpeg.exe
[New I/O server worker #1-1] DEBUG 23:09:56.933 Forcing short path name on D:\Vidéos\Séries\Fringe\Fringe.S04E15.720p.HDTV.X264-DIMENSION.mkv
[Thread-30] DEBUG 23:09:59.444 Stopping process: win32/mencoder_mt.exe
[Thread-33] DEBUG 23:10:00.947 Forcing short path name on D:\Vidéos\Séries\Fringe\Fringe.S04E15.720p.HDTV.X264-DIMENSION.mkv
gabychou
 
Posts: 5
Joined: Thu Mar 29, 2012 10:27 pm

Re: Videos (MKV and AVI) are lagging on Panasonic TX-P50VT30

Postby gabychou » Fri Mar 30, 2012 7:21 pm

And I can confirm : the lag comes from my computer's CPU : 100%...
I thought it was sufficient for that : it's an AMD Athlon II X2 215 2.70GHz with 3Gb RAM running Win7 :o
gabychou
 
Posts: 5
Joined: Thu Mar 29, 2012 10:27 pm

Re: Videos (MKV and AVI) are lagging on Panasonic TX-P50VT30

Postby ExSport » Fri Mar 30, 2012 8:36 pm

So it is easy, will repeat it but it is already deeply discussed here in forum:
Code: Select all
Starting PS3 Media Server 1.40.0
Avoid using so old version. Check official latest build or eg. SB one:
viewtopic.php?f=14&t=8883
Starting C:\Program Files (x86)\PS3 Media Server\win32\mencoder_mt.exe -ss 0 -quiet D:\VIDOS~1\SRIES~1\Fringe\FRINGE~1.MKV -quiet -quiet -oac copy -of mpeg -quiet -quiet -mpegopts format=mpeg2:muxrate=500000:vbuf_size=1194:abuf_size=64 -ovc lavc -channels 2 -lavdopts debug=0:threads=2 -lavcopts autoaspect=1:vcodec=mpeg2video:vrc_buf_size=1835:vrc_minrate=15000:vrc_maxrate=15000:vbitrate=15000:acodec=ac3:abitrate=256:threads=2:keyint=5:vqscale=1:vqmin=3:vqmax=5:vrc_maxrate=60000:vrc_buf_size=7000 -subcp cp1252 -subfont C:\Windows\Fonts\Arial.ttf -subfont-text-scale 3 -subfont-outline 1 -subfont-blur 1 -subpos 98 -quiet -quiet -sid 100 -quiet -quiet -ofps 24000/1001 -sub D:\VIDOS~1\SRIES~1\Fringe\FRINGE~1.SRT -lavdopts fast -mc 0 -noskip -af lavcresample=48000 -srate 48000 -o \\.\pipe\mencoder1333055380707

  • Very old MEncoder build
  • PanTV can't TimeSeek so CBR bitrate is used(for Byte2TimeSeek conversion). Old versions are limited to 16Mbit/s stream what is very low for HD source so it is very CPU demanding (you have 15000).
    New PMS version already includes patch which can use higher CBRVideoBitrate= values. Install it and use eg. 60000 which will be better with CPU usage:
    https://github.com/ps3mediaserver/ps3me ... er/pull/22
  • vrc_maxrate=60000 says that MaxVideoBitrateMbps=?? is used in Panasonic.conf(Renderers folder) which degrades this CBR feature. New version has it already fixed 8-)
    When CBRVideoBitrate=?? is used, bandwidth limiting is ignored in new version so MaxVideoBitrateMbps is ignored so don't use it for this purpose but CBRVideoBitrate ;)
    It is because with CBRVideoBitrate enabled you will be able to limit bandwidth and also FF/RW will work. MaxVideoBitrateMbps limits bitrate only
  • You should know what difference is between TRANSCODING(MENcoder engine) and Remuxing(tsMuxeR engine). If your CPU or network is poor and you don't need subtitles, use tsMuxeR engine which changes container only MKV->M2TS so requirements for CPU is low
I will make some modifications to Panasonic.conf file (instead of using 15000, 60000 will be much better) and will try to publish it to official version so people will know the precedence of CBR value when it is set so better to ignore "MaxVideoBitrateMbps" parameter in this case :idea:
Hope it helps
ExSport
 
Posts: 2167
Joined: Mon Jan 19, 2009 5:40 pm

Re: Videos (MKV and AVI) are lagging on Panasonic TX-P50VT30

Postby gabychou » Sat Mar 31, 2012 9:34 am

Wow... I must confess I didn't get everything you explained... :)
I've downloaded the version you advised, but didn't understand if I had to modify some options, in the GUI or in config files :?
Anyway, the result is the same : 100% CPU when reading MKV files...

Thanks again
gabychou
 
Posts: 5
Joined: Thu Mar 29, 2012 10:27 pm

Re: Videos (MKV and AVI) are lagging on Panasonic TX-P50VT30

Postby ExSport » Sat Mar 31, 2012 11:27 am

In your installation folder, find RENDERERS folder and edit this file: Panasonic.conf
Replace here line CBRVideoBitrate=15000 with CBRVideoBitrate=60000
That CPU is used at 100% it is normal when MEncoder engine is used because video is re-encoded on the fly.
In PMS GUI there is "Transcode buffer maximum size". It is used to preencode your file to memory so your renderer is feeded in time. On the status page you can see how buffer grow or not.
If it doesn't grow, it means your CPU can't reencode your video in realtime so it will stutter on your renderer because of that.
If you don't need subtitles, you can use txMuxeR engine (for MKV) which only remuxes video(no reencoding/transcoding but it changes container only) so CPU is almost not needed.
Browse to #TRANSCODE# folder where you will see more options how to play your movie ;)
ExSport
 
Posts: 2167
Joined: Mon Jan 19, 2009 5:40 pm

Re: Videos (MKV and AVI) are lagging on Panasonic TX-P50VT30

Postby gabychou » Sun Apr 01, 2012 9:59 pm

OK, found the file, I've modified it, but it doesn't work any better (it's much worse actually, video stuck and there is no sound) :

Code: Select all
[mencoder.exe-12] DEBUG 2012-04-01 22:51:56.726 Starting "C:\Program Files (x86)\PS3 Media Server\win32\mencoder.exe" -ss 0 -quiet D:\VIDOS~1\SRIES~1\Fringe\FRINGE~1.MKV -quiet -quiet -oac copy -of mpeg -quiet -quiet -mpegopts format=mpeg2:muxrate=500000:vbuf_size=1194:abuf_size=64 -ovc lavc -channels 2 -vf softskip,expand=::::1:16/9:4 -lavdopts debug=0:threads=2 -lavcopts autoaspect=1:vcodec=mpeg2video:vrc_buf_size=5000:vrc_minrate=60000:vrc_maxrate=60000:vbitrate=60000000:acodec=ac3:abitrate=448:threads=2:keyint=5:vqscale=1:vqmin=3:vqmax=5 -font C:\Windows\Fonts\Arial.ttf -subfont-text-scale 3 -subfont-outline 1 -subfont-blur 1 -subpos 98 -fontconfig -subcp cp1252 -quiet -quiet -sid 100 -quiet -quiet -ofps 24000/1001 -sub D:\VIDOS~1\SRIES~1\Fringe\FRINGE~1.SRT -lavdopts fast -mc 0 -noskip -af lavcresample=48000 -srate 48000 -o \\.\pipe\mencoder1333313515180
[mencoder.exe-12] DEBUG 2012-04-01 22:51:56.895 Reading pipe: \\.\pipe\mencoder1333313515180
[mencoder.exe-12] DEBUG 2012-04-01 22:51:56.895 Attaching thread: mencoder.exe-12
[New I/O server worker #1-2] DEBUG 2012-04-01 22:51:57.326 Forcing short path name on D:\Vidéos\Séries\Fringe\Fringe - 04x16 - Nothing As It Seems.mkv
[StartPlaying Event] DEBUG 2012-04-01 22:51:57.329 Forcing short path name on D:\Vidéos\Séries\Fringe\Fringe - 04x16 - Nothing As It Seems.mkv
[StartPlaying Event] INFO  2012-04-01 22:51:57.329 renderer: 192.168.1.2, file: D:\VIDOS~1\SRIES~1\Fringe\FRINGE~1.MKV
[Thread-62] DEBUG 2012-04-01 22:51:57.574 MEncoder SB28 (C) 2000-2012 MPlayer Team
[Thread-62] DEBUG 2012-04-01 22:51:57.575 Custom build by SubJunk, http://www.spirton.com
[Thread-62] DEBUG 2012-04-01 22:51:57.575
[Thread-62] DEBUG 2012-04-01 22:51:57.575 success: format: 0  data: 0x0 - 0x4359c817
[Thread-62] DEBUG 2012-04-01 22:51:57.575 libavformat version 54.2.100 (internal)
[Thread-62] DEBUG 2012-04-01 22:51:57.575 libavformat file format detected.
[Thread-62] DEBUG 2012-04-01 22:51:57.579 [lavf] stream 0: video (h264), -vid 0
[Thread-62] DEBUG 2012-04-01 22:51:57.579 [lavf] stream 1: audio (ac3), -aid 0
[Thread-62] DEBUG 2012-04-01 22:51:57.580 VIDEO:  [H264]  1280x720  0bpp  23.976 fps    0.0 kbps ( 0.0 kbyte/s)
[Thread-62] DEBUG 2012-04-01 22:51:57.580 [V] filefmt:44  fourcc:0x34363248  size:1280x720  fps:23.976  ftime:=0.0417
[Thread-58] DEBUG 2012-04-01 22:51:57.580 Result of \\.\pipe\mencoder1333313515180 : true
[Thread-62] DEBUG 2012-04-01 22:51:57.581 PACKET SIZE: 2048 bytes, deltascr: 884
[Thread-62] DEBUG 2012-04-01 22:51:57.582 libavcodec version 54.10.100 (internal)
[Thread-62] DEBUG 2012-04-01 22:51:57.582 Opening video filter: [expand osd=1]
[Thread-62] DEBUG 2012-04-01 22:51:57.582 Expand: -1 x -1, -1 ; -1, osd: 1, aspect: 0.000000, round: 1
[Thread-62] DEBUG 2012-04-01 22:51:57.582 Opening video filter: [expand osd=1 aspect=16/9 round=4]
[Thread-62] DEBUG 2012-04-01 22:51:57.582 Expand: -1 x -1, -1 ; -1, osd: 1, aspect: 1.777778, round: 4
[Thread-62] DEBUG 2012-04-01 22:51:57.582 Opening video filter: [softskip]
[Thread-62] DEBUG 2012-04-01 22:51:57.591 ==========================================================================
[Thread-62] DEBUG 2012-04-01 22:51:57.593 Opening video decoder: [ffmpeg] FFmpeg's libavcodec codec family
[Thread-62] DEBUG 2012-04-01 22:51:57.594 Selected video codec: [ffh264] vfm: ffmpeg (FFmpeg H.264)
[Thread-62] DEBUG 2012-04-01 22:51:57.594 ==========================================================================
[Thread-62] DEBUG 2012-04-01 22:51:57.595 audiocodec: framecopy (format=2000 chans=2 rate=48000 bits=0 B/s=48000 sample-0)
[Thread-61] DEBUG 2012-04-01 22:51:57.595 Limiting audio preload to 0.4s.
[Thread-61] DEBUG 2012-04-01 22:51:57.595 Increasing audio density to 4.
[Thread-61] DEBUG 2012-04-01 22:51:58.016
[Thread-61] DEBUG 2012-04-01 22:51:58.016 Too many video packets in the buffer: (1486 in 33572365 bytes).
[Thread-61] DEBUG 2012-04-01 22:51:58.016 Unsupported PixelFormat 61
[Thread-61] DEBUG 2012-04-01 22:51:58.016 Unsupported PixelFormat 53
[Thread-61] DEBUG 2012-04-01 22:51:58.016 Unsupported PixelFormat 81
[Thread-62] DEBUG 2012-04-01 22:51:58.016 Maybe you are playing a non-interleaved stream/file or the codec failed?
[Thread-62] DEBUG 2012-04-01 22:51:58.016 For AVI files, try to force non-interleaved mode with the -ni option.
[Thread-62] DEBUG 2012-04-01 22:51:58.030 Movie-Aspect is 1.78:1 - prescaling to correct movie aspect.
[Thread-62] DEBUG 2012-04-01 22:51:58.030 videocodec: libavcodec (1280x720 fourcc=3267706d [mpg2])
[Thread-62] DEBUG 2012-04-01 22:51:58.030 [VE_LAVC] Using constant qscale = 1.000000 (VBR).
[Thread-62] DEBUG 2012-04-01 22:51:58.296 Writing header...
[Thread-62] DEBUG 2012-04-01 22:51:58.300 INITV: 0.200, 0.158, fps: 23.976
[Thread-62] DEBUG 2012-04-01 22:51:58.300
[New I/O server worker #1-2] DEBUG 2012-04-01 22:52:36.665 Setting margin to 2Mb


My CPU seems ton be able to reencode the video though, buffer is used.

Too bad, since I do need the subtitles... but I've succeeded to make serviio works the way I needed, so I think I'll stay with it.

Thanks a lot
gabychou
 
Posts: 5
Joined: Thu Mar 29, 2012 10:27 pm


Return to Alternative Media Renderers

Who is online

Users browsing this forum: Exabot [Bot] and 4 guests