Strange network issue with XBox360

Discuss alternative media renderers (not PS3) supported by PS3 Media Server (e.g. Xbox 360, TVs &c.)

Strange network issue with XBox360

Postby Val Killmore » Tue Feb 28, 2012 8:56 am


When I stream to one of my XBox 360's, I get an annoying tick.....tick......tick to all videos that are transcoded. The issue is not Java heap related as I have compensated by adjusting both PMS servers to run Java heap at 1200MB, and only seems to occur really noticeably with the one XBox (B). It is not a typical stutter where the audio and video drop or stop simultaneously, or where the video eventually goes out of sync. It is not an issue of the buffer running out, as I always pause movies for a few minutes before watching them on either Xbox360, and I have verified by running as a task and viewing the GUI. This problem occurs whether run as a service, or run as a task, and both servers have Java heap value adjusted for task and service. It just seems like either my 360, or PMS are dropping occasional frames to keep the audio and video from going out of sync. It would be fine if it wasn't so noticeable, especially in fast action scenes where a dropped frame is REALLY noticeable.

Using MEncoder

Network Layout that may be problem:

There are two 'sides' to my network with an 'N' bridge between them. I have PMS versions on both PC's and I have a WMP server on each PC. Both programs (PMS and WMP) are sharing the exact same folders on both PC's. Basically each side is a mirror of the other. I have a PS3 on the A side that I have excluded from description, that works flawlessly with virtually every thing I serve to it.

Side A: (living room hooked up to A/V receiver and 40" 1080P HDTV)

(XBox-A)<------Cat5e------>DIR-655 Extreme N 4-GB port router<------Cat5e------>(PC-A)(PMS SB-53)
'N' Wifi
Side B: (bedroom hooked to small 26" 720p TV thru built-in 2- channel speakers)

(Xbox-B)<------Cat5e------>DAP-1522 Bridge/AP w/4-GB ports<------>Cat5e<------(PC-B)(PMS SB-66)

The problem occurs on XBox-B, regardless if I use PC-A or PC-B PMS server.

What I have tried and checked:

-I have tried using the server on the same side of the bridge....IE using PC-B to serve to X-Box360-B with PMS. I get the annoying tick. I thought at first it was an issue with the 'N' wifi and the fact that some of the shared folders on the "A" side. But when I use the either WMP player (Shark007 codecs installed) from either side of the bridge to play the same videos to either 360, they stream flawlessly without the tick.....tick....tick.

- I have tried reducing video quality settings on both servers.

- I have tried capping the bandwidth limit thru various values on both servers, none of which have made a difference either.

- I have tried using the PC-A server to serve to Xbox-B using PMS. The tick.....tick....tick is present.

- I have tried serving using PMS on PC-B to serve to Xbox-A. The tick is present, but not quite as noticeable.

- I have tried serving using PC-A to serve to Xbox-A using PMS thru the router. This route does not 'cross' the bridge, and the tick is not present, which is fine, but redundant. In my living room, I use the PS3 for streaming for audio reasons and the fact the PS3 literally plays everything. XBox-A is only present for gaming in the living room.

- I have tried both 360's with native files (AVI tv shows and certain MP4's with 2 channel audio) from either side of the bridge, from both programs (PMS and WMP), and they all stream flawlessly, and full FF and RW is possible, as well as the segment skipping option the 360 has with native files. In other words, I haven't found a native file that has given me grief in any way.

- Netflix with the highest quality video settings streams flawlessly from across the "N" bridge to Xbox-B.

- I have tried all manners described using PMS as a task and as a service from either side of the network as well. Task or service seems to make no difference.

- According to my router, I am getting speeds above 100 Mbps across the bridge (usually around 160Mbps consistently), and all other network functions from gaming to Netflix, to streaming with WMP server, work great on the "B" side of the network.

What I have deduced:

The problem only seems to occur specifically:

When PMS is used to transcode video to an XBox, and if any data travels at any point across the "N" bridge OR thru the DAP-1522 network device itself the tick issue is present. It doesn't seem to matter the location of the share folder.

When WMP does it's thing to decode movie files, then serve to my Xbox's, even across the bridge, it is virtually flawless. I could simply use WMP, but I would really like to clean up my network, and get rid of one program or the other. And also I am sick of seeing the WMP servers on my PS3 XMB.... :x

And, as stated before, PMS serves perfectly to my PS3 so the likelihood it'll be PMS axed is pretty slim as the PS3 is setup to run full DTS thru my receiver in living room.

This problem has been present for me for some time, and other than the annoying tick, it seems PMS wants to play nearly all files. I just can't watch HD movies that make me think my brain is short circuiting.
Gonna try messing with QOS settings and see if they help, but I am not holding my breath. Perhaps if someone has seen this issue, and has any suggestions, I am all ears.
Val Killmore: Potato Chip Assassin
SubJunk53--Java 7u4--Acer Aspire 6930 2CoreDuo @ 2.00 GHz 3.00 GB RAM serving to : PS3 Slim -- 2 Xbox360
User avatar
Val Killmore
Posts: 712
Joined: Sun May 01, 2011 8:48 am

Return to Alternative Media Renderers

Who is online

Users browsing this forum: No registered users and 1 guest