Latest SVN build discussion

Download and discuss official beta builds here

Re: Latest SVN build discussion

Postby MKUltra » Fri Apr 27, 2012 12:54 am

Raptor399 wrote:
MKUltra wrote:Does anybody know which build of XCode 4.3 and Command Line Tools are needed to run the MPlayer Build Script? The Apple Developer Download page has multiple builds of each and I want to make sure I choose correctly. Thanks in advance.

Things broke severely when I switched to the XCode 4.3 app and its Command Line Tools.
If I remember correctly, I picked the bottom choice. But after that I needed to install a lot of things I didn't need to install before.
I did update the build script accordingly, though.

Let me know if it needs changing.


Thanks. Not sure what you mean when you say that you picked the "bottom choice. "
Mac Mini 2.26 GHz Intel Core 2 Duo 4 GB RAM OS 10.7.2/Airport Extreme Basestation (Early 2009) Wireless N/PS3-Fatboy 40GB/1Gibps via Cat 6 LAN connection w/ Airport Extreme/PS3 connected via HDMI to Denon AVR-3808CI
MKUltra
 
Posts: 75
Joined: Sun Aug 30, 2009 10:41 pm

Re: Latest SVN build discussion

Postby Raptor399 » Fri Apr 27, 2012 6:45 am

MKUltra wrote:Not sure what you mean when you say that you picked the "bottom choice. "

Neither did I at the time of writing. ;-)

So I opened up the Xcode 4.3 preferences and took a screenshot:

Image

Hope that helps!
Raptor399
Project Member
 
Posts: 1916
Joined: Thu Mar 10, 2011 12:06 am

Re: Latest SVN build discussion

Postby MKUltra » Fri Apr 27, 2012 1:40 pm

Thanks Raptor. Seems something went sideways for me. I installed XCode 4.3 with the Command Line Tools and let it uninstall the previous version 4.1, but now when I try to run the build script I get the following:

Code: Select all
It seems you are missing Xcode.

Please go to http://developer.apple.com/technologies/xcode.html, create a free
Apple developer account and download Xcode and install it. After installation,
install the "Command Line Tools" under "Preferences... > Downloads > Components".

****-mac-mini:contrib jahluv$ XCODE-SELECT -version
xcode-select version 2307.
***-mac-mini:contrib jahluv$


:!:
Mac Mini 2.26 GHz Intel Core 2 Duo 4 GB RAM OS 10.7.2/Airport Extreme Basestation (Early 2009) Wireless N/PS3-Fatboy 40GB/1Gibps via Cat 6 LAN connection w/ Airport Extreme/PS3 connected via HDMI to Denon AVR-3808CI
MKUltra
 
Posts: 75
Joined: Sun Aug 30, 2009 10:41 pm

Re: Latest SVN build discussion

Postby Raptor399 » Fri Apr 27, 2012 7:38 pm

The problem is a lot of tools that were shipped with earlier versions of Xcode were somehow not added to the Command Line Tools of Xcode 4.3. I have adapted the script to compensate for this a couple of commits ago.

Are you using the latest version of the script?
Raptor399
Project Member
 
Posts: 1916
Joined: Thu Mar 10, 2011 12:06 am

Re: Latest SVN build discussion

Postby MKUltra » Fri Apr 27, 2012 9:51 pm

Raptor399 wrote:The problem is a lot of tools that were shipped with earlier versions of Xcode were somehow not added to the Command Line Tools of Xcode 4.3. I have adapted the script to compensate for this a couple of commits ago.

Are you using the latest version of the script?


I am using the latest version of the script.
Mac Mini 2.26 GHz Intel Core 2 Duo 4 GB RAM OS 10.7.2/Airport Extreme Basestation (Early 2009) Wireless N/PS3-Fatboy 40GB/1Gibps via Cat 6 LAN connection w/ Airport Extreme/PS3 connected via HDMI to Denon AVR-3808CI
MKUltra
 
Posts: 75
Joined: Sun Aug 30, 2009 10:41 pm

Re: Latest SVN build discussion

Postby Raptor399 » Sat Apr 28, 2012 8:02 am

Then the message means that the developer SDK directories are missing.
Does either one of these directories exist:
Code: Select all
/Applications/Xcode.app/Contents/Developer/Platforms/MacOSX.platform/Developer/SDKs

or:
Code: Select all
/Developer/SDKs

If neither exists, try this to find the path on your computer:
Code: Select all
locate SDKs

If still nothing comes up, ehr... :-?
Raptor399
Project Member
 
Posts: 1916
Joined: Thu Mar 10, 2011 12:06 am

Re: Latest SVN build discussion

Postby MKUltra » Sat Apr 28, 2012 9:32 pm

I got XCode 4.3 to work but seems like I still need to have XCode 4.1 installed.

The build script aborts when trying to compile libmediainfo.

Code: Select all
./configure: line 17348: syntax error near unexpected token `TINYXML,'
./configure: line 17348: `   PKG_CHECK_MODULES(TINYXML, tinyxml)'
make: *** No targets specified and no makefile found.  Stop.
Fatal error occurred, aborting build.


So I skipped building libmediainfo, then Mplayer does not compile:

Code: Select all
/Users/***/***/ps3mediaserver/target/bin-tools/target/lib -lfreetype -lz -lbz2 -lfontconfig -lexpat -lfreetype -lfribidi -lenca -lz -lbz2 -llzo2 -lmad -ltheoradec -logg -ldca -lfaad -ldv -lxvidcore      -lx264  -lmp3lame
Undefined symbols for architecture i386:
  "_MM_FIX_0_707106781", referenced from:
      _filter in vf_fspp.o
  "_MM_FIX_0_541196100", referenced from:
      _filter in vf_fspp.o
ld: symbol(s) not found for architecture i386
collect2: ld returned 1 exit status
make: *** [mencoder] Error 1
make: *** Waiting for unfinished jobs....
Undefined symbols for architecture i386:
  "_MM_FIX_0_707106781", referenced from:
      _filter in vf_fspp.o
  "_MM_FIX_0_541196100", referenced from:
      _filter in vf_fspp.o
ld: symbol(s) not found for architecture i386
collect2: ld returned 1 exit status
make: *** [mplayer] Error 1
Fatal error occurred, aborting build.


:!:
Mac Mini 2.26 GHz Intel Core 2 Duo 4 GB RAM OS 10.7.2/Airport Extreme Basestation (Early 2009) Wireless N/PS3-Fatboy 40GB/1Gibps via Cat 6 LAN connection w/ Airport Extreme/PS3 connected via HDMI to Denon AVR-3808CI
MKUltra
 
Posts: 75
Joined: Sun Aug 30, 2009 10:41 pm

Re: Latest SVN build discussion

Postby Raptor399 » Tue May 01, 2012 7:52 am

Yep, same thing is happening here with the same errors.
Haven't found a solution yet. :-|
Raptor399
Project Member
 
Posts: 1916
Joined: Thu Mar 10, 2011 12:06 am

Re: Latest SVN build discussion

Postby MKUltra » Tue May 01, 2012 2:37 pm

Raptor399 wrote:Yep, same thing is happening here with the same errors.
Haven't found a solution yet. :-|


Same issue for the SB32 build script. I should point out that libmediainfo 0.7.56 will compile with libzen 0.4.26 and zlib 1.2.6
Mac Mini 2.26 GHz Intel Core 2 Duo 4 GB RAM OS 10.7.2/Airport Extreme Basestation (Early 2009) Wireless N/PS3-Fatboy 40GB/1Gibps via Cat 6 LAN connection w/ Airport Extreme/PS3 connected via HDMI to Denon AVR-3808CI
MKUltra
 
Posts: 75
Joined: Sun Aug 30, 2009 10:41 pm

Re: Latest SVN build discussion

Postby Raptor399 » Tue May 01, 2012 7:39 pm

MKUltra wrote:Same issue for the SB32 build script. I should point out that libmediainfo 0.7.56 will compile with libzen 0.4.26 and zlib 1.2.6

Hrmmm, not here. I changed the version numbers, downloaded the new sources and rebuilt everything from scratch, but MediaInfo still bombs out:

Code: Select all
checking zlib.h usability... yes
checking zlib.h presence... yes
checking for zlib.h... yes
./configure: line 16970: syntax error near unexpected token `TINYXML,'
./configure: line 16970: `   PKG_CHECK_MODULES(TINYXML, tinyxml)'
make: *** No targets specified and no makefile found.  Stop.
Fatal error occurred, aborting build.
Raptor399
Project Member
 
Posts: 1916
Joined: Thu Mar 10, 2011 12:06 am

Previous

Return to Beta Builds

Who is online

Users browsing this forum: No registered users and 1 guest