pms-mlx (2014-09-24 v1.1.0)

Download and discuss official beta builds here

Re: pms-mlx (2014-09-24 v1.1.0)

Postby taconaut » Fri Oct 03, 2014 3:52 pm

I might have found it! The reference frame count, which causes those two different log entries, has been added while merging the code 27.08.2013 (this was a huge merge!). It is not being stored in the pms-mlx db and thus not used. I'll have to check if other properties like that have been added, which I've missed.
But now it's Friday evening and time for a beer :)CHeers
If you always wanted to have your most recent videos at the top of the folder in the ps3 or wished you could group all videos with the same genre in one folder, have a look at pms-mlx
taconaut
Project Member
 
Posts: 1112
Joined: Sat Apr 11, 2009 12:29 am
Location: Switzerland
Top

Re: pms-mlx (2014-09-24 v1.1.0)

Postby chach » Fri Oct 03, 2014 4:33 pm

yes, cheers. Thank you

i go now with my girl friend to lunch ...

see u
Jan
chach
 
Posts: 57
Joined: Tue Mar 24, 2009 12:40 pm
Top

Re: pms-mlx (2014-09-24 v1.1.0)

Postby taconaut » Tue Oct 07, 2014 10:34 am

@chach

I've implemented the changes and pms-mlx should now transcode all the files the same way as pms again. I've created an issue for this; as you can see, the last point is missing, that's why the library has currently to be recreated. It would be great if you could confirm that it is working.

To test:
- Launch pms-mlx and look for the line '[net.pms.PMS.main()] INFO 2014-10-07 11:19:44.938 Medialibrary database location = ...' in the logs
- Close pms-mlx and rename the db folder. (You can restore it after having tested)
- Download 'pms-packaging-1.90.2-mlx-1.1.1-SNAPSHOT-jar-with-dependencies.jar' from here and rename it to pms.jar
- Replace pms.jar in your App. (Backup the original one if you want)
- Scan the files you want to test and play them
If you always wanted to have your most recent videos at the top of the folder in the ps3 or wished you could group all videos with the same genre in one folder, have a look at pms-mlx
taconaut
Project Member
 
Posts: 1112
Joined: Sat Apr 11, 2009 12:29 am
Location: Switzerland
Top

Re: pms-mlx (2014-09-24 v1.1.0)

Postby chach » Tue Oct 07, 2014 1:43 pm

hi taconaut,

thanks i will test it when i have time i think this is at the weekend sorry heavy workload :(.
Anyway something is wrong with my Library in the Log he shows me some Java errors. not found..... etc.
I will refreshing the db :)

In your PMS MLX.app i have only a pms-core.jar file not an pms.jar is this the correct one ? Or is it not correct Installed ?
Is your Link correct ? localhost ? :)

Regards,
Jan
chach
 
Posts: 57
Joined: Tue Mar 24, 2009 12:40 pm
Top

Re: pms-mlx (2014-09-24 v1.1.0)

Postby taconaut » Tue Oct 07, 2014 1:48 pm

No hurry :)
Yep pms-core.jar is the right one.
The link was of course wrong hehe, I've corrected it.
If you always wanted to have your most recent videos at the top of the folder in the ps3 or wished you could group all videos with the same genre in one folder, have a look at pms-mlx
taconaut
Project Member
 
Posts: 1112
Joined: Sat Apr 11, 2009 12:29 am
Location: Switzerland
Top

Re: pms-mlx (2014-09-24 v1.1.0)

Postby chach » Sat Oct 11, 2014 6:23 pm

hi taconaut,

i have test it and the snapshot works very Great. You can close the issue :))) with success.
I recreate the Library without errors and the problem with tsmuxer is gone away ... tha tha thank you.

By the Way i found 3 other bugs :)*g*
1 library timer not refreshing at the deleting only on restart but for importing he refreshing :(

2 its bette to save the library-tree and the library-settings in an extra file of the db for Backup. When i delete the db with the videos i have to recreate them, too :(.

3 when i have a file-error (pms-mlx import not correctly and cannot read) in the library-db the log not display the file and i have to renew the hole library.

and two Questions when i delete a file in the library the name is only show in the debug.log not in the log of pms-mlx is this correct ?
and i cannot sort by tags for Series :(is this also correct ?

sorry bis dann ...
Jan thanks you so much
chach
 
Posts: 57
Joined: Tue Mar 24, 2009 12:40 pm
Top

Re: pms-mlx (2014-09-24 v1.1.0)

Postby taconaut » Mon Oct 13, 2014 9:45 am

chach wrote:i have test it and the snapshot works very Great. You can close the issue :))) with success.
I recreate the Library without errors and the problem with tsmuxer is gone away ... tha tha thank you.

Thanks for testing! Glad it works :)

chach wrote:1 library timer not refreshing at the deleting only on restart but for importing he refreshing :(

I'll check that (issue)

chach wrote:2 its bette to save the library-tree and the library-settings in an extra file of the db for Backup. When i delete the db with the videos i have to recreate them, too :(.

I know, sorry about that. There is an old issue which would solve this. Once the feature is finished, the DB will be updated automatically and it wont be required to make a new configuration; this was just for testing.

chach wrote:3 when i have a file-error (pms-mlx import not correctly and cannot read) in the library-db the log not display the file and i have to renew the hole library.

Could you please post the exception shown in the log for me to understand what's going on?

chach wrote:when i delete a file in the library the name is only show in the debug.log not in the log of pms-mlx is this correct ?

As it is being logged with level INFO, you should have it in the log as well as in the console.

chach wrote:and i cannot sort by tags for Series :(is this also correct ?

This is correct. TheTVDB plugin sets the 'Sort Name' field with 'seee' (e.g. 1001 for season 1 episode 1) for that. If you can explain what you want to do, I might have an idea how to achieve it :)

Cheers
If you always wanted to have your most recent videos at the top of the folder in the ps3 or wished you could group all videos with the same genre in one folder, have a look at pms-mlx
taconaut
Project Member
 
Posts: 1112
Joined: Sat Apr 11, 2009 12:29 am
Location: Switzerland
Top

Re: pms-mlx (2014-09-24 v1.1.0)

Postby chach » Tue Oct 14, 2014 8:49 am

taconaut wrote:Thanks for testing! Glad it works :)

PMS-MLX where great almost like as Xbox1 with XBMC :)

taconaut wrote:Could you please post the exception shown in the log for me to understand what's going on?

when i have the error again , i will let you now.

taconaut wrote:As it is being logged with level INFO, you should have it in the log as well as in the console.

I think in the gui i dont see it but i look again or have i change the log level of pms-mlx to INFO or DEBUG ?

taconaut wrote:This is correct. TheTVDB plugin sets the 'Sort Name' field with 'seee' (e.g. 1001 for season 1 episode 1) for that. If you can explain what you want to do, I might have an idea how to achieve it :)

I have to sort the series with tags (EpisodesNumber and SeasonNumber) not filename because its sometimes different and the Name of the Episode from TheTVDB plugin is not unique.

taconaut wrote:Cheers

Cheers, too
Jan
chach
 
Posts: 57
Joined: Tue Mar 24, 2009 12:40 pm
Top

Re: pms-mlx (2014-09-24 v1.1.0)

Postby taconaut » Wed Oct 15, 2014 8:35 am

chach wrote:I think in the gui i dont see it but i look again or have i change the log level of pms-mlx to INFO or DEBUG ?
As the message is being logged with INFO level and the log tab shows log entries for INFO and above, it should be there.

chach wrote:I have to sort the series with tags (EpisodesNumber and SeasonNumber) not filename because its sometimes different and the Name of the Episode from TheTVDB plugin is not unique.
This is precisely the reason why TheTVDB plugin had been modified to set the sort name including the season and episode number. Try sorting on this field and you should be fine :)
If you always wanted to have your most recent videos at the top of the folder in the ps3 or wished you could group all videos with the same genre in one folder, have a look at pms-mlx
taconaut
Project Member
 
Posts: 1112
Joined: Sat Apr 11, 2009 12:29 am
Location: Switzerland
Top

Re: pms-mlx (13-12-04 v1.0)

Postby Raketemensch » Fri Oct 17, 2014 7:30 pm

tonyv138 wrote:No worries, thanks. you got me moving in the right direction. I think it was working out of the box, i just needed to set transcoding and it worked on PS3 and Sony BDP520. I played SPOTIFY on both.
Appreciate your help!


How are you getting Spotify to work? Are you using libspotify?
Raketemensch
 
Posts: 3
Joined: Mon Mar 10, 2014 12:58 am
Top

PreviousNext

Return to Beta Builds

Who is online

Users browsing this forum: No registered users and 3 guests