PMS SubJunk Build

Download and discuss official beta builds here

Re: PMS SubJunk Build 69 (Updated 2012-04-02)

Postby Serenus » Sun Apr 08, 2012 1:43 am

Half of the mp4 files I tried to stream via the PS3 MS won't play on my Sony Bravia KDL-40EX405, it loads a black screen and if I pop out the timeline it keeps skeeping forward 3 seconds, anything I could do to help troubleshoot it?
Serenus
 
Posts: 4
Joined: Mon Jan 03, 2011 5:04 pm

Re: PMS SubJunk Build 69 (Updated 2012-04-02)

Postby slooff » Sun Apr 08, 2012 11:03 am

quick question: which PMS.conf parameter controls the Alternate A/V sync? I am using PMS in a headless config so have no access to the GUI like most of you ;-)
opensuse 12.1, latest PMS build, mplayer/mencoder with static libraries, movieinfo, pmsencoder, edl plugin, PS3, XBOX, Samsung ES7000
slooff
 
Posts: 54
Joined: Fri Dec 11, 2009 11:28 am

Re: PMS SubJunk Build 69 (Updated 2012-04-02)

Postby SubJunk » Sun Apr 08, 2012 11:34 am

mencoder_nooutofsync = true or false
SubJunk
 
Posts: 1210
Joined: Fri Mar 27, 2009 5:25 am

Re: PMS SubJunk Build 69 (Updated 2012-04-02)

Postby acme64 » Mon Apr 09, 2012 12:21 am

I can't run the program, i click it and nothing happens. No errors or anything, wtf?

edit: reinstall of java 6 and 7 fixed it.
acme64
 
Posts: 4
Joined: Wed Jan 26, 2011 1:14 am

Re: PMS SubJunk Build 69 (Updated 2012-04-02)

Postby slooff » Mon Apr 09, 2012 1:44 pm

SubJunk wrote:mencoder_nooutofsync = true or false

Thanks! True is the current default I assume?
opensuse 12.1, latest PMS build, mplayer/mencoder with static libraries, movieinfo, pmsencoder, edl plugin, PS3, XBOX, Samsung ES7000
slooff
 
Posts: 54
Joined: Fri Dec 11, 2009 11:28 am

Re: PMS SubJunk Build 69 (Updated 2012-04-02)

Postby squadjot » Mon Apr 09, 2012 6:28 pm

acme64 wrote:I can't run the program, i click it and nothing happens. No errors or anything, wtf?

edit: reinstall of java 6 and 7 fixed it.


We need both 6 and 7 installed?
User avatar
squadjot
 
Posts: 243
Joined: Thu Mar 25, 2010 10:03 pm

Re: PMS SubJunk Build 69 (Updated 2012-04-02)

Postby SubJunk » Mon Apr 09, 2012 10:42 pm

slooff wrote:
SubJunk wrote:mencoder_nooutofsync = true or false

Thanks! True is the current default I assume?
Yes, true is default.

squadjot wrote:
acme64 wrote:I can't run the program, i click it and nothing happens. No errors or anything, wtf?

edit: reinstall of java 6 and 7 fixed it.


We need both 6 and 7 installed?
No, just one of them.
SubJunk
 
Posts: 1210
Joined: Fri Mar 27, 2009 5:25 am

Re: PMS SubJunk Build 70 (Updated 2012-04-10)

Postby SubJunk » Tue Apr 10, 2012 9:46 am

SB70 is released. This updates to the latest code and uses a new build of MPlayer/MEncoder which improves buffering and ASS/SSA subtitle handling
SubJunk
 
Posts: 1210
Joined: Fri Mar 27, 2009 5:25 am

Re: PMS SubJunk Build 69 (Updated 2012-04-02)

Postby SubJunk » Tue Apr 10, 2012 12:26 pm

ExSport wrote:Can you post few samples where you can reproduce unsynced audio when Alternate A/V sync is disabled but it works OK when enabled?
It happens with every scene release I've tried.

One I just tried is Stargate.Universe.S02E02.720p.HDTV.x264-IMMERSE.
Convert the whole episode using both:

Code: Select all
mencoder input.mkv -oac lavc -of mpeg -mpegopts format=mpeg2:muxrate=500000:vbuf_size=1194:abuf_size=64 -ovc lavc -channels 2 -lavdopts debug=0:threads=8 -lavcopts autoaspect=1:vcodec=mpeg2video:acodec=ac3:abitrate=448:threads=8:keyint=25:vqscale=1:vqmin=2:vrc_maxrate=54000:vrc_buf_size=1835 -ofps 24000/1001 -lavdopts fast -mc 0 -noskip -af lavcresample=48000 -srate 48000 -o noskip.mkv

and
Code: Select all
mencoder input.mkv -oac lavc -of mpeg -mpegopts format=mpeg2:muxrate=500000:vbuf_size=1194:abuf_size=64 -ovc lavc -channels 2 -lavdopts debug=0:threads=8 -lavcopts autoaspect=1:vcodec=mpeg2video:acodec=ac3:abitrate=448:threads=8:keyint=25:vqscale=1:vqmin=2:vrc_maxrate=54000:vrc_buf_size=1835 -ofps 24000/1001 -lavdopts fast -af lavcresample=48000 -srate 48000 -o default.mkv


Then go to around 27:30 of the output files, since the sync can take minutes to go out. In the one without noskip (alternative a/v sync disabled) the audio is 200ms behind at that scene. If you play in VLC, push "k" 4 times to see that the sync is better with a 200ms delay. In the file with noskip it's perfect.
SubJunk
 
Posts: 1210
Joined: Fri Mar 27, 2009 5:25 am

Re: PMS SubJunk Build 70 (Updated 2012-04-10)

Postby Butman » Wed Apr 11, 2012 6:29 am

Hi Val Killmore,

Sorry for the vague post. Yes, I am still experiencing issues (when transcoding subs). I went to the FAQ regarding skipping and increased my heap in the PMS.bat to 2048 (javaw -Xmx2048M) but has not changed anything. However, the last test I did of Bolt got me to 3:45 of the movie before skipping about 15 min.

Here's part of my debug log if this helps to see what's going on.

Code: Select all
DEBUG 2012-04-11 00:55:47.793 [New I/O server worker #1-1] Requesting time seek: 531.431 seconds
DEBUG 2012-04-11 00:55:47.797 [External Process Stopper] Stopping process: mencoder.exe-136
DEBUG 2012-04-11 00:55:47.813 [New I/O server worker #1-1] Creating pipe \\.\pipe\mencoder1334120147813
DEBUG 2012-04-11 00:55:47.820 [Thread-580] Waiting for pipe connection \\.\pipe\mencoder1334120147813
DEBUG 2012-04-11 00:55:47.870 [mencoder.exe-137] Starting "E:\Program Files (x86)\PS3 Media Server\win32\mencoder.exe" -ss 531.431 -quiet L:\Video\PS3\Video\Movies\Family\Bolt.mkv -quiet -quiet -oac lavc -of mpeg -quiet -quiet -mpegopts format=mpeg2:muxrate=500000:vbuf_size=1194:abuf_size=64 -ovc lavc -channels 6 -lavdopts debug=0:threads=4 -lavcopts autoaspect=1:vcodec=mpeg2video:acodec=ac3:abitrate=384:threads=4:keyint=25:vqmax=8:vqmin=3:vrc_maxrate=9000:vrc_buf_size=3333 -ass -ass-color ffffff00 -ass-border-color 00000000 -ass-font-scale 1.5 -font E:\Windows\Fonts\Arial.ttf -ass-force-style FontName=E:\Windows\Fonts\Arial.ttf,Outline=1,Shadow=1,MarginV=5 -noflip-hebrew -nofontconfig -quiet -quiet -sid 100 -quiet -quiet -ofps 24000/1001 -sub L:\Video\PS3\Video\Movies\Family\Bolt.srt -utf8 -lavdopts fast -af lavcresample=48000 -srate 48000 -o \\.\pipe\mencoder1334120147813
DEBUG 2012-04-11 00:55:47.872 [mencoder.exe-137] Reading pipe: \\.\pipe\mencoder1334120147813
DEBUG 2012-04-11 00:55:47.872 [mencoder.exe-137] Attaching thread: mencoder.exe-137
DEBUG 2012-04-11 00:55:47.911 [Thread-584] MEncoder SB30 (C) 2000-2012 MPlayer Team
DEBUG 2012-04-11 00:55:47.911 [Thread-584] Custom build by SubJunk, http://www.spirton.com
DEBUG 2012-04-11 00:55:47.911 [Thread-584]
DEBUG 2012-04-11 00:55:47.916 [Thread-584] success: format: 0  data: 0x0 - 0x16bd10d9
DEBUG 2012-04-11 00:55:47.916 [Thread-584] libavformat version 54.3.100 (internal)
DEBUG 2012-04-11 00:55:47.917 [Thread-584] libavformat file format detected.
DEBUG 2012-04-11 00:55:47.940 [Thread-584] [lavf] stream 0: video (h264), -vid 0
DEBUG 2012-04-11 00:55:47.940 [Thread-584] [lavf] stream 1: audio (dca), -aid 0
DEBUG 2012-04-11 00:55:47.940 [Thread-584] VIDEO:  [H264]  1280x720  0bpp  23.976 fps    0.0 kbps ( 0.0 kbyte/s)
DEBUG 2012-04-11 00:55:47.940 [Thread-584] [V] filefmt:44  fourcc:0x34363248  size:1280x720  fps:23.976  ftime:=0.0417
DEBUG 2012-04-11 00:55:47.940 [Thread-584] ==========================================================================
DEBUG 2012-04-11 00:55:47.941 [Thread-584] Opening audio decoder: [ffmpeg] FFmpeg/libavcodec audio decoders
DEBUG 2012-04-11 00:55:47.941 [Thread-584] libavcodec version 54.14.100 (internal)
DEBUG 2012-04-11 00:55:47.941 [Thread-584] AUDIO: 48000 Hz, 6 ch, s16le, 1536.0 kbit/33.33% (ratio: 192000->576000)
DEBUG 2012-04-11 00:55:47.941 [Thread-584] Selected audio codec: [ffdca] afm: ffmpeg (FFmpeg DTS)
DEBUG 2012-04-11 00:55:47.941 [Thread-584] ==========================================================================
DEBUG 2012-04-11 00:55:47.941 [Thread-580] Result of \\.\pipe\mencoder1334120147813 : true
DEBUG 2012-04-11 00:55:47.942 [Thread-584] PACKET SIZE: 2048 bytes, deltascr: 884
DEBUG 2012-04-11 00:55:47.942 [Thread-584] Opening video filter: [ass auto=1]
DEBUG 2012-04-11 00:55:47.942 [Thread-584] [ass] auto-open
DEBUG 2012-04-11 00:55:47.973 [Thread-584] ==========================================================================
DEBUG 2012-04-11 00:55:47.974 [Thread-584] Opening video decoder: [ffmpeg] FFmpeg's libavcodec codec family
DEBUG 2012-04-11 00:55:47.977 [Thread-584] Selected video codec: [ffh264] vfm: ffmpeg (FFmpeg H.264)
DEBUG 2012-04-11 00:55:47.977 [Thread-584] ==========================================================================
DEBUG 2012-04-11 00:55:47.978 [Thread-583] [ac3 @ 010bb9e0]channel_layout not specified
DEBUG 2012-04-11 00:55:47.978 [Thread-583] [ac3 @ 010bb9e0]No channel layout specified. The encoder will guess the layout, but it might be incorrect.
DEBUG 2012-04-11 00:55:47.996 [Thread-583] Limiting audio preload to 0.4s.
DEBUG 2012-04-11 00:55:47.996 [Thread-583] Increasing audio density to 4.
DEBUG 2012-04-11 00:55:48.029 [Thread-583] Unsupported PixelFormat 61
DEBUG 2012-04-11 00:55:48.029 [Thread-583] Unsupported PixelFormat 53
DEBUG 2012-04-11 00:55:48.029 [Thread-583] Unsupported PixelFormat 81
DEBUG 2012-04-11 00:55:48.034 [Thread-583] Muxer frame buffer cannot allocate memory!
DEBUG 2012-04-11 00:55:48.051 [Thread-583] Muxer frame buffer cannot allocate memory!
DEBUG 2012-04-11 00:55:48.051 [Thread-583] Muxer frame buffer cannot allocate memory!
DEBUG 2012-04-11 00:55:48.053 [Thread-584] Movie-Aspect is 1.78:1 - prescaling to correct movie aspect.
DEBUG 2012-04-11 00:55:48.053 [Thread-584] videocodec: libavcodec (1280x720 fourcc=3267706d [mpg2])
DEBUG 2012-04-11 00:55:48.061 [Thread-583] [ass] PlayResX undefined, setting to 384
DEBUG 2012-04-11 00:55:48.062 [Thread-583] Muxer frame buffer cannot allocate memory!
DEBUG 2012-04-11 00:55:48.076 [Thread-584] Writing header...
DEBUG 2012-04-11 00:55:48.076 [Thread-584] INITV: 0.200, 0.158, fps: 23.976
DEBUG 2012-04-11 00:55:48.076 [Thread-584]
DEBUG 2012-04-11 00:56:05.551 [Thread-580] Cannot grow buffer size from 50,000,000 bytes to 419,430,400 bytes.
Butman
 
Posts: 10
Joined: Wed Apr 04, 2012 4:20 am

PreviousNext

Return to Beta Builds

Who is online

Users browsing this forum: No registered users and 1 guest