PMS SubJunk Build

Download and discuss official beta builds here

Re: PMS SubJunk Build 66 (Updated 2012-02-15)

Postby glenrocks » Wed Feb 22, 2012 12:08 am

Hi- I downloaded build SB 66 x86 windows and am having problem with mencoder-2 but SB 61 mencoder works perfectly..any idea as I tried to compare both constructed commands and I get same error from command line too.. SB66 saying "Cannot open demuxer"..Maybe something to do with IPv6 or just new mencoder-2?

Attaching SB66 as zip and SB61 working command is:
Code: Select all
Starting C:\Program Files\PS3 Media Server-SHB\win32\mencoder.exe -msglevel all=2 -quiet -prefer-ipv4 -oac lavc -of lavf -lavfopts format=dvd -ovc lavc -lavcopts vcodec=mpeg2video:vbitrate=4096:threads=2:acodec=ac3:abitrate=128 -ofps 25 -cache 16384 -vf harddup -user-agent QuickTime/7.6.2 -o \\.\pipe\pmsencoder_transcoder_out_1329865240959_88 "http://trailers.apple.com/movies/sony_pictures/residentevilretribution/residentevil-tlr1_a720p.m4v"
Attachments
debug-error.zip
mencoder-2 SB66
(1.32 KiB) Downloaded 36 times
glenrocks
 
Posts: 89
Joined: Sun Aug 21, 2011 5:06 pm

Re: PMS SubJunk Build 66 (Updated 2012-02-15)

Postby TCr82 » Sat Feb 25, 2012 1:07 pm

Hi,

I had on Ubuntu 12.04 (precise) the follow error:

Code: Select all
[main] WARN  13:10:04.258 Error loading libzen: Unable to load library 'zen': libzen.so: cannot open shared object file: No such file or directory
[main] INFO  13:10:04.259 Loading MediaInfo library
[main] INFO  13:10:04.274 Error loading MediaInfo library: Unable to load library 'mediainfo': libmediainfo.so: cannot open shared object file: No such file or directory
[main] INFO  13:10:04.275 Make sure you have libmediainfo and libzen installed


the librarys are correct installed, but PMS only search in a wrong location.

after symlinking the libs to /usr/lib/ PMS can find and load them:

Code: Select all
sudo ln -s /usr/lib/i386-linux-gnu/libmediainfo.so.0.0.0 /usr/lib/
sudo ln -s /usr/lib/i386-linux-gnu/libzen.so.0.0.0 /usr/lib/


possible it can be fixed? Version I used is: pms-1.50.2-SB66
TCr82
 
Posts: 3
Joined: Sat Feb 25, 2012 12:58 pm

Re: PMS SubJunk Build 66 (Updated 2012-02-15)

Postby chocolateboy » Sat Feb 25, 2012 4:55 pm

TCr82 wrote:possible it can be fixed?


https://code.google.com/p/ps3mediaserve ... il?id=1152
chocolateboy
Project Member
 
Posts: 2580
Joined: Wed Sep 16, 2009 10:05 am

Re: PMS SubJunk Build 66 (Updated 2012-02-15)

Postby glenrocks » Sun Feb 26, 2012 12:24 am

Hi SJ-
Since SB 66 build had issues for me with mencoder-2, I tried SHB build and came across install feature which would be nice to have in this SB 66 build too...before install, it asks for Java memory size to allocate!! Just curious though, I understand that SB build is only for windows and SB builds are both windows/linux...right??

Chocolateboy- Hi...Question: would you know if there is documentation/steps to watch for to install PS3 media server on Lacie Network space 2/NAS.

I still haven't been able to pause/rewind/save live streams but found a way to skip media files stored on local network using Chapters feature. Suggestions please! (Should I raise it as an issue/improvement with transcoding pipes being mostly named pipe over tcpip and have not been able to make save&play work through confuguration settings)
glenrocks
 
Posts: 89
Joined: Sun Aug 21, 2011 5:06 pm

Re: PMS SubJunk Build 66 (Updated 2012-02-15)

Postby Coltaine79 » Sun Feb 26, 2012 10:12 pm

I've noticed an issue where, when watching something coming through MEncoder, it seems the last 4-5 seconds of the video are getting cut off?

I didn't see anyone else complain about this so maybe I've configured something wrongly?

Also, is everyone able to play MKV/H264/AAC correctly and without audio synch issues?
Coltaine79
 
Posts: 175
Joined: Wed Aug 25, 2010 9:00 pm

Re: PMS SubJunk Build 66 (Updated 2012-02-15)

Postby Val Killmore » Tue Feb 28, 2012 10:04 am

Coltaine79 wrote:I've noticed an issue where, when watching something coming through MEncoder, it seems the last 4-5 seconds of the video are getting cut off?

I didn't see anyone else complain about this so maybe I've configured something wrongly?


Haven't noticed this on my one PC with SubJunk66. Sorry.


Coltaine79 wrote:Also, is everyone able to play MKV/H264/AAC correctly and without audio synch issues?


I can however say that I have had issues with many an MKV w/AAC audio in the past. So much so, that I either removed those files then replaced with new copies, or I remuxed them to an MP4 container, or flat out converted them using external software. I have none left to test with this build, as I now completely avoid that combination, but I do remember having issues with this combo of audio and video in MKV with previous PMS versions, trying to serve to my PS3.

Perhaps the issue is back or never left.
Val Killmore: Potato Chip Assassin
SubJunk53--Java 7u4--Acer Aspire 6930 2CoreDuo @ 2.00 GHz 3.00 GB RAM serving to : PS3 Slim -- 2 Xbox360
User avatar
Val Killmore
 
Posts: 712
Joined: Sun May 01, 2011 8:48 am

Re: PMS SubJunk Build 66 (Updated 2012-02-15)

Postby dennisreyes » Tue Feb 28, 2012 5:01 pm

Hi Subjunk, can you make one to be able to play back the Cineva code.
dennisreyes
 
Posts: 5
Joined: Fri May 27, 2011 11:25 pm

Re: PMS SubJunk Build 66 (Updated 2012-02-15)

Postby meskibob » Tue Feb 28, 2012 5:24 pm

dennisreyes wrote:Hi Subjunk, can you make one to be able to play back the Cineva code.

Not supported - viewtopic.php?f=2&t=7220&p=58376#p58376
I provide NO application support via PM or email, so please post your question to the forum per the Forum Rules.
meskibob
Moderator
 
Posts: 4778
Joined: Mon Jan 19, 2009 4:11 pm

Re: PMS SubJunk Build 66 (Updated 2012-02-15)

Postby Coltaine79 » Thu Mar 01, 2012 10:35 pm

SubJunk,

Can you please check your build for issues with MKV files which use AAC audio?

In particular, I am finding poor compatibility (using both Mencoder and TSMuxer) with the WEB-DL versions of "The Walking Dead".

Some of the affected media filenames...

The.Walking.Dead.S01E02.Guts.720p.WEB-DL.AAC2.0.h.264-ETP.mkv
The.Walking.Dead.S02E04.Cherokee.Rose.720p.WEB-DL.AAC2.0.H.264-CtrlHD.mkv
The.Walking.Dead.S02E09.Triggerfinger.720p.WEB-DL.AAC2.0.H.264-CtrlHD.mkv

If played thru Tsmuxer: crashes after 5 seconds (during studio logo)
If played thru Mencoder: plays, but the video is jerky (like it's skipping a frame) and the audio is terribly out of synch

None of the files use header compression so that can't be it.
Coltaine79
 
Posts: 175
Joined: Wed Aug 25, 2010 9:00 pm

Re: PMS SubJunk Build 66 (Updated 2012-02-15)

Postby SubJunk » Thu Mar 01, 2012 10:58 pm

I tested The.Walking.Dead.S02E04.Cherokee.Rose.720p.WEB-DL.AAC2.0.H.264-CtrlHD and it works for me. Audio is perfectly in sync and I can't notice any frame skipping. Do you have any codec packs installed?
SubJunk
 
Posts: 1210
Joined: Fri Mar 27, 2009 5:25 am

PreviousNext

Return to Beta Builds

Who is online

Users browsing this forum: No registered users and 5 guests