PMS SubJunk Build

Download and discuss official beta builds here

Re: PMS SubJunk Build 53 (Updated 2011-10-27)

Postby SubJunk » Thu Oct 27, 2011 12:52 am

SB53 is released
SubJunk
 
Posts: 1210
Joined: Fri Mar 27, 2009 5:25 am

Re: PMS SubJunk Build 53 (Updated 2011-10-27)

Postby Val Killmore » Thu Oct 27, 2011 4:31 am

SubJunk wrote:SB53 is released


Saaaaaa-weeeeeet !!

Still testing but all seems good so far.
Val Killmore: Potato Chip Assassin
SubJunk53--Java 7u4--Acer Aspire 6930 2CoreDuo @ 2.00 GHz 3.00 GB RAM serving to : PS3 Slim -- 2 Xbox360
User avatar
Val Killmore
 
Posts: 712
Joined: Sun May 01, 2011 8:48 am

Re: PMS SubJunk Build 53 (Updated 2011-10-27)

Postby squadjot » Fri Oct 28, 2011 11:37 am

Seems good!

Still This old problem still exists
User avatar
squadjot
 
Posts: 243
Joined: Thu Mar 25, 2010 10:03 pm

Re: PMS SubJunk Build 53 (Updated 2011-10-27)

Postby ExSport » Fri Oct 28, 2011 5:37 pm

For those who has problems with FF/RW for streamed content they should try add this line in renderer.conf or wait for SubJunk new version with applied patch(If he will commit it):
Code: Select all
ChunkedTransfer = true

https://code.google.com/p/ps3mediaserve ... akechanges

EDIT:
SubJunk, please can you update your code page? http://www.spirton.com/svn/PS3MS-SB/
I spotted that your last versions have desynced remuxing when FF/RW used and also when transcoding with "A/V sync alt. method" is disabled. When enabled MEncoder transcoding is synced again.
In my versions I used instead of "-mc 0 -noskip" only this one "-mc 0.005" which fixed sync problems because MEncoder counts with audio delay. Shagrath used "-mc 0 -noskip" for synced DVD images but for other files I don't like these commands 8-)
Maybe it is same problem with tsMuxeR engine when audio is extracted by MEncoder and muxed back with tsMuxeR so maybe adding -mc 0.005 when extracting audio can fix tsMuxeR issues.
I need to check my debug.log. It seems tsMuxeR counts which audio delay and audio is synced when file is played but when FF is used, it starts to be desynced.
Will try to make a test build from your latest SB53 but there is obsolete version on your code page....now I see maybe it is updated but not title only "PS3MS-SB - Revision 46:" 8-)
Many thanks
ExSport
 
Posts: 2167
Joined: Mon Jan 19, 2009 5:40 pm

Re: PMS SubJunk Build 53 (Updated 2011-10-27)

Postby Val Killmore » Fri Oct 28, 2011 10:25 pm

ExSport wrote:For those who has problems with FF/RW for streamed content they should try add this line in renderer.conf or wait for SubJunk new version with applied patch(If he will commit it):
Code: Select all
ChunkedTransfer = true

https://code.google.com/p/ps3mediaserve ... akechanges


Nice. I just tried this. I will have to read the link, but just quickly adding this value to my PMS.conf allows me to FF and RW while muxing an MKV w/DTS to my PS3. I was able to safely achieve 30 X FF, and 30 X RW, with Prince of Persia going back and forth and had no sync issues.

Will read, and keep testing.

EDIT: Just tried 120 X FF/RW with the same movie (prince of persia). Remuxing w/ tsMuxer I had no sync issues.

Full transcoded Fast Five w/forced Eng. subs and DTS 'kept in stream'. Achieved 120 X FF/RW without sync issues, again going back and forth starting/stopping.
Val Killmore: Potato Chip Assassin
SubJunk53--Java 7u4--Acer Aspire 6930 2CoreDuo @ 2.00 GHz 3.00 GB RAM serving to : PS3 Slim -- 2 Xbox360
User avatar
Val Killmore
 
Posts: 712
Joined: Sun May 01, 2011 8:48 am

Re: PMS SubJunk Build 53 (Updated 2011-10-27)

Postby ExSport » Fri Oct 28, 2011 10:55 pm

Val, this property have to be added to renderer.conf = ps3.conf, not pms.conf
ExSport
 
Posts: 2167
Joined: Mon Jan 19, 2009 5:40 pm

Re: PMS SubJunk Build 53 (Updated 2011-10-27)

Postby Val Killmore » Fri Oct 28, 2011 11:06 pm

OK. HMM.

Then how is it working now ? Strange.

EDIT: checked my PS3 renderer conf and it is showing a value of 'false'

Still have it in my PS3.conf though as 'true'
Val Killmore: Potato Chip Assassin
SubJunk53--Java 7u4--Acer Aspire 6930 2CoreDuo @ 2.00 GHz 3.00 GB RAM serving to : PS3 Slim -- 2 Xbox360
User avatar
Val Killmore
 
Posts: 712
Joined: Sun May 01, 2011 8:48 am

Re: PMS SubJunk Build 53 (Updated 2011-10-27)

Postby ExSport » Fri Oct 28, 2011 11:13 pm

SubJunk, I found why tsMuxeR remuxed files are out of sync with new versions.
It is quite weird but it seems problem is in your new and definitely better MEncoder.
I explicitly removed "timeshift=" parameter from tsMuxeR meta file and audio is synced now BUT...
Your MEncoder perhaps supports audio delay so when audio is extracted(maybe it is done by ffmpeg, I don't know), audio delay is also removed.
When movie is FF/RW or chapters are used not from beginning = position 0, audio is synced only when meta file doesn't include "timeshift" parameter.
When it is present, e.g. timeshift=959ms and also MEnocoder removed this delay, final file is out of sync logically.
And now comes BUT:
"timeshift" fixes audio delay when file is played from start=seek 0. So when timeshift is removed, audio is not synced when you start movie from start.
It is quite strange that there is another behavior for files played from zero and files from another position different from 0.
Without my patch audio is synced only when file is played from start but FF/RW/Chapters other than 0 will sync it out.
With my patch it is exactly opposite. It works after FF/RW/Chapters other than 0 but it is out of sync when file is played from start(position 0)
SubJunk, do you know what is happening there?
You can test it by editing "TSMuxerVideo.java" by commenting:
Code: Select all
//         if (params.aid != null && params.aid.delay != 0) {
//            timeshift = "timeshift=" + params.aid.delay + "ms, ";
//         }
and
Code: Select all
//            if (lang.delay != 0) {
//               timeshift = "timeshift=" + lang.delay + "ms, ";
//            }
ExSport
 
Posts: 2167
Joined: Mon Jan 19, 2009 5:40 pm

Re: PMS SubJunk Build 53 (Updated 2011-10-27)

Postby Val Killmore » Fri Oct 28, 2011 11:31 pm

ExSport wrote:Val, this property have to be added to renderer.conf = ps3.conf, not pms.conf


Both computers running SB-53:

I have tried on tower PC with 'true' in PMS.conf and 'false' in PS3 renderer .conf FF/RW works remux or trans

I have tried on laptop with no value in PMS.conf, and 'true' in PS3 renderer.conf. FF/RW works remux or trans.

It seems that magically my PS3 can now chunk stream regardless. Either way, and for whatever reason, this has now added a long desired feature to my PS3. FF'ing or RW'ing while remux/transcoding. :)
Val Killmore: Potato Chip Assassin
SubJunk53--Java 7u4--Acer Aspire 6930 2CoreDuo @ 2.00 GHz 3.00 GB RAM serving to : PS3 Slim -- 2 Xbox360
User avatar
Val Killmore
 
Posts: 712
Joined: Sun May 01, 2011 8:48 am

Re: PMS SubJunk Build 53 (Updated 2011-10-27)

Postby ExSport » Fri Oct 28, 2011 11:36 pm

Now tested
Code: Select all
ChunkedTransfer = true
in PS3.conf renderer file and it works same way as
Code: Select all
ChunkedTransfer = false

Also reproduced same behavior like I described above also on PS3. So now to find why so strange behavior and we will have tsMuxeR fully working again with correct A/V sync.
ExSport
 
Posts: 2167
Joined: Mon Jan 19, 2009 5:40 pm

PreviousNext

Return to Beta Builds

Who is online

Users browsing this forum: No registered users and 3 guests