Error with Mplayer on 1.20.412c31 MacOS

Download and discuss official beta builds here

Error with Mplayer on 1.20.412c31 MacOS

Postby andrema2 » Sun Nov 28, 2010 11:03 am

I've installed PMS 1.20.412c31 for MacOS. When I start PMS the Traces tab shows me this error.

Cannot launch MPlayer / Check the presence of /Applications/PS3 Media Server.app/Contents/Resources/Java/osx/mplayer ...
java.io.IOException: Cannot run program "osx/mplayer" (in directory "/var/folders/2L/2LfA6Q1+FoaQx1L+FmOak++++TI/-Tmp-/javaps3media"): error=2, No such file or directory


Does anyone knows how to solve it ?

Thanks
andrema2
 
Posts: 9
Joined: Wed Dec 16, 2009 1:54 am

Re: Error with Mplayer on 1.20.412c31 MacOS

Postby andrema2 » Fri Dec 03, 2010 9:16 pm

Hi All

There is anyone else having this issue ?
andrema2
 
Posts: 9
Joined: Wed Dec 16, 2009 1:54 am

Re: Error with Mplayer on 1.20.412c31 MacOS

Postby rohirm » Tue Dec 14, 2010 7:12 pm

I have the same issue.
Code: Select all
[main]        INFO  20:08:58.161 -- Checking font cache... launching simple instance of MPlayer... You may have to wait 60 seconds !
[main]        ERROR 20:08:58.225 -- Cannot launch MPlayer / Check the presence of /Applications/PS3 Media Server.app/Contents/Resources/Java/osx/mplayer ...
java.io.IOException: Cannot run program "osx/mplayer" (in directory "/var/folders/KN/KNjg9taHFveR2LrQyt8QI++++TI/-Tmp-/javaps3media"): error=2, No such file or directory
   at java.lang.ProcessBuilder.start(ProcessBuilder.java:460) ~[na:1.6.0_22]
   at net.pms.PMS.checkProcessExistence(PMS.java:218) [pms.jar:na]
   at net.pms.PMS.init(PMS.java:320) [pms.jar:na]
   at net.pms.PMS.get(PMS.java:1045) [pms.jar:na]
   at net.pms.PMS.main(PMS.java:1115) [pms.jar:na]
   at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method) ~[na:1.6.0_22]
   at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39) ~[na:1.6.0_22]
   at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25) ~[na:1.6.0_22]
   at java.lang.reflect.Method.invoke(Method.java:597) ~[na:1.6.0_22]
   at apple.launcher.LaunchRunner.run(LaunchRunner.java:115) [na:na]
   at apple.launcher.LaunchRunner.callMain(LaunchRunner.java:50) [na:na]
   at apple.launcher.JavaApplicationLauncher.launch(JavaApplicationLauncher.java:52) [na:na]
Caused by: java.io.IOException: error=2, No such file or directory
   at java.lang.UNIXProcess.forkAndExec(Native Method) ~[na:1.6.0_22]
   at java.lang.UNIXProcess.<init>(UNIXProcess.java:53) ~[na:1.6.0_22]
   at java.lang.ProcessImpl.start(ProcessImpl.java:91) ~[na:1.6.0_22]
   at java.lang.ProcessBuilder.start(ProcessBuilder.java:453) ~[na:1.6.0_22]
   ... 11 common frames omitted
[main]        INFO  20:08:58.227 -- Done!
rohirm
 
Posts: 4
Joined: Wed Jul 08, 2009 5:39 am

Re: Error with Mplayer on 1.20.412c31 MacOS

Postby skier » Sat Dec 18, 2010 4:58 am

same thing here...
skier
 
Posts: 3
Joined: Mon Nov 15, 2010 6:33 am

Re: Error with Mplayer on 1.20.412c31 MacOS

Postby siobhanellis » Sat Jan 01, 2011 8:18 pm

and me
siobhanellis
 
Posts: 8
Joined: Sat Jan 01, 2011 5:20 am

Re: Error with Mplayer on 1.20.412c31 MacOS

Postby lightglitch » Sun Jan 02, 2011 3:01 am

Is the file in the installation folder?
lightglitch a.k.a Mário Franco
lightglitch
Project Member
 
Posts: 113
Joined: Mon Jun 22, 2009 2:58 pm

Re: Error with Mplayer on 1.20.412c31 MacOS

Postby siobhanellis » Sun Jan 02, 2011 3:32 am

If you mean is it in the location where it says it isn't? yes it is.
siobhanellis
 
Posts: 8
Joined: Sat Jan 01, 2011 5:20 am

Re: Error with Mplayer on 1.20.412c31 MacOS

Postby lightglitch » Mon Jan 03, 2011 6:25 pm

If it's there I can't help you because I don't have a mac. I hope that someone does ...
lightglitch a.k.a Mário Franco
lightglitch
Project Member
 
Posts: 113
Joined: Mon Jun 22, 2009 2:58 pm

Re: Error with Mplayer on 1.20.412c31 MacOS

Postby bortek » Mon Jan 10, 2011 12:34 pm

ERROR 20:08:58.225 -- Cannot launch MPlayer / Check the presence of /Applications/PS3 Media Server.app/Contents/Resources/Java/osx/mplayer

Install mplayer
bortek
 
Posts: 37
Joined: Mon Jan 19, 2009 9:22 am

Re: Error with Mplayer on 1.20.412c31 MacOS

Postby BantryRed » Fri Jan 14, 2011 11:49 pm

Sorry for the stupid Question (new to OSX) What do I do here??? Also changed info.plist in Root/Java/VMOptions from XMX768M to XMX1500M. Still no joy. Downloaded Mplayer and tried alot of different things ,renaming etc. Sorry still lost. Thanks
BantryRed
 
Posts: 86
Joined: Wed Feb 25, 2009 11:11 am
Location: Cork Ireland


Return to Beta Builds

Who is online

Users browsing this forum: No registered users and 7 guests