PMS Community Build Beta

Download and discuss official beta builds here

Re: PMS Community Build Beta

Postby Coltaine79 » Mon Sep 27, 2010 10:17 pm

Wow, I had no idea you guys were active with a "community build"! That's what happens when you leave the forum for a month I guess.

I'll volunteer to try out the new Community Build. If it makes any difference, I have a PS3 v3.41 which I plan to leave at that firmware level.
Which build should I try?

pms-setup-windows-1.20.410-c14 ?
Coltaine79
 
Posts: 175
Joined: Wed Aug 25, 2010 9:00 pm

Re: PMS Community Build Beta

Postby lightglitch » Mon Sep 27, 2010 10:32 pm

Coltaine79 wrote:Wow, I had no idea you guys were active with a "community build"! That's what happens when you leave the forum for a month I guess.

I'll volunteer to try out the new Community Build. If it makes any difference, I have a PS3 v3.41 which I plan to leave at that firmware level.
Which build should I try?

pms-setup-windows-1.20.410-c14 ?

Check here https://code.google.com/p/ps3mediaserve ... loads/list

EDIT:
NEW VERSION ps3mediaserver 1.20.410 contrib r29:

ffmpeg updated
Applied patch to support thumbs for fotos
Fixed some bugs (The refresh bug is solved. @ExSport: with the chapters enable I don't get any exceptions)

Everybody is welcome to tested it.
lightglitch a.k.a Mário Franco
lightglitch
Project Member
 
Posts: 113
Joined: Mon Jun 22, 2009 2:58 pm

Re: PMS Community Build Beta

Postby LocutusX » Tue Sep 28, 2010 3:38 am

I quickly tried c29 to watch a TV episode (MKV/h264, no subs, 720p, PS3 @ 3.41 firmware) and it's working fine. Will update this post as I get around to watching more complicated stuff...

Spoke too soon, I seem to have found a bug. My interpretation of the following log is that the included version of mencoder does not support vobsub, but PMS is assuming that it does?

Code: Select all
[Thread-298]  TRACE 22:26:02.815 -- Found subtitles track : Sub: VobSub / lang: und / ID: 100 / FILE: C:\Users\xxx\Videos\! Xvid Movies\Open Your Eyes\oye.sub
[Thread-298]  TRACE 22:26:02.815 -- Found external file : C:\Users\xxx\Videos\! Xvid Movies\Open Your Eyes\oye.sub
[Thread-298]  TRACE 22:26:02.815 -- channels=2
[Thread-298]  DEBUG 22:26:02.822 -- Creating pipe \\.\pipe\mencoder1285640762822
[Timer-17]    TRACE 22:26:02.872 -- Buffered Space: 0 bytes / inputs: 0
[Thread-299]  DEBUG 22:26:02.872 -- Waiting for pipe connection \\.\pipe\mencoder1285640762822
[win32/mencoder.exe] DEBUG 22:26:02.922 -- Starting C:\Program Files (x86)\PS3 Media Server Community Build\win32\mencoder.exe -ss 0 -quiet C:\Users\xxx\Videos\! Xvid Movies\Open Your Eyes\oye.avi -quiet -quiet -oac lavc -of mpeg -quiet -quiet -mpegopts format=mpeg2:muxrate=500000:vbuf_size=1194:abuf_size=64 -ovc lavc -channels 2 -lavdopts debug=0:threads=4 -lavcopts autoaspect=1:vcodec=mpeg2video:acodec=ac3:abitrate=256:threads=4:keyint=1:vqscale=1:vqmin=2 -ass -nofontconfig -subcp cp1252 -subfont C:\Windows\Fonts\Arial.ttf -ass-color ffffff00 -ass-border-color 00000000 -ass-font-scale 1.2 -ass-force-style FontName=Arial,Outline=1,Shadow=1,MarginV=10 -quiet -quiet -sid 100 -quiet -quiet -ofps 24000/1001 -vobsub C:\Users\xxx\Videos\! Xvid Movies\Open Your Eyes\oye -slang und -af lavcresample=48000 -srate 48000 -o \\.\pipe\mencoder1285640762822
[win32/mencoder.exe] DEBUG 22:26:02.923 -- Reading pipe: \\.\pipe\mencoder1285640762822
[win32/mencoder.exe] DEBUG 22:26:02.923 -- Attaching thread: win32/mencoder.exe
[Thread-302]  TRACE 22:26:02.934 -- MEncoder Sherpya-SVN-r30369-4.2.5 (C) 2000-2009 MPlayer Team
[Thread-301]  TRACE 22:26:02.936 -- -vobsub is not an MEncoder option
[Thread-302]  TRACE 22:26:02.936 -- Exiting... (error parsing command line)
LocutusX
 
Posts: 2
Joined: Mon Mar 15, 2010 10:47 pm

Re: PMS Community Build Beta

Postby brotherjohn » Tue Sep 28, 2010 9:24 am

Client device = Sony TV Bravia EX505
Operating system: Win 7 32 Bit
Connected via power lan (devolo, 85 MBit).

Until now, it's more stable than the last version r19. In the version r19, I've got crashes of PS3MS because of more than 99 files in one folder. Now this doesn't happen.
Sometimes sound and video is stuttering by playing DVD ISO files. Maximum bitrate of files are 24 MBit, Network bitrate is at 30 MBit. But I guess, that sometimes for a short moment, the network bitrate decreases to 11 MBit. That could be a reason for the stuttering, I guess.

I use this renderer file:
Code: Select all
# ps3mediaserver renderer profile for Sony Bravia EX500/EX700 series
# Refer to PS3.conf for help

RendererName=Sony Bravia EX Series
RendererIcon=bravia.png
UserAgentSearch=notusedhere
UserAgentAdditionalHeader=X-AV-Client-Info
UserAgentAdditionalHeaderSearch=(BRAVIA KDL.+EX5)|(BRAVIA KDL.+EX7)
Video=true
Audio=true
Image=true
SeekByTime=true
TranscodeVideo=MPEGAC3
TranscodeAudio=MP3
DefaultVBVBufSize=true
MuxH264ToMpegTS=true
MuxDTSToMpeg=false
WrapDTSIntoPCM=false
MuxLPCMToMpeg=false
MaxVideoBitrateMbps=0
MaxVideoWidth=0
MaxVideoHeight=0
H264Level41Limited=true
MimeTypesChanges=audio/wav=audio/L16|video/mp4=video/mpeg
DLNALocalizationRequired=true
TranscodeExtensions=dvr-ms,dvr,mkv,dv,ty,mov,ogm,hdmov,hdm,rmv,rmvb,rm,asf,evo,asx,flv,m2v,mpe,mod,tivo,ty,tmf,ts,tp,m2p,mp4,m4v,avi,wmv,wm,divx,div,flac,mlp,fla,wma,m4a,aac,dts,mka,ape,ogg,shn,mpc,ra,mp2,wv,oma,aa3,gif,png,arw,cr2,crw,dng,raf,mrw,nef,pef,tif,tiff
StreamExtensions=


MediaInfo=true
# [Supported video formats]:
# Here we declare support (or lack) of DTS (here, none of the entries declare dts as a supported audio codec)
Supported = f:mpegps|mpegts v:mpeg1|mpeg2|mp4|h264 a:ac3|lpcm|aac|mpa m:video/mpeg
# No H264 for AVI files, plus specific mediainfo attributes, for better auto detection (qpel and gmc are not supported here)
Supported = f:avi|divx v:mp4|divx|mjpeg a:mp3|lpcm|mpa|ac3 m:video/x-divx qpel:no gmc:0
Supported = f:mp4 v:mp4|h264 a:ac3|aac m:video/mp4
# WMV files are supported, but not with 5.1 audio: (hence the n:2)
Supported = f:wmv v:wmv|vc1 a:wma n:2 m:video/x-ms-wmv
# [Supported audio formats]:
Supported = f:wav a:dts|lpcm n:6 s:48000 m:audio/wav
Supported = f:wav n:2 s:48000 m:audio/wav
Supported = f:mp3 n:2 m:audio/mpeg
# Apple lossless not supported
Supported = f:aac n:2 a:(?!alac).+ m:audio/x-m4a
Supported = f:wma n:2 m:audio/x-ms-wma
Supported = f:atrac n:2 m:audio/x-oma
# [Supported image formats]
Supported = f:jpg m:image/jpeg
Supported = f:png m:image/png
Supported = f:gif m:image/gif
Supported = f:tiff m:image/tiff


Great work. Keep it up. Thanks. :D
brotherjohn
 
Posts: 146
Joined: Wed Sep 15, 2010 9:13 am

Re: PMS Community Build Beta

Postby lightglitch » Tue Sep 28, 2010 10:51 am

LocutusX wrote:Spoke too soon, I seem to have found a bug. My interpretation of the following log is that the included version of mencoder does not support vobsub, but PMS is assuming that it does?


The patch is applied but the menconder is not yet updated because there were issues with the latest version.
We will have to use a older version like ExSport recommended, tonight I will do some testing with the version that ExSport said and update the builds.
lightglitch a.k.a Mário Franco
lightglitch
Project Member
 
Posts: 113
Joined: Mon Jun 22, 2009 2:58 pm

Re: PMS Community Build Beta

Postby Redlum » Tue Sep 28, 2010 12:13 pm

Hey guys,

I'm back ;) It's great that the community is still active so I wan't get some of this work into the official build so more people can enjoy it.

I'm interested in mostly bug fixes and small enhancements, no new features, I'll leave that up to Shagrath who might be back soon.

Since you've all been testing this for a while, which patches would you consider low risk? Thanks.
Redlum
Project Member
 
Posts: 371
Joined: Mon Jan 12, 2009 9:13 pm

Re: PMS Community Build Beta

Postby ExSport » Tue Sep 28, 2010 12:27 pm

It is silly that new MEncoder versions are quite problematic on some videos so my testing found that last version which worked on all of my test files was r31170. This one supports -vobsub but all recent versions have bug in -ass so you need to disable it in PMS so MEncoder will not fail. Disabling ASS/SSA doesn't mean that we will loose subtitle support, only some special formating etc. will be unavailable.
ExSport
 
Posts: 2161
Joined: Mon Jan 19, 2009 5:40 pm

Re: PMS Community Build Beta

Postby ExSport » Tue Sep 28, 2010 12:29 pm

lightglitch wrote:Fixed some bugs (The refresh bug is solved. @ExSport: with the chapters enable I don't get any exceptions)

Thanks for fix. Maybe some other patch did it, I need to investigate because I applied also other patches myself :?
ExSport
 
Posts: 2161
Joined: Mon Jan 19, 2009 5:40 pm

Re: PMS Community Build Beta

Postby fezzz » Tue Sep 28, 2010 1:10 pm

Great, thanks for the patch collection!

Just compiled "Version 29" running with java 1.6.0_21
Good news : all my standard features that I use work perferctly.
- webstreaming with chocolateboys ps3enc
- DVD-Iso-streaming with MEncoder
- MPlayer Audio streaming

Just a minor warning compilation (perhaps because of my local ANT update to 1.8.1):

Code: Select all
Buildfile: D:\WORKBENCH\00_SOURCE\PS3MS_contrib\ps3mediaserver\build.xml

depends:

clean:
   [delete] Deleting directory D:\WORKBENCH\00_SOURCE\PS3MS_contrib\ps3mediaserver\dist
   [delete] Deleting: D:\WORKBENCH\00_SOURCE\PS3MS_contrib\ps3mediaserver\pms.jar

PMS:
    [mkdir] Created dir: D:\WORKBENCH\00_SOURCE\PS3MS_contrib\ps3mediaserver\classes
    [javac] D:\WORKBENCH\00_SOURCE\PS3MS_contrib\ps3mediaserver\build.xml:31: warning: 'includeantruntime' was not set, defaulting to build.sysclasspath=last; set to false for repeatable builds
    [javac] Compiling 172 source files to D:\WORKBENCH\00_SOURCE\PS3MS_contrib\ps3mediaserver\classes
      [jar] Building jar: D:\WORKBENCH\00_SOURCE\PS3MS_contrib\ps3mediaserver\pms.jar
      [jar] META-INF/LICENSE.txt already added, skipping
    [mkdir] Created dir: D:\WORKBENCH\00_SOURCE\PS3MS_contrib\ps3mediaserver\dis
t
      [tar] Building tar: D:\WORKBENCH\00_SOURCE\PS3MS_contrib\ps3mediaserver\dist\pms-generic-linux-unix-1.20.410-c29.tgz
   [delete] Deleting directory D:\WORKBENCH\00_SOURCE\PS3MS_contrib\ps3mediaserver\classes

creatensis:
     [nsis] Successfully compiled script D:\WORKBENCH\00_SOURCE\PS3MS_contrib\ps3mediaserver\nsis\pms.nsi
     [nsis] Successfully compiled script D:\WORKBENCH\00_SOURCE\PS3MS_contrib\ps3mediaserver\nsis\setup.nsi

BUILD SUCCESSFUL
Total time: 1 minute 31 seconds


And warnings directy after startup (chocolateboys pmsencoder) but with no impact on functionality:

Code: Select all
[main]        INFO  14:02:31.071 -- initializing PMSEncoder 1.1.0
[main]        INFO  14:02:31.072 -- log4j config file: jar:file:/C:/Program%20Files%20(x86)/PS3%20Media%20Server/plugins/pmsencoder-1.1.0.jar!/log4j.xml
[main]        INFO  14:02:31.281 -- loading PMSEncoder config file: jar:file:/C:/Program%20Files%20(x86)/PS3%20Media%20Server/plugins/pmsencoder-1.1.0.jar!/pmsencoder.groovy
[main]        INFO  14:02:31.906 -- checking for a custom PMSEncoder file in C:\Program Files (x86)\PS3 Media Server
[main]        INFO  14:02:31.907 -- loading PMSEncoder config file: pmsencoder.groovy
[main]        INFO  14:02:31.907 -- Can't load PMSEncoder config file: pmsencoder.groovy: java.io.FileNotFoundException: pmsencoder.groovy (Das System kann die angegebene Datei nicht finden)
[main]        INFO  14:02:31.907 -- loading PMSEncoder config file: pmsencoder.conf
[main]        INFO  14:02:31.908 -- Can't load PMSEncoder config file: pmsencoder.conf: java.io.FileNotFoundException: pmsencoder.conf (Das System kann die angegebene Datei nicht finden)
[main]        INFO  14:02:31.910 -- Registering transcoding engine PMSEncoder
[main]        DEBUG 14:02:31.913 -- Sending ALIVE...
[main]        TRACE 14:02:31.914 -- Setting multicast network interface: name:eth4 (Intel(R) PRO/1000 GT-Desktopadapter) index: 15 addresses: /192.168.1.20;
[main]        TRACE 14:02:31.976 -- Sending message from multicast socket on network interface: name:eth4 (Intel(R) PRO/1000 GT-Desktopadapter) index: 15 addresses: /192.168.1.20;
[main]        TRACE 14:02:31.976 -- Multicast socket is on interface: /192.168.1.20


Thanks again!
Felix
fezzz
 
Posts: 20
Joined: Wed Sep 02, 2009 8:17 pm

Re: PMS Community Build Beta

Postby Coltaine79 » Tue Sep 28, 2010 3:58 pm

ExSport wrote:It is silly that new MEncoder versions are quite problematic on some videos so my testing found that last version which worked on all of my test files was r31170. This one supports -vobsub but all recent versions have bug in -ass so you need to disable it in PMS so MEncoder will not fail. Disabling ASS/SSA doesn't mean that we will loose subtitle support, only some special formating etc. will be unavailable.


Sorry for the newbie question, but where can I get this r31170 MEncoder/MEncoder_MT ?

I will go ahead and try that build while we are waiting for c30.

Also, by saying "disable -ass" I assume you just mean UNchecking the checkbox which is labelled "Support ASS/SSA" ?
Coltaine79
 
Posts: 175
Joined: Wed Aug 25, 2010 9:00 pm

PreviousNext

Return to Beta Builds

Who is online

Users browsing this forum: No registered users and 2 guests