Latest Mac OS X beta build

Download and discuss official beta builds here

Re: Latest Mac OS X beta build

Postby XenoPhex » Mon Oct 24, 2011 10:38 pm

Note: Currently running r954
Not sure if this a symtom of previous problems that have been going on, however, for the past few builds, watching certain MKVs causes them to start a few minutes into the video. If you go into the #transcode folder for said files, it renames the files the timestamp of where they start to play. The worst part is there's no way to start it it at the beginning of the movie.

Anyone else seeing this?

--EDIT--
Seems like there was a fix by r957. Thanks!
Specs: OS X 10.7.2 (64 Bit Mode); 2x 2.26 GHz Quad Core Intel i7 Processors with HT Enabled; 6 GB DDR3; ATI 5870
Network: Gigabit Ethernet LAN, all hardlined
JDK: build 1.6.0_29-b11-402-11M3527
PS3: Slim 160GB
XenoPhex
 
Posts: 14
Joined: Sun Oct 11, 2009 7:07 pm

Re: Latest Mac OS X beta build

Postby MKUltra » Sun Oct 30, 2011 2:41 pm

I recently upgraded XCode and consistently keep getting the this error at libogg when using the build script:

Code: Select all
checking size of int16_t... 0
checking size of uint16_t... 0
checking size of u_int16_t... 0
checking size of int32_t... 0
checking size of uint32_t... 0
checking size of u_int32_t... 0
checking size of int64_t... 0
checking size of short... 0
checking size of int... 0
checking size of long... 0
checking size of long long... 0
configure: error: No 16 bit type found on this platform!
make: *** No targets specified and no makefile found.  Stop.
Fatal error occurred, aborting build.


Anybody else getting the same error?
Mac Mini 2.26 GHz Intel Core 2 Duo 4 GB RAM OS 10.7.2/Airport Extreme Basestation (Early 2009) Wireless N/PS3-Fatboy 40GB/1Gibps via Cat 6 LAN connection w/ Airport Extreme/PS3 connected via HDMI to Denon AVR-3808CI
MKUltra
 
Posts: 75
Joined: Sun Aug 30, 2009 10:41 pm

Re: Latest Mac OS X beta build

Postby Pyrone89 » Wed Nov 02, 2011 6:22 pm

With 1.40.0 I kept failing for the PS3 and the PMS program to find each other. With 1.50 beta 1 I must completely close the PS3 media server and restart for it to be recognized on the PS3 each time I do a manual search for media servers (else it will say none found although the PMS program does say it found the PS3) or after waking up the Mac from sleep. This is getting highly annoying.

More so is the constant stutter while playing mp4 files (h.264 codec). It seems like a sudden spike in the bit rate causes this (at least, with the PS3 info screen on during playback I notice huge rises in bit rates amount the times this happens). Setting the connect to unlimited (was set at 100 by dev) did not help. Strangely, it plays other files with high bit rates (like NCIS in HD) fine but those are avi codecs.

Furthermore: how to properly clean the PS3 Media Server files when uninstalling? When i try to do a clean install it keeps my settings (so the settings files is hidden somewhere and as a recent Mac switch i can not find this file, so basically old files keep present in the OS).
Pyrone89
 
Posts: 27
Joined: Mon Oct 26, 2009 12:54 pm

Re: Latest Mac OS X beta build

Postby MKUltra » Thu Nov 03, 2011 2:19 am

MKUltra wrote:I recently upgraded XCode and consistently keep getting the this error at libogg when using the build script:

Code: Select all
checking size of int16_t... 0
checking size of uint16_t... 0
checking size of u_int16_t... 0
checking size of int32_t... 0
checking size of uint32_t... 0
checking size of u_int32_t... 0
checking size of int64_t... 0
checking size of short... 0
checking size of int... 0
checking size of long... 0
checking size of long long... 0
configure: error: No 16 bit type found on this platform!
make: *** No targets specified and no makefile found.  Stop.
Fatal error occurred, aborting build.


Anybody else getting the same error?


The problem was with XCode 4.2, so I uninstalled it and re-installed 4.1.1 - no more issues running the build script.
Mac Mini 2.26 GHz Intel Core 2 Duo 4 GB RAM OS 10.7.2/Airport Extreme Basestation (Early 2009) Wireless N/PS3-Fatboy 40GB/1Gibps via Cat 6 LAN connection w/ Airport Extreme/PS3 connected via HDMI to Denon AVR-3808CI
MKUltra
 
Posts: 75
Joined: Sun Aug 30, 2009 10:41 pm

Re: Latest Mac OS X beta build

Postby mohammad » Fri Nov 04, 2011 10:56 pm

Hi guys,
This is my first post but have been a long time follower on this thread. I would like to thank everyone in making this happen.
I have the following:
MAC 10.7.2
2.8GHz intel i7
8GM 1067 MHz DDR3

Since JAVA upgrade (i get version in ABOUT JAVA PREF,14.0.3)but in general have java 1.6.0_26-b03-383 in both 32 and 64 bit, pushed by apple i have encountered problems this is both on the 1.40 and 1.50 server versions.

I get the server on my PS3 but fails to load anything and gives error 2006. Checking PS3 server TRACES i get the following:

Code: Select all
[New I/O server worker #1-11] INFO  21:23:42.732 java.lang.OutOfMemoryError: Java heap space
[New I/O server worker #1-11] INFO  21:23:42.735    at com.sun.org.apache.xerces.internal.dom.ElementImpl.getAttributes(ElementImpl.java:136)
[New I/O server worker #1-11] INFO  21:23:42.735    at net.pms.xmlwise.XmlElementAttributes.<init>(XmlElementAttributes.java:33)
[New I/O server worker #1-11] INFO  21:23:42.736    at net.pms.xmlwise.XmlElement.<init>(XmlElement.java:29)
[New I/O server worker #1-11] INFO  21:23:42.736    at net.pms.xmlwise.XmlElement.<init>(XmlElement.java:36)
[New I/O server worker #1-11] INFO  21:23:42.737    at net.pms.xmlwise.XmlElement.<init>(XmlElement.java:36)
[New I/O server worker #1-11] INFO  21:23:42.737    at net.pms.xmlwise.XmlElement.<init>(XmlElement.java:36)
[New I/O server worker #1-11] INFO  21:23:42.738    at net.pms.xmlwise.XmlElement.<init>(XmlElement.java:36)
[New I/O server worker #1-11] INFO  21:23:42.738    at net.pms.xmlwise.Xmlwise.loadXml(Xmlwise.java:127)
[New I/O server worker #1-11] INFO  21:23:42.738    at net.pms.xmlwise.Plist.load(Plist.java:151)
[New I/O server worker #1-11] INFO  21:23:42.739    at net.pms.xmlwise.Plist.load(Plist.java:163)
[New I/O server worker #1-11] INFO  21:23:42.739    at net.pms.dlna.RootFolder.getiPhotoFolder(RootFolder.java:355)
[New I/O server worker #1-11] INFO  21:23:42.740    at net.pms.dlna.RootFolder.discoverChildren(RootFolder.java:117)
[New I/O server worker #1-11] INFO  21:23:42.740    at net.pms.dlna.DLNAResource.discoverWithRenderer(DLNAResource.java:592)
[New I/O server worker #1-11] INFO  21:23:42.740    at net.pms.dlna.DLNAResource.getDLNAResources(DLNAResource.java:534)
[New I/O server worker #1-11] INFO  21:23:42.740    at net.pms.network.RequestV2.answer(RequestV2.java:558)
[New I/O server worker #1-11] INFO  21:23:42.741    at net.pms.network.RequestHandlerV2.writeResponse(RequestHandlerV2.java:255)
[New I/O server worker #1-11] INFO  21:23:42.741    at net.pms.network.RequestHandlerV2.messageReceived(RequestHandlerV2.java:225)
[New I/O server worker #1-11] INFO  21:23:42.742    at org.jboss.netty.handler.stream.ChunkedWriteHandler.handleUpstream(ChunkedWriteHandler.java:148)
[New I/O server worker #1-11] INFO  21:23:42.742    at org.jboss.netty.handler.codec.http.HttpChunkAggregator.messageReceived(HttpChunkAggregator.java:116)
[New I/O server worker #1-11] INFO  21:23:42.743    at org.jboss.netty.channel.Channels.fireMessageReceived(Channels.java:302)
[New I/O server worker #1-11] INFO  21:23:42.744    at org.jboss.netty.handler.codec.replay.ReplayingDecoder.unfoldAndfireMessageReceived(ReplayingDecoder.java:522)
[New I/O server worker #1-11] INFO  21:23:42.744    at org.jboss.netty.handler.codec.replay.ReplayingDecoder.callDecode(ReplayingDecoder.java:506)
[New I/O server worker #1-4] INFO  21:23:42.748 Checking shared folder: /Users/iMac/Downloads/-Movie-
[New I/O server worker #1-11] INFO  21:23:42.750    at org.jboss.netty.handler.codec.replay.ReplayingDecoder.messageReceived(ReplayingDecoder.java:443)
[New I/O server worker #1-4] INFO  21:23:42.750 Checking shared folder: /Users/iMac/Downloads
[New I/O server worker #1-4] INFO  21:23:42.750 Checking shared folder: /Users/iMac/Movies
[New I/O server worker #1-4] INFO  21:23:42.751 Checking shared folder: /Users/iMac/Desktop
[Poller SunPKCS11-Darwin] INFO  21:24:49.057 Exception in thread "Poller SunPKCS11-Darwin" java.lang.OutOfMemoryError: Java heap space
[AWT-EventQueue-0] INFO  21:24:49.061 Exception in thread "AWT-EventQueue-0" java.lang.OutOfMemoryError: Java heap space
[New I/O server worker #1-4] INFO  21:24:49.061 java.lang.OutOfMemoryError: Java heap space


I have played around with the info.plist in the PS3 app and changed the following line:
<string>-Xmx768M -Xss16M -Dfile.encoding=UTF-8 -Djava.net.preferIPv4Stack=true -
to the following:
<string>-Xmx1024M -Xss64M -Dfile.encoding=UTF-8 -Djava.net.preferIPv4Stack=true -

Everything works fine now but it seems my MAC has slowed done slightly as in when i have a full on movie playing and use the MAC at the same time it either shutters te movie for a few seconds or the computer process stuff more slowly.

I would like to know what i am doing wrong and if the line i have changed is appropiate for my MAC? And why i never had this issue for the last 3 years or so, is it because of the 64bit mode on lion?

If i need to give any other info please let me know.
Thanks
mohammad
 
Posts: 2
Joined: Fri Nov 04, 2011 10:36 pm

Re: Latest Mac OS X beta build

Postby Raptor399 » Sat Nov 05, 2011 1:09 am

mohammad wrote:I would like to know what i am doing wrong and if the line i have changed is appropiate for my MAC? And why i never had this issue for the last 3 years or so, is it because of the 64bit mode on lion?

The line you changed is appropriate.
You got a heap space memory error and you increased the Java heap space.
Sounds like a sensible thing to do to me. :-)
Raptor399
Project Member
 
Posts: 1916
Joined: Thu Mar 10, 2011 12:06 am

Re: Latest Mac OS X beta build

Postby mohammad » Sat Nov 05, 2011 4:27 pm

Is there better numbers i should change it to, to stop getting slow speed on MAC?
mohammad
 
Posts: 2
Joined: Fri Nov 04, 2011 10:36 pm

Re: Latest Mac OS X beta build

Postby Raptor399 » Sun Nov 06, 2011 10:05 am

I don't think so.
Maybe there's something in the FAQ that helps in your situation.
Raptor399
Project Member
 
Posts: 1916
Joined: Thu Mar 10, 2011 12:06 am

Re: Latest Mac OS X beta build

Postby Pyrone89 » Sat Nov 12, 2011 4:16 pm

I have the latest beta installed on my Mac 10.7.2 OS but it keeps losing the connection to the PS3 after some time (not showing up anymore in the PS3) while the PS3 media server home screen keeps saying it has detected the renderer (which the PS3 clearly disagrees with).

Also, if you pause a playback (like a video) for some minutes and then want to continue it crashes, forcing me to go over to my mac and restart the whole program.

Very annoying. Checked everything and it seems to happen at friends of my also using it (just to verify if it had to do anything with my Mac)
Pyrone89
 
Posts: 27
Joined: Mon Oct 26, 2009 12:54 pm

Re: Latest Mac OS X beta build

Postby tsynik » Sat Nov 12, 2011 6:20 pm

There is bogus mediainfo in the trunk now:

Code: Select all
Pro:osx nikk$ file /Applications/PS3\ Media\ Server.app/Contents/Resources/Java/libmediainfo.dylib
/Applications/PS3 Media Server.app/Contents/Resources/Java/libmediainfo.dylib: Mach-O universal binary with 2 architectures
/Applications/PS3 Media Server.app/Contents/Resources/Java/libmediainfo.dylib (for architecture i386):   Mach-O dynamically linked shared library i386
/Applications/PS3 Media Server.app/Contents/Resources/Java/libmediainfo.dylib (for architecture x86_64):   Mach-O 64-bit dynamically linked shared library x86_64
Pro:osx nikk$ file /Applications/PS3\ Media\ Server.app/Contents/Resources/Java/libmediainfo.dylib.new.dylib
/Applications/PS3 Media Server.app/Contents/Resources/Java/libmediainfo.dylib.new.dylib: Mach-O universal binary with 2 architectures
/Applications/PS3 Media Server.app/Contents/Resources/Java/libmediainfo.dylib.new.dylib (for architecture ppc):   Mach-O dynamically linked shared library ppc
/Applications/PS3 Media Server.app/Contents/Resources/Java/libmediainfo.dylib.new.dylib (for architecture i386):   Mach-O dynamically linked shared library i386

old one worked fine, new one generates this error:
Code: Select all
[main] INFO  20:19:41.440 Loading MediaInfo library
[main] INFO  20:19:41.474 Error loading MediaInfo library: Unable to load library 'mediainfo': dlopen(libmediainfo.dylib, 9): no suitable image found.  Did find:
   libmediainfo.dylib: no matching architecture in universal wrapper
[main] INFO  20:19:41.475 The server will now use the less accurate ffmpeg parsing method
tsynik
 
Posts: 4
Joined: Mon Jul 18, 2011 7:02 am

PreviousNext

Return to Beta Builds

Who is online

Users browsing this forum: Google [Bot] and 3 guests