Latest Mac OS X beta build

Download and discuss official beta builds here

Re: Latest Mac OS X beta build

Postby pk.oddity » Mon Jun 20, 2011 8:35 am

Thanks Redlum for the subs fix.
pk.oddity
 
Posts: 11
Joined: Sun Jun 05, 2011 2:43 pm

FLAC audio problems

Postby Bansaku » Tue Jun 21, 2011 10:28 am

Heyas, just downloaded and tried out the latest build, 1.25.1, updated from 1.20.409, and I am experiencing audio problems related to 6ch FLAC audio tracks in MKV files. In 1.20.409 FLAC audio is transcoded fine to DolbyDigital**. However, in 1.25.1, the dialogue (centre channel) is outputted to the left rear. All other channels are represented fine. I don't know if there is a fix, or if others have reported the same problem, I am simply reporting my findings.

**Regardless of the PS3MS version, some 6ch FLAC audio refuses to play (resulting in a corrupt file warning). Granted, I have only ever seen FLAC audio attached to Anime. Why do people encode into multi-channel in FLAC? IMHO FLAC is the bane of MKV files. Just because it works on SOME of the media players out there, doesn't make it a good option to encode to.
Bansaku
 
Posts: 4
Joined: Tue Jun 21, 2011 10:14 am

Re: Latest Mac OS X beta build

Postby machadcm » Tue Jun 21, 2011 6:37 pm

tizoune wrote:Hi I just test a bit the newly 1.25 macos x release on my Mac Pro early 2008 10 GB MacOs X 10.6.7 streaming on PS3 tru gigabit ethernet.

When I try video with external subtitles: I received a message from PS3 that data were corrupted. I try twice : restarting PMS and PS3: same issue.
When I try same videos a) without external subtitles or b) with the "no substitles" options turn ON in the video options those videos just play fine but of course without subs.

But other thinks go realy well with that newly release version, PMS now find my PS3 on my network almost immediatly, with the v1.20.409 it took systematicaly more than 9 minutes. Also, VDO in lower resolutions seems render better.

Thanks for the good job!


I face a similar problem, running 1.25.1 and streaming on WD TV Live, data corrupted with ASS/SSA subtitles selected and ok without it. It took me a while to find it out.

Keep up the great job!
machadcm
 
Posts: 3
Joined: Tue Jun 21, 2011 6:11 pm

Re: Latest Mac OS X beta build

Postby Redlum » Tue Jun 21, 2011 8:03 pm

New beta build. This one should work better with subtitles and ASS is now disabled by default to avoid confusion.

http://ps3mediaserver.org/files/pms-mac ... a-r662.dmg
Redlum
Project Member
 
Posts: 371
Joined: Mon Jan 12, 2009 9:13 pm

Re: Latest Mac OS X beta build

Postby souldead » Thu Jun 23, 2011 10:16 am

Hi Need a little help on the Mac OS build

My Oppo 93 cant seem to detect the PS3 Media Server running on my Mac OS X 10.6.7

I already add an oppo.conf renderer. what do I do to ractify this
Thanks in advance :D

Code: Select all
# ps3mediaserver renderer profile for Oppo BDP-93
# Refer to PS3.conf for help

RendererName=BDP - 93
RendererIcon=pch.png
# UserAgentSearch=OPPO PLAYER
UserAgentSearch=IPI/1.0 UPnP/1.0 DLNADOC/1.50
Video=true
Audio=true
Image=true
SeekByTime=false
TranscodeVideo=MPEGAC3
TranscodeAudio=pcm
DefaultVBVBufSize=true
MuxH264ToMpegTS=true
MuxDTSToMpeg=true
WrapDTSIntoPCM=false
MuxLPCMToMpeg=false
MaxVideoBitrateMbps=0
MaxVideoWidth=0
MaxVideoHeight=0
H264Level41Limited=false
TranscodeExtensions=flac,iso,vob
StreamExtensions= gif,jpg,png,aac,m4a,mp3,pcm,wav,wma,avi,mkv,mp4,m2ts,ts,wmv
souldead
 
Posts: 1
Joined: Thu Jun 23, 2011 10:09 am

Re: Latest Mac OS X beta build

Postby Horseylicious » Fri Jun 24, 2011 8:51 am

The BDP93.conf is wrong. Try this (it works for my 93):

Code: Select all
# ps3mediaserver renderer profile for Oppo BDP-93
# Refer to PS3.conf for help

RendererName=BDP - 93
RendererIcon=pch.png
UserAgentSearch=OPPO PLAYER
Video=true
Audio=true
Image=true
SeekByTime=false
TranscodeVideo=MPEGAC3
TranscodeAudio=pcm
DefaultVBVBufSize=true
MuxH264ToMpegTS=true
MuxDTSToMpeg=true
WrapDTSIntoPCM=false
MuxLPCMToMpeg=false
MaxVideoBitrateMbps=0
MaxVideoWidth=0
MaxVideoHeight=0
H264Level41Limited=false
TranscodeExtensions=iso,vob
StreamExtensions= gif,jpg,png,aac,flac,m4a,mp3,pcm,wav,wma,avi,mkv,mp4,m2ts,ts,wmv,ogg
Horseylicious
 
Posts: 18
Joined: Sun Mar 27, 2011 1:32 am

Re: Latest Mac OS X beta build

Postby Raptor399 » Wed Jul 06, 2011 7:48 pm

I have committed new versions of mplayer and mencoder in r721. These versions should add support for external VOBsub.

If you are in an experimental mood, you can simply check them out from Google Code and replace your current binaries, e.g. with a Terminal:

Code: Select all
SRC=ps3mediaserver-read-only/ps3mediaserver/osx
DEST=/Applications/PS3\ Media\ Server.app/Contents/Resources/Java/osx
mv $DEST/mplayer $DEST/mplayer.bak
mv $DEST/mencoder $DEST/mencoder.bak
cp $SRC/mplayer $DEST
cp $SRC/mencoder $DEST

Let me know if they work as expected.
Raptor399
Project Member
 
Posts: 1916
Joined: Thu Mar 10, 2011 12:06 am

Re: Latest Mac OS X beta build

Postby XenoPhex » Mon Jul 18, 2011 4:58 am

Anyone else seeing problems on HD Content shuddering when the video goes above 30 Mb/s? I noticed this a while back and set the Max Bandwidth to never go above 30 Mb/s, but it seems the latest version (r755) seems to be randomly getting around this limit.

Anyone else having this problem? The only way I seem to get this to fix is either by pausing the video for a few seconds or by stopping the video and restarting it.
Specs: OS X 10.7.2 (64 Bit Mode); 2x 2.26 GHz Quad Core Intel i7 Processors with HT Enabled; 6 GB DDR3; ATI 5870
Network: Gigabit Ethernet LAN, all hardlined
JDK: build 1.6.0_29-b11-402-11M3527
PS3: Slim 160GB
XenoPhex
 
Posts: 14
Joined: Sun Oct 11, 2009 7:07 pm

Re: Latest Mac OS X beta build

Postby meskibob » Mon Jul 18, 2011 1:18 pm

I provide NO application support via PM or email, so please post your question to the forum per the Forum Rules.
meskibob
Moderator
 
Posts: 4788
Joined: Mon Jan 19, 2009 4:11 pm

Re: Latest Mac OS X beta build

Postby XenoPhex » Mon Jul 18, 2011 11:43 pm

I've read that... What I'm getting at was that something changed recently that is allowing the server to get around this enforced limit.
Specs: OS X 10.7.2 (64 Bit Mode); 2x 2.26 GHz Quad Core Intel i7 Processors with HT Enabled; 6 GB DDR3; ATI 5870
Network: Gigabit Ethernet LAN, all hardlined
JDK: build 1.6.0_29-b11-402-11M3527
PS3: Slim 160GB
XenoPhex
 
Posts: 14
Joined: Sun Oct 11, 2009 7:07 pm

PreviousNext

Return to Beta Builds

Who is online

Users browsing this forum: Google [Bot] and 4 guests