SharkHunter Build 43 (Update 12-04-29)

Download and discuss official beta builds here

Re: SharkHunter Build (Update 11-05-29)

Postby SharkHunter » Thu Jun 02, 2011 12:48 pm

You right I was too quick actually that part work bu then some weird stuff happens . This is a v1 processor and v1 are real old stuff :) Maybe I made a shortcut there :)

Edit: Bug found and fixed. New version of Channels (1.18) is out and can be fetched from https://github.com/downloads/SharkHunte ... ug_118.jar. A new SHB will be made later when more stuff is there to be added. For instructions on how to upgrade Channels see https://github.com/SharkHunter/Channel.
SharkHunter
 
Posts: 941
Joined: Tue Jun 01, 2010 8:39 pm

Re: SharkHunter Build (Update 11-05-29)

Postby brotherjohn » Thu Jun 02, 2011 10:58 pm

Filmtrailer on NaviX works now with the new version 1.18. Thanks a lot, SharkHunter. :D
brotherjohn
 
Posts: 146
Joined: Wed Sep 15, 2010 9:13 am

Re: SharkHunter Build (Update 11-05-29)

Postby lartomar2002 » Fri Jun 03, 2011 5:50 am

lartomar2002 wrote:
SharkHunter wrote:extras/channels will not work on windows. It must be extras\channels. Have you tried browsing? Or simply open the PMS.conf file and then find the line "channels.path" and set it to "extras\\channels". Note the double \, don't ask windows is weird. (you should use one \ in th GUI but two \\ in the conf file cool ha?)

I have tried every thing here is the PMS>conf file. I had to c&p because windows would not let me zip it.

Code: Select all
cred.path = C:\\ProgramData\\PMS-SHB\\PMS.cred
thumbnails = true
alternativeffmpegpath = C:\\Program Files (x86)\\PS3MediaServer-SHB\

\win32\\dvrms\\ffmpeg_MPGMUX.exe
engines =

mencoder,tsmuxer,mplayeraudio,ffmpegaudio,tsmuxeraudio,vlcvideo,mencoder

webvideo,mplayervideodump,mplayerwebaudio,vlcaudio,ffmpegdvrmsremux,rawt

humbs,pmsencoder
channels.path = C:\\Program Files (x86)\\PS3MediaServer-SHB\\extras\

\channels
pmsencoder.script.directory = C:\\Program Files (x86)\\PS3MediaServer-

SHB\\scripts
cookie.path = C:\\Program Files (x86)\\PS3MediaServer-SHB\\channels\

\data\\cookies
channels.debug = true
channels.subtitles = true
mencoder_ass = true
maximumbitrate = 14
mencoder_encode = keyint=25:vqmax=5:vqmin=2
folders = C:\\Users\\lartomar2002\\Videos,C:\\Users\\lartomar2002\

\Music,C:\\Users\\lartomar2002\\Pictures
channels.save = C:\\Program Files (x86)\\PS3MediaServer-SHB\\Channels

Save Path
sopcast.path = C:\\Users\\lartomar2002\\Documents\\SOP Cast Path
pplive.path = C:\\Users\\lartomar2002\\Documents\\PPLive path
get-flash-videos.path = C:\\Program Files (x86)\\PS3MediaServer-SHB\

\scripts
youtube-dl.path = C:\\Program Files (x86)\\PS3MediaServer-SHB\\scripts


I went into PMS.conf and changed the channels path to all \\ as you can see. i also went through the channels plugin options and changed the channel path to C:\Program Files (x86)\PS3MediaServer-SHB\extras\channels. I then quit PMS and restart it and check the channel path and it has reverted back to: C:\Program Files (x86)\PS3MediaServer-SHB\channels.
I am calling it a night for now I will see you later. Thanks
Oh, by the way I did save the PMS.conf. after the changes

Hi again, I uninstall PMS-SHB and reinstalled. went in the channels plugin made your suggested changes then saved it closed and restared it and everything apppeared ok. went to ps3 and saw all the channels. I could not get navi-x to work, ps3 would only go so deep or if i did find a video i would get "corrupt data" error. this was the same with icefilms and yahoo. i was able to get some of the tv programs and videos to play and some did not but did not test them all.
i am sending you the channel log and the debug log. also, is there a way i can sign into megavideo because i have premium account. do i need to with icefilm (perhaps they just compare ip addresses)? i know on my wdltv live (with b-rad hack) i did not have to.
Attachments
debug (2).zip
(7.11 KiB) Downloaded 42 times
channel (2).zip
(3.13 KiB) Downloaded 66 times
Nothing left in my right brain, Nothing right in my left brain!
User avatar
lartomar2002
 
Posts: 104
Joined: Thu Jan 27, 2011 12:42 am

Re: SharkHunter Build (Update 11-05-29)

Postby SharkHunter » Fri Jun 03, 2011 7:59 am

This doesn't look good.
Code: Select all
 ERROR 11:24:52.732 Cannot launch MPlayer / Check the presence of win32/mplayer.exe ...
java.lang.IllegalThreadStateException: process has not exited
   at java.lang.ProcessImpl.exitValue(Native Method) ~[na:1.6.0_24]
   at net.pms.PMS.checkProcessExistence(PMS.java:303) [pms.jar:na]
   at net.pms.PMS.init(PMS.java:415) [pms.jar:na]
   at net.pms.PMS.get(PMS.java:1322) [pms.jar:na]
   at net.pms.PMS.main(PMS.java:1408) [pms.jar:na]

Make sure you don't have a mplayer.path in your PMS.conf. Then I think you hit the folder limit depth limit on the PS3 which is 8. Try a short (not so deep path) like site scrapers -> 66 stage and then an early film ther. Also make sure you diable Channels saving since that will use an extra folder Just to present you with the save option.

As for megaupload premium I will make a really long answer somewhere else. But look in the cahnnels thread for some hints. Short answer: Yes it is possible to use megaupload premium.
SharkHunter
 
Posts: 941
Joined: Tue Jun 01, 2010 8:39 pm

Re: SharkHunter Build (Update 11-05-29)

Postby brotherjohn » Fri Jun 03, 2011 11:10 am

Does someone know whether their is a possibility to set a filter for NaviX-sites (e.g. for site scrapers->FilmTrailer) or to customize what I want to see for the channel plugin?
Background of my question: Most of the sites doesn't work for me or I'm not interested in and it takes a lot of time to wait until all folders appear on the XMB of my Bravia TV.
brotherjohn
 
Posts: 146
Joined: Wed Sep 15, 2010 9:13 am

Re: SharkHunter Build (Update 11-05-29)

Postby SharkHunter » Fri Jun 03, 2011 11:26 am

brotherjon we move this discussion to the Channels thread instead.
viewtopic.php?f=12&t=9329&p=51412#p51412
SharkHunter
 
Posts: 941
Joined: Tue Jun 01, 2010 8:39 pm

Re: SharkHunter Build (Update 11-06-03)

Postby SharkHunter » Fri Jun 03, 2011 2:07 pm

Added a new version (SHB8) which move Channels up to 1.19 and add chocolateboy new EDL plugin.
NOTE!!!!

If you are using IceFilms you MUST upgrade Channels one way or the other since versions prior to 1.19 has stopped working. The easiest way is to use SHB8.
SharkHunter
 
Posts: 941
Joined: Tue Jun 01, 2010 8:39 pm

Re: SharkHunter Build (Update 11-06-03)

Postby lastmoexit » Fri Jun 03, 2011 3:59 pm

hello ...not since SHB5 have the Channels worked for me ...there are only 2 folders when selecting (Cache and Recent Searches) ...selecting either of those only yields "There are no titles." ...i'm running WinXP Pro SP3 ...clean install of SHB, too ...not sure what's wrong ...any help would be greatly appreciated
lastmoexit
 
Posts: 29
Joined: Fri May 13, 2011 4:43 am

Re: SharkHunter Build (Update 11-06-03)

Postby SharkHunter » Fri Jun 03, 2011 4:04 pm

Since SHB6/7 the location of your PMS.conf moved and probably the PMS.conf merge process that SHB uses is to "smart". It merges your really old config wich says channels.path=xxxxxx where it should say channels.path=extras\\channels
SharkHunter
 
Posts: 941
Joined: Tue Jun 01, 2010 8:39 pm

Re: SharkHunter Build (Update 11-06-03)

Postby lastmoexit » Fri Jun 03, 2011 4:13 pm

okay, but i deleted the old PMS-SHB folder before clean install ...so, there was not a pms.conf file to merge with ...all values would be default, i assume ...please bear with me ...i am new to all of this

edit: okay, so i changed the channels plugin to v1.11 on SHB8 and still had nothing but cache and recent searches folders ...changed it back to 1.19 and also d/l'ed latest channels.zip and extracted to channels folder ...now all of the channels are there ...not sure what i did exactly since i assume that SHB8 install would have the most recent channels ...sorry for the newb problems ...trying to learn by reading all i can on this forum ...i appreciate your patience ...thanks
Last edited by lastmoexit on Fri Jun 03, 2011 4:34 pm, edited 1 time in total.
lastmoexit
 
Posts: 29
Joined: Fri May 13, 2011 4:43 am

PreviousNext

Return to Beta Builds

Who is online

Users browsing this forum: Bing [Bot] and 4 guests