SharkHunter Build 43 (Update 12-04-29)

Download and discuss official beta builds here

Re: SharkHunter Build (Update 11-05-29)

Postby SharkHunter » Thu Jun 02, 2011 8:23 am

Hmm... You are trying to download the channels via the Channel GUI (which cant find the channel pack this is a bug)
Have you changed the paths (via the channel GUI or in the PMS.conf file)? If you just install SHB out of the box the channels path should be extras\channels while yours is C:\Program Files (x86)\PS3MediaServer-SHB\channels. This dir is probably empty and does not contain any channel files and thus no channel (not NaviX either of course) will show up. Quick fix set the channles path to extras\channels and restart...
SharkHunter
 
Posts: 941
Joined: Tue Jun 01, 2010 8:39 pm

Re: SharkHunter Build (Update 11-05-29)

Postby lartomar2002 » Thu Jun 02, 2011 9:18 am

Every time I change the channel path to ...extras/channel and quit the server and restart it the path reverts back to: C:\Program Files (x86)\PS3MediaServer-SHB\channels. I did this in the channel plugin options.Any suggestions?
Nothing left in my right brain, Nothing right in my left brain!
User avatar
lartomar2002
 
Posts: 104
Joined: Thu Jan 27, 2011 12:42 am

Re: SharkHunter Build (Update 11-05-29)

Postby SharkHunter » Thu Jun 02, 2011 9:26 am

extras/channels will not work on windows. It must be extras\channels. Have you tried browsing? Or simply open the PMS.conf file and then find the line "channels.path" and set it to "extras\\channels". Note the double \, don't ask windows is weird. (you should use one \ in th GUI but two \\ in the conf file cool ha?)
SharkHunter
 
Posts: 941
Joined: Tue Jun 01, 2010 8:39 pm

Re: SharkHunter Build (Update 11-05-29)

Postby lartomar2002 » Thu Jun 02, 2011 9:54 am

SharkHunter wrote:extras/channels will not work on windows. It must be extras\channels. Have you tried browsing? Or simply open the PMS.conf file and then find the line "channels.path" and set it to "extras\\channels". Note the double \, don't ask windows is weird. (you should use one \ in th GUI but two \\ in the conf file cool ha?)

I have tried every thing here is the PMS>conf file. I had to c&p because windows would not let me zip it.

Code: Select all
cred.path = C:\\ProgramData\\PMS-SHB\\PMS.cred
thumbnails = true
alternativeffmpegpath = C:\\Program Files (x86)\\PS3MediaServer-SHB\

\win32\\dvrms\\ffmpeg_MPGMUX.exe
engines =

mencoder,tsmuxer,mplayeraudio,ffmpegaudio,tsmuxeraudio,vlcvideo,mencoder

webvideo,mplayervideodump,mplayerwebaudio,vlcaudio,ffmpegdvrmsremux,rawt

humbs,pmsencoder
channels.path = C:\\Program Files (x86)\\PS3MediaServer-SHB\\extras\

\channels
pmsencoder.script.directory = C:\\Program Files (x86)\\PS3MediaServer-

SHB\\scripts
cookie.path = C:\\Program Files (x86)\\PS3MediaServer-SHB\\channels\

\data\\cookies
channels.debug = true
channels.subtitles = true
mencoder_ass = true
maximumbitrate = 14
mencoder_encode = keyint=25:vqmax=5:vqmin=2
folders = C:\\Users\\lartomar2002\\Videos,C:\\Users\\lartomar2002\

\Music,C:\\Users\\lartomar2002\\Pictures
channels.save = C:\\Program Files (x86)\\PS3MediaServer-SHB\\Channels

Save Path
sopcast.path = C:\\Users\\lartomar2002\\Documents\\SOP Cast Path
pplive.path = C:\\Users\\lartomar2002\\Documents\\PPLive path
get-flash-videos.path = C:\\Program Files (x86)\\PS3MediaServer-SHB\

\scripts
youtube-dl.path = C:\\Program Files (x86)\\PS3MediaServer-SHB\\scripts


I went into PMS.conf and changed the channels path to all \\ as you can see. i also went through the channels plugin options and changed the channel path to C:\Program Files (x86)\PS3MediaServer-SHB\extras\channels. I then quit PMS and restart it and check the channel path and it has reverted back to: C:\Program Files (x86)\PS3MediaServer-SHB\channels.
I am calling it a night for now I will see you later. Thanks
Oh, by the way I did save the PMS.conf. after the changes
Nothing left in my right brain, Nothing right in my left brain!
User avatar
lartomar2002
 
Posts: 104
Joined: Thu Jan 27, 2011 12:42 am

Re: SharkHunter Build (Update 11-05-29)

Postby brotherjohn » Thu Jun 02, 2011 11:05 am

I've had similiar problems. I solved it under Windows with the following workaround:
1. Deinstall every PMS build.
2. Delete every existing PMS-folder (PMS or PMS-SHB) under the user profile directories in Windows (e.g. C:\documents and settings\all users)
3. Delete PS3MediaServer folder(s) under C:\program files
4. Restart Windows
5. Do a fresh installation of the newest SHB 7
6. Rename the PMS.conf.new file located in C:\Documents and settings\All Users\PMS-SHB in PMS.conf
7. Start PMS-SHB and Update Channel under "General settings"
brotherjohn
 
Posts: 146
Joined: Wed Sep 15, 2010 9:13 am

Re: SharkHunter Build (Update 11-05-29)

Postby brotherjohn » Thu Jun 02, 2011 11:12 am

I want to watch Filtrailer.com from Germany under NaviX-->Site scraper and it doesn't work. I added my credentials in PMS.cred with "channel.navix=..." and
"channels.navix=..." but it doesn't help. Do I need these credentials?

Attached see my log-files. Could someone please help.
Attachments
pms_dbg.zip
(59.59 KiB) Downloaded 41 times
brotherjohn
 
Posts: 146
Joined: Wed Sep 15, 2010 9:13 am

Re: SharkHunter Build (Update 11-05-29)

Postby SharkHunter » Thu Jun 02, 2011 12:22 pm

lartomar2002 - weird this shouldn't happen I'll look into later.

brotherjohn - seems to be an error on teh NaviX part. The processor for filmtrailer just return "error" instead of a script and thus it is impossible to get hold of the urls. Other NaviX sites sems to work. Adding a NaviX credentials will not help you here.
SharkHunter
 
Posts: 941
Joined: Tue Jun 01, 2010 8:39 pm

Re: SharkHunter Build (Update 11-05-29)

Postby chocolateboy » Thu Jun 02, 2011 12:32 pm

chocolateboy
Project Member
 
Posts: 2577
Joined: Wed Sep 16, 2009 10:05 am

Re: SharkHunter Build (Update 11-05-29)

Postby SharkHunter » Thu Jun 02, 2011 12:37 pm

There is a processor statement in the playlist:
http://navix.turner3d.net/proc/filmtrailer
which yields error. Maybe there is some fishy stuff going on here I'll check the NIPL code again...
SharkHunter
 
Posts: 941
Joined: Tue Jun 01, 2010 8:39 pm

Re: SharkHunter Build (Update 11-05-29)

Postby chocolateboy » Thu Jun 02, 2011 12:41 pm

Only if called with no arguments. Works for me if the URL is supplied:

http://navix.turner3d.net/proc/filmtrai ... ailer.html
http://navix.turner3d.net/proc/filmtrai ... lip_type=2

&c.
chocolateboy
Project Member
 
Posts: 2577
Joined: Wed Sep 16, 2009 10:05 am

PreviousNext

Return to Beta Builds

Who is online

Users browsing this forum: No registered users and 2 guests