Channel plugin (Updated 12-06-23)

Discuss third-party additions, plugins and translations for PS3 Media Server

Re: Channel plugin (Updated 12-06-23)

Postby Kempo » Mon Aug 20, 2012 3:26 pm

To add to the people above, I've been using PS3 Media Server for around 6 months, tried using Channel over the weekend and I'm having the same problem with "This content cannot be played".

I currently have two installs, my standard "latest PS3 Media Server install" that I use for my .mkvs along with the SHBuild43, both with individual .conf files, and both give me the same error. The web.conf added the web.video folder and the streams in there (Apple Trailers and Giant Bomb videos, for instance) work absolutely fine, however nothing in the "channels" folder will stream (I'm particularly trying to get the two RTMP folders and the myp2p folder to work, I can see the dontent in the folders but they always give the same error).

I've set the rtmpdump.path to the .exe in the root of my C: drive, the SopCast path to the .exe in Program Files, everything I can think of is pointing at the right places, and tried all of the fixes I've been able to find in the thread.

Any more ideas?
Kempo
 
Posts: 1
Joined: Mon Aug 20, 2012 3:09 pm

Re: Channel plugin (Updated 12-06-23)

Postby Lund » Mon Aug 20, 2012 6:17 pm

Hi there.

I'm really new at this so please bear with me. I'm trying to get the Channel plugin to work with my PS3 but seem to be having problems. I've downloaded the latest Sharkhunter Build (SHB43) and have installed this but when I try to watch videos (eg on WatchSeries) using the Channels, there are no video files in the folder. I have tried other channels and cannot seem to play anything! If someone could help me find out how to fix this or point me in the direction of a detailed step-by-step guide on how to install the plugin from scratch, I would be very greatful :) .

Cheers

PS I've looked at the installation instructions on Github but it hasn't helped me solve anything
Lund
 
Posts: 2
Joined: Mon Aug 20, 2012 6:03 pm

Re: Channel plugin (Updated 12-06-23)

Postby Lund » Fri Aug 24, 2012 8:09 pm

Could someone please help me with the above problem ^^^
Lund
 
Posts: 2
Joined: Mon Aug 20, 2012 6:03 pm

Re: Channel plugin (Updated 12-06-23)

Postby seaman » Sun Aug 26, 2012 6:35 pm

Lund wrote:... there are no video files in the folder...

I have the same problem. There are no files in folders or cannot be played...
seaman
 
Posts: 1
Joined: Sun Aug 26, 2012 10:59 am

Noob trying to get Channels working

Postby billymild » Sun Aug 26, 2012 10:38 pm

https://github.com/SharkHunter/Channel/wiki

I have followed this install guide and upgrade the tv_plug to 1.9.1 as well as the PMS_Encoder 1.6.1. It appears that I can see the channels and navigate down the menus, but sometimes it won't show any files in the folder. Or as I am navigating down the folders it won't go any further. This is happening on 1channel.ch. I have updated the .ch file and it didn't make much of a difference.

Any ideas or maybe a good tutorial would help me.
billymild
 
Posts: 2
Joined: Sun Aug 26, 2012 10:16 pm

Re: Channel plugin (Updated 12-06-23)

Postby schwiz » Tue Sep 04, 2012 12:07 am

I can't get this working on linix, I am guessing its because I have no idea where to put all the scripts at. I get this error when I launch mediaserver

INFO 2012-09-03 17:59:15.720 [main] Searching for plugins in /usr/lib/ps3mediaserver/plugins
INFO 2012-09-03 17:59:15.724 [main] Found plugin: com.sharkhunter.channel.CH_plugin
INFO 2012-09-03 17:59:15.734 [main] Registering transcoding engine: FFmpeg Audio
INFO 2012-09-03 17:59:15.737 [main] Registering transcoding engine: MEncoder
INFO 2012-09-03 17:59:15.737 [main] Registering transcoding engine: FFmpeg
INFO 2012-09-03 17:59:15.738 [main] Registering transcoding engine: MPlayer Audio
INFO 2012-09-03 17:59:15.738 [main] Registering transcoding engine: MEncoder Web
INFO 2012-09-03 17:59:15.738 [main] Registering transcoding engine: MPlayer Video Dump
INFO 2012-09-03 17:59:15.739 [main] Registering transcoding engine: MPlayer Web
INFO 2012-09-03 17:59:15.740 [main] Registering transcoding engine: tsMuxeR
INFO 2012-09-03 17:59:15.740 [main] Registering transcoding engine: Audio High Fidelity
INFO 2012-09-03 17:59:15.741 [main] Registering transcoding engine: VLC Audio Streaming
INFO 2012-09-03 17:59:15.741 [main] Registering transcoding engine: VLC Video Streaming
INFO 2012-09-03 17:59:15.742 [main] Registering transcoding engine: dcraw Thumbnailer
INFO 2012-09-03 17:59:15.805 [main] Start channel 1.42
INFO 2012-09-03 17:59:15.819 [main] parsing channel file /usr/lib/ps3mediaserver/plugins/sharkhunter/channels/common.ch version 0.2
INFO 2012-09-03 17:59:15.822 [main] parsing channel file /usr/lib/ps3mediaserver/plugins/sharkhunter/channels/veetles.ch version 0.1
INFO 2012-09-03 17:59:15.822 [main] parsing channel file /usr/lib/ps3mediaserver/plugins/sharkhunter/channels/ur.ch version 0.11
INFO 2012-09-03 17:59:15.823 [main] Configuration error: children
schwiz
 
Posts: 2
Joined: Tue Sep 04, 2012 12:03 am

Re: Channel plugin (Updated 12-06-23)

Postby thecrazyfarang » Tue Sep 04, 2012 5:49 pm

I'm having the same problems as above. I have the latest sharky version, I'm able to view the folders and the channels in the web folder however I'm unable to stream anything as I get the error "this content cannot be played". I have the latest pmsencoder. Below is part of the log file of the errors I'm getting:


INFO 2012-09-04 18:20:29.767 [New I/O server worker #1-8] Starting transcode/remux of Fab 3 Mosa Mosa
INFO 2012-09-04 18:20:42.861 [cmd.exe] Process cmd.exe has a return code of 255! Maybe an error occured... check the log file
INFO 2012-09-04 18:20:47.635 [Thread-29] renderer: 192.168.0.130, file: http://www.youtube.com/watch?v=sKp3tRLL ... tube_gdata
INFO 2012-09-04 18:20:51.646 [Thread-31] renderer: 192.168.0.130, file: http://www.youtube.com/watch?v=sKp3tRLL ... tube_gdata
INFO 2012-09-04 18:21:03.026 [New I/O server worker #1-5] Starting transcode/remux of How to Copy Shirts on Roblox
INFO 2012-09-04 18:21:08.082 [cmd.exe] Process cmd.exe has a return code of 255! Maybe an error occured... check the log file
INFO 2012-09-04 18:21:12.975 [Thread-38] renderer: 192.168.0.130, file: http://www.youtube.com/watch?v=rcxZXSrl ... tube_gdata
INFO 2012-09-04 18:21:16.980 [Thread-40] renderer: 192.168.0.130, file: http://www.youtube.com/watch?v=rcxZXSrl ... tube_gdata
INFO 2012-09-04 18:21:36.666 [New I/O server worker #1-7] Starting transcode/remux of The Pirates! Band of Misfits - LittleBigPlanet DLC
INFO 2012-09-04 18:21:43.917 [cmd.exe] Process cmd.exe has a return code of 255! Maybe an error occured... check the log file
INFO 2012-09-04 18:21:48.788 [Thread-47] renderer: 192.168.0.130, file: http://www.youtube.com/watch?v=RetBbvBg ... tube_gdata
INFO 2012-09-04 18:21:52.793 [Thread-49] renderer: 192.168.0.130, file: http://www.youtube.com/watch?v=RetBbvBg ... tube_gdata
ERROR 2012-09-04 18:22:00.133 [pool-53-thread-1] Error in parsing stream: http://www.gametrailers.com/rssgenerate ... =&favplats[ps3]=ps3&vidformat[wmv]=on&quality[either]=on&orderby=newest&limit=100
com.sun.syndication.io.ParsingFeedException: Invalid XML: Error on line 80: The element type "meta" must be terminated by the matching end-tag "</meta>".
at com.sun.syndication.io.WireFeedInput.build(WireFeedInput.java:198) ~[pms.jar:na]
at com.sun.syndication.io.SyndFeedInput.build(SyndFeedInput.java:123) ~[pms.jar:na]
at net.pms.dlna.Feed.parse(Feed.java:114) ~[pms.jar:na]
at net.pms.dlna.Feed.resolve(Feed.java:97) ~[pms.jar:na]
at net.pms.dlna.DLNAResource.run(DLNAResource.java:778) [pms.jar:na]
at java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source) [na:1.7.0_04]
at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source) [na:1.7.0_04]
at java.lang.Thread.run(Unknown Source) [na:1.7.0_04]
Caused by: org.jdom.input.JDOMParseException: Error on line 80: The element type "meta" must be terminated by the matching end-tag "</meta>".
at org.jdom.input.SAXBuilder.build(SAXBuilder.java:468) ~[pms.jar:na]
at org.jdom.input.SAXBuilder.build(SAXBuilder.java:851) ~[pms.jar:na]
at com.sun.syndication.io.WireFeedInput.build(WireFeedInput.java:194) ~[pms.jar:na]
... 7 common frames omitted
thecrazyfarang
 
Posts: 5
Joined: Tue May 15, 2012 11:54 am

Re: Channel plugin (Updated 12-06-23)

Postby SharkHunter » Tue Oct 16, 2012 7:09 am

Hi all,

Seems I missed some action here. I've been busy adding new features to channels.
Last edited by chocolateboy on Tue Oct 16, 2012 7:18 am, edited 1 time in total.
Reason: Please keep posts on-topic
SharkHunter
 
Posts: 941
Joined: Tue Jun 01, 2010 8:39 pm

SVTPLAY program error

Postby mattley » Tue Oct 23, 2012 9:39 pm

Hello,

I have 2 problems with the newer builds (have tried r40-r43, they all show the same defects).

1. Svtplay folder doesnt show any programs at all. I can go thru the upper menus A-Z but inside theres nothing but an add to favorites folder.

2. The woman im living with wanted to watch project runway sverige (TV3play), this doesnt seem to work, it starts and then stops after a second, not even getting a picture, just black screen, i see the play button in the corner, then after a second it changes to pause and nothing happens after this.

I can watch several other programs from TV3 but not project runway sverige. I also tried URplay and that works fine. i havent seen any posts about this on the forum but if i missed one about this, im sorry for cluttering up the forums.
mattley
 
Posts: 5
Joined: Tue Oct 23, 2012 9:31 pm

Re: SVTPLAY program error

Postby meskibob » Tue Oct 23, 2012 9:41 pm

This a forum for the program PS3 Media Server. I'm not sure what you're talking about.
Thread locked.
I provide NO application support via PM or email, so please post your question to the forum per the Forum Rules.
meskibob
Moderator
 
Posts: 4761
Joined: Mon Jan 19, 2009 4:11 pm

PreviousNext

Return to Additions and Plugins

Who is online

Users browsing this forum: Bing [Bot], Google [Bot] and 5 guests