Channel plugin (Updated 12-06-23)

Discuss third-party additions, plugins and translations for PS3 Media Server

Re: SharkHunter Build (Update 11-06-03)

Postby lartomar2002 » Fri Jun 03, 2011 10:56 pm

Hi SharkHunter, i am still having the same problems with some of the channels . I did as you said and removed mplayer. about the channel saves, as long as i have deleted it in pms conf and in the channels gui i'm ok but, when i restart pms the path shows back up again but i delete on the gui and i recheck the pms conf and it has not re-populated there. with navi-x i am getting "no titles" and with icefilms i am getting "corrupt data". youtube takes a long time to load. i am sending you the new pms cofig, debug and i am including the trace logs, maybe you can see something in there. i see where you have made a new channels jar, can i get it my using the update in the channels gui or do i have to down load it and then put it in the plugins folder?
Attachments
PMS.conf.zip
(606 Bytes) Downloaded 71 times
PMS Trace Log.zip
(20.01 KiB) Downloaded 48 times
channel.zip
(3.13 KiB) Downloaded 76 times
Nothing left in my right brain, Nothing right in my left brain!
User avatar
lartomar2002
 
Posts: 104
Joined: Thu Jan 27, 2011 12:42 am

Re: Channel plugin (Updated 11-06-03)

Postby lastmoexit » Fri Jun 03, 2011 11:14 pm

okay ...i have the latest PS3 firmware - 3.61 ...running WinXP Pro SP3 ...when i installed the SHB8 (clean install - no trace of pms on my comp) only two folders would show up under Channels ...Cache and Recent Searches ...if i select either folder, it says, "There are no titles." ...so, i downgraded the tv_plug.jar to v1.11 and still the same two folders ...changed it back to 1.19 and also d/l'ed latest channels.zip and extracted to channels folder ...then all of the channels were there ...so, i again scrubbed my system of all traces of pms ...then began installing each version, one on top of the other, of SHB starting with 3 and testing the result ...would see the channels but all vids would return "The data is corrupted." ...then upon installing SHB6 i once again only had the Cache and Recent Searches folders with no titles ...as it stands right now, i have uninstalled and removed any traces of pms from my system ...i can attach logs, but do i need to install SHB8 and try to play some vids so that the logs will contain the errors? ...and, also, should i update it with the latest channels.zip (which i assumed was in the latest build) so that i can see more than just the Cache and Recent Searches folders? ...or do you want me to just install and then attach the logs w/o attempting to view anything? ...thanks for your patience and help

edit: just now installed SHB8 and noticed that the channels folder in the install dir is empty except for an empty data folder and the file channel.log ...also noticed that under extras folder there is a channels folder with all channels inside ...did it install in the wrong place?
lastmoexit
 
Posts: 29
Joined: Fri May 13, 2011 4:43 am

Re: Channel plugin (Updated 11-06-03)

Postby saleopardi » Sat Jun 04, 2011 4:37 am

SharkHunter - thanks a lot for the help! now the nipl script works :) will post the cuevana.tv channel shortly.
saleopardi
 
Posts: 94
Joined: Sat Mar 19, 2011 7:59 am

Re: Channel plugin (Updated 11-06-03)

Postby saleopardi » Sat Jun 04, 2011 7:44 am

I think there might be an issue with nipl script implementation. if a channel has a nipl script, in the pms logs you see that the whole process for the url received from the channel is repeated three times. either if there is a groovy involved (in which case the whole groovy is called three times) or not.
any reason for this? or maybe is it something wrong with my config?
saleopardi
 
Posts: 94
Joined: Sat Mar 19, 2011 7:59 am

Re: Channel plugin (Updated 11-06-03)

Postby SharkHunter » Sat Jun 04, 2011 9:38 am

lastmoexit - the more you log the better. As for chanels and extras\channels the empty channels dir is an old relic. It will be gone soon. Everything should end up in extras\channels. FromSHB6 we switched folder structure so from there on stuff is different. SHB8 should work on a clean computer otherwise it's a bug and I need to fix this.

lartomar2002 - Your logs indicate you're using channel 1.16 and since IceFilms has changed thier structure (or whatever you wish to call it) you must use 1.19 other wise you'll see nothing there. Since 1.18 a bug in NaviX handling was fixed so pls first try with 1.19

saleopardi - I've seen that to. I think it is PMS (or the render) that is a bit unpatience. It wants its data and it wan't it now! But it works in the end so no need to bother about the extra script running. I'll see if I can optimize it...
SharkHunter
 
Posts: 941
Joined: Tue Jun 01, 2010 8:39 pm

Re: Channel plugin (Updated 11-06-03)

Postby saleopardi » Sat Jun 04, 2011 6:33 pm

New channel: CUEVANA
Cuevana.tv is a movie and tv series site with subtitles in spanish. the advantage over normal subtitles, is that they are always 100% both for movies and TV series.
still have two main issues with it:
1-using the nipl script, the groovy is called twice..so I would get 2 culr and mencoder process. to solve this (temporally) the groovy script kills any open mencoder.exe when it starts
2-Some movies have a different fps and for this reason they don't play :( don't know how to fix this... I guess this is due to movies in 23 fps...but...
(this happens specially in the best rated (mejor puntadas) part

Cuevana_v1.rar
(3.14 KiB) Downloaded 98 times
saleopardi
 
Posts: 94
Joined: Sat Mar 19, 2011 7:59 am

Re: SharkHunter Build (Update 11-06-03)

Postby chocolateboy » Sat Jun 04, 2011 7:50 pm

lartomar2002 wrote:youtube takes a long time to load.


saleopardi wrote:the groovy is called twice.


Try disabling HTTP Engine V2.
chocolateboy
Project Member
 
Posts: 2580
Joined: Wed Sep 16, 2009 10:05 am

Re: Channel plugin (Updated 11-06-03)

Postby lastmoexit » Sun Jun 05, 2011 12:29 am

SharkHunter wrote:the empty channels dir is an old relic. It will be gone soon. Everything should end up in extras\channels. FromSHB6 we switched folder structure so from there on stuff is different. SHB8 should work on a clean computer otherwise it's a bug and I need to fix this.


in order to see any channels on the PS3 i had to extract channels.zip to the empty channels dir ...all ch files are in the extras/channels dir, but with a clean install and the empty channels dir no channels show up ...to test this i emptied the channels dir and upon starting pms there are only 2 folders listed under Channels (Cache and Recent Searches) ...i also updated icefilms.ch with the latest file found here ...all but icefilms seems to work with the ch files in the channels dir whether the extras/channels dir has ch files or not ...i'm still browsing all different parts to log as much as possible before submitting my logs ...so, from my end it looks like it might be a bug as you mentioned ...thanks for helping me with this

btw, Grooveshark has never worked for me, but Web: Music does
lastmoexit
 
Posts: 29
Joined: Fri May 13, 2011 4:43 am

Re: Channel plugin (Updated 11-06-03)

Postby voxhel » Sun Jun 05, 2011 4:56 pm

Hi!

I would love to have as a channel Vimeo http://vimeo.com/

any chance that we get a new channel! :)

Regards
Vox
voxhel
 
Posts: 1
Joined: Sat Jan 15, 2011 3:08 pm

Re: Channel plugin (Updated 11-06-03)

Postby SharkHunter » Sun Jun 05, 2011 5:13 pm

voxhel - vimeo is supported by NaviX. No site scraper exist but create an account on NaviX and start making a playlist.

lastmoexit - I'll make an update of SHB soon. There are some crappy programmers who don't know if it should be called channels or channel, subtitle or subtiles etc.
SharkHunter
 
Posts: 941
Joined: Tue Jun 01, 2010 8:39 pm

PreviousNext

Return to Additions and Plugins

Who is online

Users browsing this forum: No registered users and 5 guests