problems with pms 1.30.1 and Channels.

Discuss third-party additions, plugins and translations for PS3 Media Server

problems with pms 1.30.1 and Channels.

Postby juan » Thu Sep 01, 2011 4:52 am

Hi,
it is my first post and I usually can debug all the problems myself. This seems like an easy problem to solve, but for some reason, it is eluding me so far.
I had pms 1.20 running with channels and no problem. I updated to pms 1.30 and/or pms 1.40 and suddenly i get this error.
[main] INFO 20:27:18.061 Loading plugins from /home/juan/bin/pms/pms-linux-1.30.1/plugins
[main] INFO 20:27:18.064 Found plugin: com.sharkhunter.channel.CH_plugin
[main] INFO 20:27:18.075 Start channel 1.26
[main] INFO 20:27:18.081 parsing channel file /home/juan/bin/pms/pms-linux-1.30.1/channels/channels/nzb.ch version 0.1
[main] INFO 20:27:18.096 Exception in thread "main" java.lang.NoClassDefFoundError: net/pms/movieinfo/MovieInfoVirtualFolder
[main] INFO 20:27:18.098 at java.lang.ClassLoader.defineClass1(Native Method)
[main] INFO 20:27:18.098 at java.lang.ClassLoader.defineClass(ClassLoader.java:634)
[main] INFO 20:27:18.098 at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:142)
[main] INFO 20:27:18.099 at java.net.URLClassLoader.defineClass(URLClassLoader.java:277)
[main] INFO 20:27:18.099 at java.net.URLClassLoader.access$000(URLClassLoader.java:73)
[main] INFO 20:27:18.100 at java.net.URLClassLoader$1.run(URLClassLoader.java:212)

It seems to be a classpath problem and I have been trying to fix it bit no cigar. Can someone point me to how I can solve this seemingly easy problem so I can continue enjoying the channels plugin.

I have set up all the variables in PMS.CON correctly and in Linux this file moved from the regular place to /home/.config/PMS, so I have correctly made all those changes.

Thanks so much for your help

Juan
juan
 
Posts: 3
Joined: Thu Sep 01, 2011 4:43 am

Re: problems with pms 1.30.1 and Channels.

Postby SharkHunter » Thu Sep 01, 2011 8:30 am

I thought I fixed this a long time ago, but maybe it got lost some how. A quick fix is to download the movieinfo.jar (https://github.com/SharkHunter/MovieInfo/downloads). If you don't want movieinfo on you can disable it via the GUI or the PMS.conf (set channels.movieinfo=false)
SharkHunter
 
Posts: 941
Joined: Tue Jun 01, 2010 8:39 pm

Re: problems with pms 1.30.1 and Channels.

Postby juan » Thu Sep 01, 2011 4:27 pm

Thanks. Do I place this jar in the base directory or in the channels directory?
Thanks again,
Juan
juan
 
Posts: 3
Joined: Thu Sep 01, 2011 4:43 am

Re: problems with pms 1.30.1 and Channels.

Postby juan » Thu Sep 01, 2011 4:31 pm

It works !! I figured it out. It goes on the plugins directory. Thanks so much.

Juan
juan
 
Posts: 3
Joined: Thu Sep 01, 2011 4:43 am


Return to Additions and Plugins

Who is online

Users browsing this forum: Bing [Bot] and 4 guests